summaryrefslogtreecommitdiff
path: root/sys-fs/mac-fdisk/mac-fdisk-0.1_p16.ebuild
diff options
context:
space:
mode:
authorAndrew Wilcox <AWilcox@Wilcox-Tech.com>2016-01-24 03:43:33 -0600
committerAndrew Wilcox <AWilcox@Wilcox-Tech.com>2016-01-24 03:43:33 -0600
commit897095052aabbe5e1173489e2e2e95ab7fc8b1f9 (patch)
tree018df398ac28a65df4a1f98d14f9339c51898d6f /sys-fs/mac-fdisk/mac-fdisk-0.1_p16.ebuild
parentce08c4a8bed21dd61229556b105dc1d4c779d607 (diff)
downloadpackages-897095052aabbe5e1173489e2e2e95ab7fc8b1f9.tar.gz
packages-897095052aabbe5e1173489e2e2e95ab7fc8b1f9.tar.bz2
packages-897095052aabbe5e1173489e2e2e95ab7fc8b1f9.tar.xz
packages-897095052aabbe5e1173489e2e2e95ab7fc8b1f9.zip
sys-fs/mac-fdisk: Apple *smh*
Diffstat (limited to 'sys-fs/mac-fdisk/mac-fdisk-0.1_p16.ebuild')
-rw-r--r--sys-fs/mac-fdisk/mac-fdisk-0.1_p16.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-fs/mac-fdisk/mac-fdisk-0.1_p16.ebuild b/sys-fs/mac-fdisk/mac-fdisk-0.1_p16.ebuild
new file mode 100644
index 000000000..5794eaa69
--- /dev/null
+++ b/sys-fs/mac-fdisk/mac-fdisk-0.1_p16.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2015-2016 Adélie Linux Team
+# Distributed under the terms of the NCSA License
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Mac/PowerMac disk partitioning utility"
+HOMEPAGE="ftp://ftp.mklinux.apple.com/pub/Other_Tools/"
+SRC_URI="
+ mirror://debian/pool/main/m/mac-fdisk/${PN}_${PV/_p*}.orig.tar.gz
+ mirror://debian/pool/main/m/mac-fdisk/${PN}_${PV/_p*}-${PV/*_p}.diff.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S=${WORKDIR}/${P/_p*}.orig
+
+EPATCH_SOURCES=(
+ "${WORKDIR}"/${PN}_${PV/_p*}-${PV/*_p}.diff
+ "${FILESDIR}"/${PN}-largerthan2gb.patch
+ "${FILESDIR}"/${PN}-0.1-headers.patch
+ # Gentoo bug #142737
+ "${FILESDIR}"/${PN}-0.1_p16-ppc64.patch
+ "${FILESDIR}"/${PN}-amd64.patch
+
+ ### Patch for large (>550GB disks)
+ ### Note that >=2TB disks may not work due to limitations of the Mac
+ ### Partition Table structure, this needs to be investigated
+ "${FILESDIR}"/${PN}-large-disk-support.patch
+ "${FILESDIR}"/${PN}-non-glibc-support.patch
+ )
+
+src_prepare() {
+ epatch
+ epatch_user
+}
+
+src_install() {
+ into /
+ newsbin pdisk mac-fdisk
+ newsbin fdisk pmac-fdisk
+
+ into /usr
+ newman mac-fdisk.8.in mac-fdisk.8
+ newman pmac-fdisk.8.in pmac-fdisk.8
+ dodoc README HISTORY
+}