summaryrefslogtreecommitdiff
path: root/user/aspell-dict-is/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-12-29 21:57:26 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-12-29 21:57:26 +0000
commitc999dc9826ec3ac419865778b19f4ba2e710a50f (patch)
tree928d6c9fd778122d915bccfe71c9e95164523bdc /user/aspell-dict-is/APKBUILD
parentf64e3c9d8907eb4ee3165975ceb1267d4eb40c5c (diff)
parente8ea961cf71d87ff11329a1e2d56b9f7626c1f2c (diff)
downloadpackages-c999dc9826ec3ac419865778b19f4ba2e710a50f.tar.gz
packages-c999dc9826ec3ac419865778b19f4ba2e710a50f.tar.bz2
packages-c999dc9826ec3ac419865778b19f4ba2e710a50f.tar.xz
packages-c999dc9826ec3ac419865778b19f4ba2e710a50f.zip
Merge branch 'aspell' into 'master'
Fix aspell package, add all (official) aspell dictionaries See merge request !128
Diffstat (limited to 'user/aspell-dict-is/APKBUILD')
-rw-r--r--user/aspell-dict-is/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/user/aspell-dict-is/APKBUILD b/user/aspell-dict-is/APKBUILD
new file mode 100644
index 000000000..1bdaab2f5
--- /dev/null
+++ b/user/aspell-dict-is/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=aspell-dict-is
+pkgver=0.51.1.0
+_pkgver=${pkgver%.*}-${pkgver#*.*.*.}
+pkgrel=0
+pkgdesc="Icelandic dictionaries for aspell"
+url="http://aspell.net"
+arch="noarch"
+options="!check" # no tests
+license="GPL-2.0-only"
+depends="aspell"
+makedepends="debianutils-which"
+source="ftp://ftp.gnu.org/gnu/aspell/dict/is/aspell-is-$_pkgver.tar.bz2"
+builddir="$srcdir/aspell-is-$_pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --vars DESTDIR="$pkgdir"
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="b96aeb407c1de700a20ca18bbd9e1bc1a4c086379ef7fbd0467178d11b9ed70e547a81a4659619e7385f89926638cb2a5e807cc701b444a7bf0d246905795bf2 aspell-is-0.51.1-0.tar.bz2"