summaryrefslogtreecommitdiff
path: root/user/aspell-dict-rw/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-12-29 21:57:26 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-12-29 21:57:26 +0000
commitc999dc9826ec3ac419865778b19f4ba2e710a50f (patch)
tree928d6c9fd778122d915bccfe71c9e95164523bdc /user/aspell-dict-rw/APKBUILD
parentf64e3c9d8907eb4ee3165975ceb1267d4eb40c5c (diff)
parente8ea961cf71d87ff11329a1e2d56b9f7626c1f2c (diff)
downloadpackages-c999dc9826ec3ac419865778b19f4ba2e710a50f.tar.gz
packages-c999dc9826ec3ac419865778b19f4ba2e710a50f.tar.bz2
packages-c999dc9826ec3ac419865778b19f4ba2e710a50f.tar.xz
packages-c999dc9826ec3ac419865778b19f4ba2e710a50f.zip
Merge branch 'aspell' into 'master'
Fix aspell package, add all (official) aspell dictionaries See merge request !128
Diffstat (limited to 'user/aspell-dict-rw/APKBUILD')
-rw-r--r--user/aspell-dict-rw/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/user/aspell-dict-rw/APKBUILD b/user/aspell-dict-rw/APKBUILD
new file mode 100644
index 000000000..accb77d6c
--- /dev/null
+++ b/user/aspell-dict-rw/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=aspell-dict-rw
+pkgver=0.50.0
+_pkgver=${pkgver%.*}-${pkgver#*.*.}
+pkgrel=0
+pkgdesc="Kinyarwanda dictionaries for aspell"
+url="http://aspell.net"
+arch="noarch"
+options="!check" # no tests
+license="GPL-2.0-only"
+depends="aspell"
+makedepends="debianutils-which"
+source="ftp://ftp.gnu.org/gnu/aspell/dict/rw/aspell-rw-$_pkgver.tar.bz2"
+builddir="$srcdir/aspell-rw-$_pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --vars DESTDIR="$pkgdir"
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="a987fe90b091c5f8d4c28713ad50ca917d2a8fd120df55bd413e3112913cb7e9e8fdc740994aa881bbfdd9ac38fa5ebe728c9e62e25a0e7cc8eac13c2380c56a aspell-rw-0.50-0.tar.bz2"