summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/abuild/APKBUILD2
-rw-r--r--system/apk-tools/APKBUILD6
-rw-r--r--system/apk-tools/s6-linux-init.patch11
-rw-r--r--system/cxref/APKBUILD4
-rw-r--r--system/dash/APKBUILD2
-rw-r--r--system/file/APKBUILD2
-rw-r--r--system/ncurses/APKBUILD2
-rw-r--r--system/patch/APKBUILD2
-rw-r--r--system/perl-encode-eucjpascii/APKBUILD2
-rw-r--r--system/perl-encode-hanextra/APKBUILD2
-rw-r--r--system/perl-encode-iso2022/APKBUILD2
-rw-r--r--system/perl-encode-jisx0213/APKBUILD2
-rw-r--r--system/perl-http-message/APKBUILD2
-rw-r--r--system/perl-json/APKBUILD2
-rw-r--r--system/perl-mime-charset/APKBUILD2
-rw-r--r--system/perl-pod2-base/APKBUILD2
-rw-r--r--system/perl-sgmls/APKBUILD2
-rw-r--r--system/perl-test-fatal/APKBUILD2
-rw-r--r--system/perl-test-needs/APKBUILD2
-rw-r--r--system/perl-try-tiny/APKBUILD2
-rw-r--r--system/perl-unicode-linebreak/APKBUILD2
-rw-r--r--system/perl-uri/APKBUILD2
-rw-r--r--system/perl/APKBUILD6
-rw-r--r--system/psmisc/APKBUILD8
-rw-r--r--system/python3/APKBUILD2
-rw-r--r--system/rsync/APKBUILD2
-rw-r--r--system/sed/APKBUILD2
-rw-r--r--system/shimmy/APKBUILD2
-rw-r--r--system/sudo/APKBUILD8
-rw-r--r--system/sudo/CVE-2021-3156.patch165
-rw-r--r--system/uucp/APKBUILD4
-rw-r--r--system/vim/APKBUILD4
32 files changed, 221 insertions, 41 deletions
diff --git a/system/abuild/APKBUILD b/system/abuild/APKBUILD
index 1ec934da1..f3c5bef69 100644
--- a/system/abuild/APKBUILD
+++ b/system/abuild/APKBUILD
@@ -3,7 +3,7 @@ pkgname=abuild
pkgver=3.4.2
pkgrel=0
pkgdesc="Script to build APK packages"
-url="https://code.foxkit.us/adelie/abuild"
+url="https://git.adelielinux.org/adelie/abuild"
arch="all"
options="suid !check"
license="GPL-2.0-only"
diff --git a/system/apk-tools/APKBUILD b/system/apk-tools/APKBUILD
index 5f0683e86..d664340e0 100644
--- a/system/apk-tools/APKBUILD
+++ b/system/apk-tools/APKBUILD
@@ -4,7 +4,7 @@ pkgname=apk-tools
pkgver=2.12.0
pkgrel=0
pkgdesc="Alpine Package Keeper - package manager"
-url="https://code.foxkit.us/adelie/apk-tools"
+url="https://git.adelielinux.org/adelie/apk-tools"
arch="all"
license="GPL-2.0-only"
depends="ca-certificates"
@@ -15,6 +15,7 @@ subpackages="$pkgname-dev $pkgname-static $pkgname-doc"
source="https://dev.sick.bike/dist/$pkgname-v$pkgver+adelie.tar.gz
https://dev.sick.bike/dist/$pkgname-help-v$pkgver.tar.gz
apk.zsh-completion
+ s6-linux-init.patch
"
builddir="$srcdir/$pkgname-v$pkgver"
@@ -72,4 +73,5 @@ static() {
sha512sums="739cbf487a9184aba56c87448d18acebf357b6eddb4852033cc0cd331fc910d425a5d01f7b0bf109f5cd62f78f10cca96ebcbdb4fa00d197edb90726998e1523 apk-tools-v2.12.0+adelie.tar.gz
b8e6e6e9efe2fc3a900e5fea54ed2f047bbf8917c8c3e470e001865c2169167ce6a273869ba577aceb1a1580b7dd684de115a4d92250786958fa13b9e8abf28b apk-tools-help-v2.12.0.tar.gz
-cedda9bf11e0a516c9bf0fd1a239ffa345cdd236419cbd8b10273410610ae7d0f0f61fd36e1e9ccc3bbf32f895508cdca4fb57a0e04f78dd88469b33bf64a32a apk.zsh-completion"
+cedda9bf11e0a516c9bf0fd1a239ffa345cdd236419cbd8b10273410610ae7d0f0f61fd36e1e9ccc3bbf32f895508cdca4fb57a0e04f78dd88469b33bf64a32a apk.zsh-completion
+f92e2e0c062b71e1e5cf95f0d4997166ccc7f7a5e45af8d1650f5951a1d552d89217c8c60d24f31fa626e8e0675c5e882e6b36ef1af8f7624e54627b22801381 s6-linux-init.patch"
diff --git a/system/apk-tools/s6-linux-init.patch b/system/apk-tools/s6-linux-init.patch
new file mode 100644
index 000000000..2dc3db924
--- /dev/null
+++ b/system/apk-tools/s6-linux-init.patch
@@ -0,0 +1,11 @@
+The s6-linux-init-common package has a FIFO which breaks with this.
+--- apk-tools-v2.12.0/src/database.c.old 2020-12-30 02:39:04.000000000 +0000
++++ apk-tools-v2.12.0/src/database.c 2021-01-27 01:47:04.680712750 +0000
+@@ -2592,7 +2592,6 @@
+ apk_warning(PKG_VER_FMT": support for packages without embedded "
+ "checksums will be dropped in apk-tools 3.",
+ PKG_VER_PRINTF(pkg));
+- ipkg->broken_files = 1;
+ ctx->missing_checksum = 1;
+ }
+ break;
diff --git a/system/cxref/APKBUILD b/system/cxref/APKBUILD
index f1bc75fb4..c9d05c608 100644
--- a/system/cxref/APKBUILD
+++ b/system/cxref/APKBUILD
@@ -1,5 +1,5 @@
-# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
-# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Contributor: Sheila Aman <sheila@vulpine.house>
+# Maintainer: Sheila Aman <sheila@vulpine.house>
pkgname=cxref
pkgver=1.6e
pkgrel=0
diff --git a/system/dash/APKBUILD b/system/dash/APKBUILD
index acf091602..f2f096ffd 100644
--- a/system/dash/APKBUILD
+++ b/system/dash/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Maintainer: Sheila Aman <sheila@vulpine.house>
pkgname=dash
pkgver=0.5.11.2
pkgrel=0
diff --git a/system/file/APKBUILD b/system/file/APKBUILD
index b2968c3ca..8955ca71c 100644
--- a/system/file/APKBUILD
+++ b/system/file/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Maintainer: Sheila Aman <sheila@vulpine.house>
pkgname=file
pkgver=5.39
pkgrel=0
diff --git a/system/ncurses/APKBUILD b/system/ncurses/APKBUILD
index d2ad46900..e3c114a6d 100644
--- a/system/ncurses/APKBUILD
+++ b/system/ncurses/APKBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Maintainer: Sheila Aman <sheila@vulpine.house>
pkgname=ncurses
pkgver=6.2
_ver=${pkgver}-20200212
diff --git a/system/patch/APKBUILD b/system/patch/APKBUILD
index b299382c9..677dec208 100644
--- a/system/patch/APKBUILD
+++ b/system/patch/APKBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Maintainer: Sheila Aman <sheila@vulpine.house>
pkgname=patch
pkgver=2.7.6
pkgrel=4
diff --git a/system/perl-encode-eucjpascii/APKBUILD b/system/perl-encode-eucjpascii/APKBUILD
index 02ed7b7e3..2e1a0a5cf 100644
--- a/system/perl-encode-eucjpascii/APKBUILD
+++ b/system/perl-encode-eucjpascii/APKBUILD
@@ -1,4 +1,4 @@
-# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-encode-eucjpascii
_pkgreal=Encode-EUCJPASCII
diff --git a/system/perl-encode-hanextra/APKBUILD b/system/perl-encode-hanextra/APKBUILD
index 6d52e5647..5529f338b 100644
--- a/system/perl-encode-hanextra/APKBUILD
+++ b/system/perl-encode-hanextra/APKBUILD
@@ -1,4 +1,4 @@
-# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-encode-hanextra
_pkgreal=Encode-HanExtra
diff --git a/system/perl-encode-iso2022/APKBUILD b/system/perl-encode-iso2022/APKBUILD
index b59b3a5cb..9e41c6a16 100644
--- a/system/perl-encode-iso2022/APKBUILD
+++ b/system/perl-encode-iso2022/APKBUILD
@@ -1,4 +1,4 @@
-# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-encode-iso2022
_pkgreal=Encode-ISO2022
diff --git a/system/perl-encode-jisx0213/APKBUILD b/system/perl-encode-jisx0213/APKBUILD
index 5a956d1aa..809a06b25 100644
--- a/system/perl-encode-jisx0213/APKBUILD
+++ b/system/perl-encode-jisx0213/APKBUILD
@@ -1,4 +1,4 @@
-# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-encode-jisx0213
_pkgreal=Encode-JISX0213
diff --git a/system/perl-http-message/APKBUILD b/system/perl-http-message/APKBUILD
index 839df093e..af9d236cf 100644
--- a/system/perl-http-message/APKBUILD
+++ b/system/perl-http-message/APKBUILD
@@ -1,5 +1,5 @@
# Automatically generated by apkbuild-cpan, template 1
-# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-http-message
_pkgreal=HTTP-Message
diff --git a/system/perl-json/APKBUILD b/system/perl-json/APKBUILD
index e3ce567bb..7b85dc2ca 100644
--- a/system/perl-json/APKBUILD
+++ b/system/perl-json/APKBUILD
@@ -1,4 +1,4 @@
-# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-json
_pkgreal=JSON
diff --git a/system/perl-mime-charset/APKBUILD b/system/perl-mime-charset/APKBUILD
index 4a04e17e9..139766e3a 100644
--- a/system/perl-mime-charset/APKBUILD
+++ b/system/perl-mime-charset/APKBUILD
@@ -1,4 +1,4 @@
-# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-mime-charset
_pkgreal=MIME-Charset
diff --git a/system/perl-pod2-base/APKBUILD b/system/perl-pod2-base/APKBUILD
index 05703bcf6..dc9fd74f0 100644
--- a/system/perl-pod2-base/APKBUILD
+++ b/system/perl-pod2-base/APKBUILD
@@ -1,4 +1,4 @@
-# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-pod2-base
_pkgreal=POD2-Base
diff --git a/system/perl-sgmls/APKBUILD b/system/perl-sgmls/APKBUILD
index e6ceae295..e64291280 100644
--- a/system/perl-sgmls/APKBUILD
+++ b/system/perl-sgmls/APKBUILD
@@ -1,4 +1,4 @@
-# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-sgmls
_pkgreal=SGMLSpm
diff --git a/system/perl-test-fatal/APKBUILD b/system/perl-test-fatal/APKBUILD
index e97893fda..a0b3b1e96 100644
--- a/system/perl-test-fatal/APKBUILD
+++ b/system/perl-test-fatal/APKBUILD
@@ -1,5 +1,5 @@
# Automatically generated by apkbuild-cpan, template 1
-# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-test-fatal
_pkgreal=Test-Fatal
diff --git a/system/perl-test-needs/APKBUILD b/system/perl-test-needs/APKBUILD
index 0d098b55c..f8d644f76 100644
--- a/system/perl-test-needs/APKBUILD
+++ b/system/perl-test-needs/APKBUILD
@@ -1,4 +1,4 @@
-# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-test-needs
_pkgreal=Test-Needs
diff --git a/system/perl-try-tiny/APKBUILD b/system/perl-try-tiny/APKBUILD
index 4078a2f5e..14efc46ce 100644
--- a/system/perl-try-tiny/APKBUILD
+++ b/system/perl-try-tiny/APKBUILD
@@ -1,5 +1,5 @@
# Automatically generated by apkbuild-cpan, template 1
-# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-try-tiny
_pkgreal=Try-Tiny
diff --git a/system/perl-unicode-linebreak/APKBUILD b/system/perl-unicode-linebreak/APKBUILD
index 907b970b3..b14736fc0 100644
--- a/system/perl-unicode-linebreak/APKBUILD
+++ b/system/perl-unicode-linebreak/APKBUILD
@@ -1,4 +1,4 @@
-# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-unicode-linebreak
_pkgreal=Unicode-LineBreak
diff --git a/system/perl-uri/APKBUILD b/system/perl-uri/APKBUILD
index 1f3cbec5c..0c8774c7e 100644
--- a/system/perl-uri/APKBUILD
+++ b/system/perl-uri/APKBUILD
@@ -1,4 +1,4 @@
-# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-uri
_pkgreal=URI
diff --git a/system/perl/APKBUILD b/system/perl/APKBUILD
index 7e23f0a82..40277eb72 100644
--- a/system/perl/APKBUILD
+++ b/system/perl/APKBUILD
@@ -1,11 +1,11 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Contributor: Valery Kartel <valery.kartel@gmail.com>
-# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
# Proxy-For: solar
pkgname=perl
pkgver=5.26.3
-pkgrel=1
+pkgrel=2
pkgdesc="Larry Wall's Practical Extraction and Report Language"
url="https://www.perl.org/"
arch="all"
@@ -41,7 +41,7 @@ prepare() {
default_prepare
sed -e 's/less -R/less/g' \
-e 's/libswanted="\(.*\) nsl\(.*\)"/libswanted="\1\2"/g' \
- -i ./Configure ||
+ -i ./Configure
# Ensure that we never accidentally bundle zlib or bzip2
rm -rf cpan/Compress-Raw-Zlib/zlib-src
diff --git a/system/psmisc/APKBUILD b/system/psmisc/APKBUILD
index 4414d28b9..0f53e5ffa 100644
--- a/system/psmisc/APKBUILD
+++ b/system/psmisc/APKBUILD
@@ -15,15 +15,13 @@ makedepends_build="autoconf>=2.69 automake"
makedepends_host="ncurses-dev"
subpackages="$pkgname-doc"
[ "$CBUILD" != "$CHOST" ] || subpackages="$subpackages $pkgname-lang"
-source="$pkgname-$pkgver.tar.bz2::https://gitlab.com/$pkgname/$pkgname/repository/archive.tar.bz2?ref=v$pkgver
+source="$pkgname-$pkgver.tar.bz2::https://gitlab.com/psmisc/psmisc/-/archive/v$pkgver/psmisc-v$pkgver.tar.bz2
fix-peekfd-on-ppc.patch
"
+builddir="$srcdir/$pkgname-v$pkgver"
prepare() {
- ln -fs $pkgname-v$pkgver-* "$builddir"
-
default_prepare
-
sh autogen.sh
}
@@ -51,5 +49,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="0571aadcd89ecbc89f991a80b02372b3cb881abed97313640bb23905e133473e1c7a51bf8d6c6dbd3d12a013b3aad88d7f94adfcdc3f6f22a53c57e1e0b33016 psmisc-23.3.tar.bz2
+sha512sums="78e8298b4cc2d888159f2689c7957ab5f17c782d6a64642b055a455579d79759a0f62d46e473d9c0dd4e026f4917226b8907afa6178a24a5615194d38b8aed1a psmisc-23.3.tar.bz2
a910611896368a088503f50a04a1c2af00d57ee20f3613e81c79cd89574805a505dff43e356ed833a464e3b59d7c1e11fd52cf0bbf32fcfece4dbd2380f23b71 fix-peekfd-on-ppc.patch"
diff --git a/system/python3/APKBUILD b/system/python3/APKBUILD
index e875d3941..a6d47495b 100644
--- a/system/python3/APKBUILD
+++ b/system/python3/APKBUILD
@@ -1,4 +1,4 @@
-# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=python3
pkgver=3.6.10
diff --git a/system/rsync/APKBUILD b/system/rsync/APKBUILD
index 728a32fbc..f48b55099 100644
--- a/system/rsync/APKBUILD
+++ b/system/rsync/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Maintainer: Sheila Aman <sheila@vulpine.house>
pkgname=rsync
pkgver=3.1.3
pkgrel=2
diff --git a/system/sed/APKBUILD b/system/sed/APKBUILD
index 17f50b841..cb4369afe 100644
--- a/system/sed/APKBUILD
+++ b/system/sed/APKBUILD
@@ -1,5 +1,5 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Maintainer: Sheila Aman <sheila@vulpine.house>
pkgname=sed
pkgver=4.8
pkgrel=0
diff --git a/system/shimmy/APKBUILD b/system/shimmy/APKBUILD
index ab9b55f64..d0d8470d3 100644
--- a/system/shimmy/APKBUILD
+++ b/system/shimmy/APKBUILD
@@ -4,7 +4,7 @@ pkgname=shimmy
pkgver=0.6
pkgrel=0
pkgdesc="Utilities for stricter POSIX conformance"
-url="https://code.foxkit.us/adelie/shimmy"
+url="https://git.adelielinux.org/adelie/shimmy"
arch="all"
options="!check" # No test suite.
license="NCSA"
diff --git a/system/sudo/APKBUILD b/system/sudo/APKBUILD
index 5ad968957..1305a61f3 100644
--- a/system/sudo/APKBUILD
+++ b/system/sudo/APKBUILD
@@ -9,7 +9,7 @@ if [ "${pkgver%_*}" != "$pkgver" ]; then
else
_realver=$pkgver
fi
-pkgrel=1
+pkgrel=2
pkgdesc="Give certain users the ability to run some commands as root"
url="https://www.sudo.ws/sudo/"
arch="all"
@@ -24,6 +24,7 @@ source="https://www.sudo.ws/dist/sudo-${_realver}.tar.gz
fix-cross-compile.patch
musl-fix-headers.patch
SIGUNUSED.patch
+ CVE-2021-3156.patch
"
builddir="$srcdir"/$pkgname-$_realver
somask="audit_json.so
@@ -42,6 +43,8 @@ somask="audit_json.so
# - CVE-2019-14287
# 1.9.0-r0:
# - CVE-2019-19232
+# 1.9.2-r2:
+# - CVE-2021-3156
build() {
./configure \
@@ -84,4 +87,5 @@ package() {
sha512sums="20afdf2604b1c93395157382b24f225cd1ff88d3a892362e2d69fecd240c4e7171f05032c08be1778cd1dea6e460025e4241f57272fac0ea3550e220b6d73d21 sudo-1.9.2.tar.gz
f0f462f40502da2194310fe4a72ec1a16ba40f95a821ba9aa6aabaa423d28c4ab26b684afa7fb81c2407cf60de9327bdab01de51b878c5d4de49b0d62645f53c fix-cross-compile.patch
dcc03abdd672c934f90dfd3683b3f81a8d39cfff91307d2dbd20a31a852022ab605d034c4fe11860ba99b78d391a9812fca1d6e052620b8ff2c42e4f0c7a1a62 musl-fix-headers.patch
-2733c220ccbdaf61a32d8c72a5bc0209673733014f0d71b568f1523b71416e9d1754dd8c95bc6cd99aa7f935ed6e93c5f19b1a1dbb7dfc2daf9917fd37f96e78 SIGUNUSED.patch"
+2733c220ccbdaf61a32d8c72a5bc0209673733014f0d71b568f1523b71416e9d1754dd8c95bc6cd99aa7f935ed6e93c5f19b1a1dbb7dfc2daf9917fd37f96e78 SIGUNUSED.patch
+7ef329edccbbd26ac55ff58d4c6c470bf2d829ff8ad1388d67b6ea8c2c8284fd362209cf11458787efaa4e301106bd3b49b8b7310c9d222ac3a3483a17b3ec0e CVE-2021-3156.patch"
diff --git a/system/sudo/CVE-2021-3156.patch b/system/sudo/CVE-2021-3156.patch
new file mode 100644
index 000000000..7cb492d61
--- /dev/null
+++ b/system/sudo/CVE-2021-3156.patch
@@ -0,0 +1,165 @@
+
+# HG changeset patch
+# User Todd C. Miller <Todd.Miller@sudo.ws>
+# Date 1611416639 25200
+# Node ID 049ad90590be1e5dfb7df2675d2eb3e37c96ab86
+# Parent a97dc92eae6b60ae285055441341d493c17262ff
+Fix potential buffer overflow when unescaping backslashes in user_args.
+Also, do not try to unescaping backslashes unless in run mode *and*
+we are running the command via a shell.
+Found by Qualys, this fixes CVE-2021-3156.
+
+diff -r a97dc92eae6b -r 049ad90590be plugins/sudoers/sudoers.c
+--- a/plugins/sudoers/sudoers.c Sat Jan 23 08:43:59 2021 -0700
++++ b/plugins/sudoers/sudoers.c Sat Jan 23 08:43:59 2021 -0700
+@@ -547,7 +547,7 @@
+
+ /* If run as root with SUDO_USER set, set sudo_user.pw to that user. */
+ /* XXX - causes confusion when root is not listed in sudoers */
+- if (sudo_mode & (MODE_RUN | MODE_EDIT) && prev_user != NULL) {
++ if (ISSET(sudo_mode, MODE_RUN|MODE_EDIT) && prev_user != NULL) {
+ if (user_uid == 0 && strcmp(prev_user, "root") != 0) {
+ struct passwd *pw;
+
+@@ -932,8 +932,8 @@
+ if (user_cmnd == NULL)
+ user_cmnd = NewArgv[0];
+
+- if (sudo_mode & (MODE_RUN | MODE_EDIT | MODE_CHECK)) {
+- if (ISSET(sudo_mode, MODE_RUN | MODE_CHECK)) {
++ if (ISSET(sudo_mode, MODE_RUN|MODE_EDIT|MODE_CHECK)) {
++ if (!ISSET(sudo_mode, MODE_EDIT)) {
+ if (def_secure_path && !user_is_exempt())
+ path = def_secure_path;
+ if (!set_perms(PERM_RUNAS))
+@@ -961,7 +961,8 @@
+ sudo_warnx(U_("%s: %s"), __func__, U_("unable to allocate memory"));
+ debug_return_int(NOT_FOUND_ERROR);
+ }
+- if (ISSET(sudo_mode, MODE_SHELL|MODE_LOGIN_SHELL)) {
++ if (ISSET(sudo_mode, MODE_SHELL|MODE_LOGIN_SHELL) &&
++ ISSET(sudo_mode, MODE_RUN)) {
+ /*
+ * When running a command via a shell, the sudo front-end
+ * escapes potential meta chars. We unescape non-spaces
+@@ -969,10 +970,22 @@
+ */
+ for (to = user_args, av = NewArgv + 1; (from = *av); av++) {
+ while (*from) {
+- if (from[0] == '\\' && !isspace((unsigned char)from[1]))
++ if (from[0] == '\\' && from[1] != '\0' &&
++ !isspace((unsigned char)from[1])) {
+ from++;
++ }
++ if (size - (to - user_args) < 1) {
++ sudo_warnx(U_("internal error, %s overflow"),
++ __func__);
++ debug_return_int(NOT_FOUND_ERROR);
++ }
+ *to++ = *from++;
+ }
++ if (size - (to - user_args) < 1) {
++ sudo_warnx(U_("internal error, %s overflow"),
++ __func__);
++ debug_return_int(NOT_FOUND_ERROR);
++ }
+ *to++ = ' ';
+ }
+ *--to = '\0';
+
+
+# HG changeset patch
+# User Todd C. Miller <Todd.Miller@sudo.ws>
+# Date 1611416639 25200
+# Node ID 9b97f1787804aedccaec63c379053b1a91a0e409
+# Parent 90aba6ba6e03f3bc33b4eabf16358396ed83642d
+Reset valid_flags to MODE_NONINTERACTIVE for sudoedit.
+This is consistent with how the -e option is handled.
+Also reject -H and -P flags for sudoedit as was done in sudo 1.7.
+Found by Qualys, this is part of the fix for CVE-2021-3156.
+
+diff -r 90aba6ba6e03 -r 9b97f1787804 src/parse_args.c
+--- a/src/parse_args.c Mon Jan 18 12:30:52 2021 +0100
++++ b/src/parse_args.c Sat Jan 23 08:43:59 2021 -0700
+@@ -117,7 +117,10 @@
+ /*
+ * Default flags allowed when running a command.
+ */
+-#define DEFAULT_VALID_FLAGS (MODE_BACKGROUND|MODE_PRESERVE_ENV|MODE_RESET_HOME|MODE_LOGIN_SHELL|MODE_NONINTERACTIVE|MODE_SHELL)
++#define DEFAULT_VALID_FLAGS (MODE_BACKGROUND|MODE_PRESERVE_ENV|MODE_RESET_HOME|MODE_LOGIN_SHELL|MODE_NONINTERACTIVE|MODE_PRESERVE_GROUPS|MODE_SHELL)
++#define EDIT_VALID_FLAGS MODE_NONINTERACTIVE
++#define LIST_VALID_FLAGS (MODE_NONINTERACTIVE|MODE_LONG_LIST)
++#define VALIDATE_VALID_FLAGS MODE_NONINTERACTIVE
+
+ /* Option number for the --host long option due to ambiguity of the -h flag. */
+ #define OPT_HOSTNAME 256
+@@ -262,6 +265,7 @@
+ progname = "sudoedit";
+ mode = MODE_EDIT;
+ sudo_settings[ARG_SUDOEDIT].value = "true";
++ valid_flags = EDIT_VALID_FLAGS;
+ }
+
+ /* Load local IP addresses and masks. */
+@@ -365,7 +369,7 @@
+ usage_excl();
+ mode = MODE_EDIT;
+ sudo_settings[ARG_SUDOEDIT].value = "true";
+- valid_flags = MODE_NONINTERACTIVE;
++ valid_flags = EDIT_VALID_FLAGS;
+ break;
+ case 'g':
+ assert(optarg != NULL);
+@@ -377,6 +381,7 @@
+ break;
+ case 'H':
+ sudo_settings[ARG_SET_HOME].value = "true";
++ SET(flags, MODE_RESET_HOME);
+ break;
+ case 'h':
+ if (optarg == NULL) {
+@@ -431,7 +436,7 @@
+ usage_excl();
+ }
+ mode = MODE_LIST;
+- valid_flags = MODE_NONINTERACTIVE|MODE_LONG_LIST;
++ valid_flags = LIST_VALID_FLAGS;
+ break;
+ case 'n':
+ SET(flags, MODE_NONINTERACTIVE);
+@@ -439,6 +444,7 @@
+ break;
+ case 'P':
+ sudo_settings[ARG_PRESERVE_GROUPS].value = "true";
++ SET(flags, MODE_PRESERVE_GROUPS);
+ break;
+ case 'p':
+ /* An empty prompt is allowed. */
+@@ -505,7 +511,7 @@
+ if (mode && mode != MODE_VALIDATE)
+ usage_excl();
+ mode = MODE_VALIDATE;
+- valid_flags = MODE_NONINTERACTIVE;
++ valid_flags = VALIDATE_VALID_FLAGS;
+ break;
+ case 'V':
+ if (mode && mode != MODE_VERSION)
+@@ -533,7 +539,7 @@
+ if (!mode) {
+ /* Defer -k mode setting until we know whether it is a flag or not */
+ if (sudo_settings[ARG_IGNORE_TICKET].value != NULL) {
+- if (argc == 0 && !(flags & (MODE_SHELL|MODE_LOGIN_SHELL))) {
++ if (argc == 0 && !ISSET(flags, MODE_SHELL|MODE_LOGIN_SHELL)) {
+ mode = MODE_INVALIDATE; /* -k by itself */
+ sudo_settings[ARG_IGNORE_TICKET].value = NULL;
+ valid_flags = 0;
+@@ -601,7 +607,7 @@
+ /*
+ * For shell mode we need to rewrite argv
+ */
+- if (ISSET(mode, MODE_RUN) && ISSET(flags, MODE_SHELL)) {
++ if (ISSET(flags, MODE_SHELL|MODE_LOGIN_SHELL) && ISSET(mode, MODE_RUN)) {
+ char **av, *cmnd = NULL;
+ int ac = 1;
+
+
diff --git a/system/uucp/APKBUILD b/system/uucp/APKBUILD
index 422f28ae5..71151e6f0 100644
--- a/system/uucp/APKBUILD
+++ b/system/uucp/APKBUILD
@@ -1,5 +1,5 @@
-# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
-# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Contributor: Sheila Aman <sheila@vulpine.house>
+# Maintainer: Sheila Aman <sheila@vulpine.house>
pkgname=uucp
pkgver=1.07
pkgrel=0
diff --git a/system/vim/APKBUILD b/system/vim/APKBUILD
index e9148fed1..cd4a39004 100644
--- a/system/vim/APKBUILD
+++ b/system/vim/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Łukasz Jendrysik <scadu@yandex.com>
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+# Maintainer: Sheila Aman <sheila@vulpine.house>
pkgname=vim
pkgver=8.2.1900
_pkgver=${pkgver%.*.*}${pkgver#*.}
@@ -49,7 +49,7 @@ build() {
--with-compiledby="Adélie Linux" \
vim_cv_toupper_broken=no \
vim_cv_terminfo=yes \
- vim_cv_tgent=zero \
+ vim_cv_tgetent=zero \
vim_cv_tty_group=world \
vim_cv_getcwd_broken=no \
vim_cv_stat_ignores_slash=no \