summaryrefslogtreecommitdiff
path: root/user/wireguard-module
diff options
context:
space:
mode:
Diffstat (limited to 'user/wireguard-module')
-rw-r--r--user/wireguard-module/APKBUILD38
1 files changed, 24 insertions, 14 deletions
diff --git a/user/wireguard-module/APKBUILD b/user/wireguard-module/APKBUILD
index 2e4a7e74f..e77179680 100644
--- a/user/wireguard-module/APKBUILD
+++ b/user/wireguard-module/APKBUILD
@@ -1,32 +1,42 @@
# Contributor: Luis Ressel <aranea@aixah.de>
# Maintainer: Luis Ressel <aranea@aixah.de>
-# KEEP THIS IN SYNC with the other wireguard-module packages.
-_kflavour=""
-_kver="4.14.138-mc15"
-pkgver=0.0.20191012
+_kver="5.4.5-mc0"
+pkgver=0.0.20200105
pkgrel=0
-_pkgname="wireguard-module$_kflavour"
+_pkgname="wireguard-module"
pkgname="$_pkgname-$_kver"
-_pkgreal="WireGuard"
+_pkgreal="wireguard-linux-compat"
pkgdesc="Kernel module for the WireGuard VPN, built for easy-kernel"
url="https://www.wireguard.com/"
arch="all"
options="!check !dbg !strip" # no test suite
license="GPL-2.0-only"
provides="$_pkgname=$pkgver"
-depends="easy-kernel$_kflavour-modules-$_kver"
-makedepends="easy-kernel$_kflavour-src-$_kver"
-source="https://git.zx2c4.com/WireGuard/snapshot/$_pkgreal-$pkgver.tar.xz"
+depends="easy-kernel-modules-$_kver"
+makedepends="easy-kernel-src-$_kver"
+subpackages="wireguard-patch:_patch:noarch"
+source="https://git.zx2c4.com/$_pkgreal/snapshot/$_pkgreal-$pkgver.tar.xz"
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
- make -C src LDFLAGS="" KERNELDIR="/usr/src/linux-$_kver$_kflavour" module
+ make -C src LDFLAGS="" KERNELDIR="/usr/src/linux-$_kver" module
}
package() {
- cd "$builddir"
- make -C src DEPMOD=true KERNELDIR="/usr/src/linux-$_kver$_kflavour" INSTALL_MOD_PATH="$pkgdir" module-install
+ if [ -f $HOME/kernel_key.pem ]; then
+ /usr/src/linux-$_kver/scripts/sign-file sha512 \
+ $HOME/kernel_key.pem $HOME/kernel_key.pem \
+ "$builddir"/src/wireguard.ko
+ fi
+ make -C src DEPMOD=true KERNELDIR="/usr/src/linux-$_kver" INSTALL_MOD_PATH="$pkgdir" module-install
}
-sha512sums="b15424036f26298d8511ca0d0d6a485ff0992726d61fabff8bf6dd64d0a65423bf901e5eb14d3080372017390b05d25faff89a72128932c7408f93f59165c321 WireGuard-0.0.20191012.tar.xz"
+_patch() {
+ depends=""
+ pkgdesc="Kernel patch for the WireGuard VPN"
+
+ mkdir -p "$subpkgdir/usr/share/wireguard"
+ "$builddir"/kernel-tree-scripts/create-patch.sh > "$subpkgdir/usr/share/wireguard/wireguard-$pkgver.patch"
+}
+
+sha512sums="a27d863e7af9ecbdad784d9ebd6b7613cb6a3a8749d2552c0ecc932c606ed08effc9600813d8cc6801748041456d6e59aab28b9ba486986c88f3d2e90a9209bd wireguard-linux-compat-0.0.20200105.tar.xz"