From e383b8782bbb48262f8123f2d7cb296c38fb057f Mon Sep 17 00:00:00 2001
From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
Date: Wed, 4 Jul 2018 01:37:06 -0500
Subject: system/xfsprogs: pull in, bump, take

---
 system/xfsprogs/APKBUILD             | 43 ++++++++++++++++++++++++++++++++++++
 system/xfsprogs/no-utmp-header.patch | 20 +++++++++++++++++
 2 files changed, 63 insertions(+)
 create mode 100644 system/xfsprogs/APKBUILD
 create mode 100644 system/xfsprogs/no-utmp-header.patch

diff --git a/system/xfsprogs/APKBUILD b/system/xfsprogs/APKBUILD
new file mode 100644
index 000000000..c9e558f61
--- /dev/null
+++ b/system/xfsprogs/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=xfsprogs
+pkgver=4.17.0
+pkgrel=0
+pkgdesc="XFS filesystem utilities"
+url="http://xfs.org/index.php/Main_Page"
+arch="all"
+options="!check"  # No test suite.
+license="GPL-1.0-only"
+makedepends="attr-dev bash linux-headers util-linux-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="https://www.kernel.org/pub/linux/utils/fs/xfs/$pkgname/$pkgname-$pkgver.tar.gz
+	no-utmp-header.patch
+	"
+
+build() {
+	cd "$builddir"
+	export DEBUG=-DNDEBUG
+	export OPTIMIZER="$CFLAGS"
+	./configure \
+		--build=$CBUILD \
+		--host=$CHOST \
+		--prefix=/usr \
+		--sbindir=/sbin \
+		--libexecdir=/usr/lib \
+		--enable-gettext=no
+	make SHELL=/bin/bash
+}
+
+check() {
+	cd "$builddir"
+	make check
+}
+
+package() {
+	cd "$builddir"
+	make -j1 DIST_ROOT="$pkgdir" install install-dev
+	find "$pkgdir" -name *.la -delete
+}
+
+sha512sums="19bdb9b1698b07d42c52976c17ac8dc95170e59bbd7d74e3d6faadd36cba88ed36a8b0c309052cab01ecb3a14e564b42ea982380b76922401be516d463476548  xfsprogs-4.17.0.tar.gz
+272bd64cf6aa3311edfea94c15167313a805bab3a659c231142a02cb7fd87b97c811ba68b1ef77bb5737b2e37defe6a41b234143b0951b13c251abab7186645b  no-utmp-header.patch"
diff --git a/system/xfsprogs/no-utmp-header.patch b/system/xfsprogs/no-utmp-header.patch
new file mode 100644
index 000000000..05e897cc8
--- /dev/null
+++ b/system/xfsprogs/no-utmp-header.patch
@@ -0,0 +1,20 @@
+--- xfsprogs-4.17.0/quota/report.c.old	2018-06-28 12:00:43.000000000 -0500
++++ xfsprogs-4.17.0/quota/report.c	2018-07-04 00:50:44.940000000 -0500
+@@ -20,7 +20,6 @@
+ #include <sys/types.h>
+ #include <pwd.h>
+ #include <grp.h>
+-#include <utmp.h>
+ #include "init.h"
+ #include "quota.h"
+ 
+--- xfsprogs-4.17.0/quota/util.c.old	2018-06-28 12:00:43.000000000 -0500
++++ xfsprogs-4.17.0/quota/util.c	2018-07-04 00:53:25.470000000 -0500
+@@ -20,7 +20,6 @@
+ #include <stdbool.h>
+ #include <pwd.h>
+ #include <grp.h>
+-#include <utmp.h>
+ #include "init.h"
+ #include "quota.h"
+ 
-- 
cgit v1.2.3-70-g09d2