From cb3f92223d1a88b8402ede9fe800fd5e3bb8f550 Mon Sep 17 00:00:00 2001
From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
Date: Tue, 23 Oct 2018 04:52:00 +0000
Subject: system/sudo: bugfix bump to 1.8.25_p1

---
 system/sudo/APKBUILD               | 10 ++++------
 system/sudo/libcrypt.patch         | 11 -----------
 system/sudo/musl-fix-headers.patch | 12 ++++++------
 3 files changed, 10 insertions(+), 23 deletions(-)
 delete mode 100644 system/sudo/libcrypt.patch

(limited to 'system/sudo')

diff --git a/system/sudo/APKBUILD b/system/sudo/APKBUILD
index 3e3fdc7b5..f9b1fc66d 100644
--- a/system/sudo/APKBUILD
+++ b/system/sudo/APKBUILD
@@ -3,13 +3,13 @@
 # Contributor: Natanael Copa <ncopa@alpinelinux.org>
 # Maintainer: Horst Burkhardt <horst@adelielinux.org>
 pkgname=sudo
-pkgver=1.8.23
+pkgver=1.8.25_p1
 if [ "${pkgver%_*}" != "$pkgver" ]; then
 	_realver=${pkgver%_*}${pkgver#*_}
 else
 	_realver=$pkgver
 fi
-pkgrel=2
+pkgrel=0
 pkgdesc="Give certain users the ability to run some commands as root"
 url="https://www.sudo.ws/sudo/"
 arch="all"
@@ -22,7 +22,6 @@ depends=
 subpackages="$pkgname-doc $pkgname-dev $pkgname-lang"
 source="https://www.sudo.ws/dist/sudo-${_realver}.tar.gz
 	fix-cross-compile.patch
-	libcrypt.patch
 	musl-fix-headers.patch
 	"
 
@@ -61,7 +60,6 @@ package() {
 	rm -rf "$pkgdir"/var/run
 }
 
-sha512sums="a9d61850a4857bfd075547a13efb13b054e4736e3ebe3c8a98a90a090b1d9b9688354ec9725fc99d1d256999b6f9c6ae6215ce9770fcdebd7f24731107b48342  sudo-1.8.23.tar.gz
+sha512sums="b1445be688d3c1dd7efbdfab68977a7a9b6fd6887191dc99ca717117eec0a550492642556cd55ca5873d054ddc5ccc2b87b2c34602e1ffc729ab6fbc4e523a72  sudo-1.8.25p1.tar.gz
 f0f462f40502da2194310fe4a72ec1a16ba40f95a821ba9aa6aabaa423d28c4ab26b684afa7fb81c2407cf60de9327bdab01de51b878c5d4de49b0d62645f53c  fix-cross-compile.patch
-5ad20254aa587ef615f794081ecd55344eada5cf8c1a1d7956cc3f73375554716c483eeb74081da9a8501afce92cfbaf2abe59d1067aac67ce6e4874eb5a23e1  libcrypt.patch
-113416fed7532c6092687c8bdd9913d04888d2f0a32e4333dd27a6b3d39145717ad5c3b3f05ba11bd6462612a9a013d446d254d50b2b651c33eeebe670f41ab5  musl-fix-headers.patch"
+dcc03abdd672c934f90dfd3683b3f81a8d39cfff91307d2dbd20a31a852022ab605d034c4fe11860ba99b78d391a9812fca1d6e052620b8ff2c42e4f0c7a1a62  musl-fix-headers.patch"
diff --git a/system/sudo/libcrypt.patch b/system/sudo/libcrypt.patch
deleted file mode 100644
index e83b69113..000000000
--- a/system/sudo/libcrypt.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./plugins/sudoers/Makefile.in.orig
-+++ ./plugins/sudoers/Makefile.in
-@@ -52,7 +52,7 @@
- LT_LIBS = $(top_builddir)/lib/util/libsudo_util.la
- LIBS = $(LT_LIBS) @LIBINTL@
- NET_LIBS = @NET_LIBS@
--SUDOERS_LIBS = @SUDOERS_LIBS@ @AFS_LIBS@ @GETGROUPS_LIB@ $(LIBS) $(NET_LIBS) @ZLIB@ @LIBMD@
-+SUDOERS_LIBS = @SUDOERS_LIBS@ @AFS_LIBS@ @GETGROUPS_LIB@ $(LIBS) $(NET_LIBS) @ZLIB@ @LIBMD@ -lcrypt
- REPLAY_LIBS = @REPLAY_LIBS@ @ZLIB@
- VISUDO_LIBS = $(NET_LIBS) @LIBMD@
- TESTSUDOERS_LIBS = $(NET_LIBS) @LIBMD@
diff --git a/system/sudo/musl-fix-headers.patch b/system/sudo/musl-fix-headers.patch
index 18a19b75d..d57a9ff4b 100644
--- a/system/sudo/musl-fix-headers.patch
+++ b/system/sudo/musl-fix-headers.patch
@@ -1,10 +1,10 @@
 --- ./include/sudo_compat.h.orig
 +++ ./include/sudo_compat.h
 @@ -25,6 +25,7 @@
- #include <stdio.h>
- #include <stdarg.h>
- #include <stddef.h>	/* for rsize_t */
+ #endif
+ #if !defined(HAVE_MEMSET_S) && !defined(rsize_t)
+ # include <stddef.h>	/* for rsize_t */
 +#include <sys/types.h> /* for id_t */
- 
- /*
-  * Macros and functions that may be missing on some operating systems.
+ # ifdef HAVE_STRING_H
+ #  include <string.h>	/* for rsize_t on AIX */
+ # endif /* HAVE_STRING_H */
-- 
cgit v1.2.3-70-g09d2