From 6079f708412b7d76c1968b1c2787908a31343cab Mon Sep 17 00:00:00 2001
From: Luis Ressel <aranea@aixah.de>
Date: Tue, 26 Feb 2019 21:42:20 +0100
Subject: system/zsh: The source tarball can be at domain/pub/ or
 domain/pub/old/

---
 system/zsh/APKBUILD | 11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)

(limited to 'system')

diff --git a/system/zsh/APKBUILD b/system/zsh/APKBUILD
index 32c86b7df..e1e54c0f5 100644
--- a/system/zsh/APKBUILD
+++ b/system/zsh/APKBUILD
@@ -6,13 +6,14 @@ pkgname=zsh
 pkgver=5.6.2
 pkgrel=1
 pkgdesc="A very advanced and programmable command interpreter (shell)"
-url="http://www.zsh.org/"
+url="https://www.zsh.org/"
 arch="all"
 license="Zsh AND BSD-3-Clause AND GPL-2.0+ AND GPL-2.0-only AND Artistic-1.0-Perl AND MIT AND GPL-1.0+"
 depends="debianutils"  # add-shell
 makedepends_host="ncurses-dev pcre-dev utmps-dev"
 install="zsh.post-install zsh.post-upgrade zsh.pre-deinstall"
-source="http://www.zsh.org/pub/$pkgname-$pkgver.tar.xz
+# Note the custom fetch() function
+source="https://www.zsh.org/pub/$pkgname-$pkgver.tar.xz
 	zprofile
 	zshrc
 	"
@@ -21,7 +22,6 @@ subpackages="$pkgname-doc
 	     $pkgname-vcs::noarch
 	     $pkgname-tcp::noarch"
 [ "$CBUILD" != "$CHOST" ] || subpackages="$subpackages $pkgname-zftp"
-builddir="$srcdir/$pkgname-$pkgver"
 
 # secfixes:
 #   5.6.2-r0:
@@ -52,6 +52,11 @@ for _i in $_comps; do
 	subpackages="$subpackages ${_i%%:*}-zsh-completion:_completion:noarch"
 done
 
+fetch() {
+	uri_fetch_mirror "https://www.zsh.org/pub/old/$pkgname-$pkgver.tar.xz" || true
+	default_fetch
+}
+
 prepare() {
 	cd "$builddir"
 
-- 
cgit v1.2.3-70-g09d2