From 7b542319e8ae0396365068e711c073f87bd661c1 Mon Sep 17 00:00:00 2001
From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
Date: Sun, 24 Oct 2021 17:51:06 -0500
Subject: system/findutils: Update to 4.8.0

---
 system/findutils/APKBUILD                   | 10 +++++-----
 system/findutils/gnulib-test-datetime.patch | 24 ------------------------
 system/findutils/xargs-test-hashbang.patch  | 11 +++++++++++
 3 files changed, 16 insertions(+), 29 deletions(-)
 delete mode 100644 system/findutils/gnulib-test-datetime.patch
 create mode 100644 system/findutils/xargs-test-hashbang.patch

(limited to 'system')

diff --git a/system/findutils/APKBUILD b/system/findutils/APKBUILD
index dc97a9de3..2b2877abc 100644
--- a/system/findutils/APKBUILD
+++ b/system/findutils/APKBUILD
@@ -2,20 +2,20 @@
 # Contributor: Michael Mason <ms13sp@gmail.com>
 # Maintainer: 	
 pkgname=findutils
-pkgver=4.7.0
+pkgver=4.8.0
 pkgrel=0
 pkgdesc="GNU utilities to locate files"
 url="https://www.gnu.org/software/findutils/"
 arch="all"
 license="GPL-3.0+"
 depends=""
-checkdepends="coreutils diffutils dejagnu"
+checkdepends="bash coreutils diffutils dejagnu"
 makedepends=""
 subpackages="$pkgname-doc $pkgname-lang"
 source="https://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz
 	gnulib-tests-dont-require-gpg-passphrase.patch
 	sysmacros.patch
-	gnulib-test-datetime.patch
+	xargs-test-hashbang.patch
 	"
 
 build() {
@@ -39,7 +39,7 @@ package() {
 	rm -rf "$pkgdir"/usr/lib
 }
 
-sha512sums="650a24507f8f4ebff83ad28dd27daa4785b4038dcaadc4fe00823b976e848527074cce3f9ec34065b7f037436d2aa6e9ec099bc05d7472c29864ac2c69de7f2e  findutils-4.7.0.tar.xz
+sha512sums="eaa2da304dbeb2cd659b9210ac37da1bde4cd665c12a818eca98541c5ed5cba1050641fc0c39c0a446a5a7a87a8d654df0e0e6b0cee21752ea485188c9f1071e  findutils-4.8.0.tar.xz
 dc7e9c4fdd36d05ca230e3456a8005a5fcd353db07181e0d17ab66db4eb967e6bdfe3b6f1da0edbb38e973fea89ae174ea31e6839f59d3084b15f08de363f139  gnulib-tests-dont-require-gpg-passphrase.patch
 2e214511de4be47dc0df46a83d4102e4b59b5f02c4b8356a1ed0b26d481e17c6604bbf07071960f219ef85e1687878cce69a8be28c46638ee4ebe9f4ce0ed487  sysmacros.patch
-8e367ba108b66ea27b2a289e51acbdf540d7e7ab5dfb8347a007eaf763355707db43c44e530fbec40f47578405880ff99d34eec97570365f2ab3439c4f1bf358  gnulib-test-datetime.patch"
+05402edd764c068c90765ced7322cca7c2d41061fb68b6d412e4010b32aad148489d367bcc447a11fa774cf959d122ec6c63cc7a846d35dea936f1e0bad7aa1c  xargs-test-hashbang.patch"
diff --git a/system/findutils/gnulib-test-datetime.patch b/system/findutils/gnulib-test-datetime.patch
deleted file mode 100644
index 2b227fc27..000000000
--- a/system/findutils/gnulib-test-datetime.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- coreutils-8.31/gnulib-tests/test-parse-datetime.c.old	2019-06-01 07:46:25.716292871 +0000
-+++ coreutils-8.31/gnulib-tests/test-parse-datetime.c	2019-06-01 22:07:59.456653669 +0000
-@@ -432,21 +432,5 @@
-   ASSERT (   parse_datetime (&result, "TZ=\"\\\\\"", &now));
-   ASSERT (   parse_datetime (&result, "TZ=\"\\\"\"", &now));
- 
--  /* Outlandishly-long time zone abbreviations should not cause problems.  */
--  {
--    static char const bufprefix[] = "TZ=\"";
--    enum { tzname_len = 2000 };
--    static char const bufsuffix[] = "0\" 1970-01-01 01:02:03.123456789";
--    enum { bufsize = sizeof bufprefix - 1 + tzname_len + sizeof bufsuffix };
--    char buf[bufsize];
--    memcpy (buf, bufprefix, sizeof bufprefix - 1);
--    memset (buf + sizeof bufprefix - 1, 'X', tzname_len);
--    strcpy (buf + bufsize - sizeof bufsuffix, bufsuffix);
--    ASSERT (parse_datetime (&result, buf, &now));
--    LOG (buf, now, result);
--    ASSERT (result.tv_sec == 1 * 60 * 60 + 2 * 60 + 3
--            && result.tv_nsec == 123456789);
--  }
--
-   return 0;
- }
diff --git a/system/findutils/xargs-test-hashbang.patch b/system/findutils/xargs-test-hashbang.patch
new file mode 100644
index 000000000..53b3f34a0
--- /dev/null
+++ b/system/findutils/xargs-test-hashbang.patch
@@ -0,0 +1,11 @@
+This test fails when using dash as /bin/sh.
+
+This workaround is also being used by Guix.
+--- findutils-4.8.0/tests/xargs/verbose-quote.sh.old	2021-01-01 18:46:51.000000000 -0600
++++ findutils-4.8.0/tests/xargs/verbose-quote.sh	2021-09-11 01:01:01.090000000 -0500
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/bin/bash
+ # Verify that 'xargs -t' quotes the command properly when needed.
+ 
+ # Copyright (C) 2019-2021 Free Software Foundation, Inc.
-- 
cgit v1.2.3-70-g09d2