From 7eb237064c8f9926942fd7dbbfe8a6a90c11fa5d Mon Sep 17 00:00:00 2001
From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
Date: Mon, 25 Apr 2022 01:01:43 -0500
Subject: system/python3: Revert back to 1 MB thread stacks

I cannot reproduce the failure on 3.10.2 or later.  This may have been a
bug in earlier 3.10 versions.  Willing to re-investigate if anyone runs
in to this at a later date.
---
 system/python3/APKBUILD | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

(limited to 'system')

diff --git a/system/python3/APKBUILD b/system/python3/APKBUILD
index ba29bea30..7c80d89a7 100644
--- a/system/python3/APKBUILD
+++ b/system/python3/APKBUILD
@@ -94,9 +94,9 @@ build() {
 		--with-system-ffi \
 		--with-threads
 
-	# set thread stack size to 2MB so we don't segfault before we hit
+	# set thread stack size to 1MB so we don't segfault before we hit
 	# sys.getrecursionlimit()
-	stacksize=0x200000;
+	stacksize=0x100000;
 	make EXTRA_CFLAGS="$CFLAGS -DTHREAD_STACK_SIZE=$stacksize"
 }
 
-- 
cgit v1.2.3-70-g09d2