From 1d76337f8d72a658184afd7f35a9db232f60b8bb Mon Sep 17 00:00:00 2001
From: Zach van Rijn <me@zv.io>
Date: Tue, 11 Apr 2023 12:21:09 -0700
Subject: user/gpgme: bump { 1.16.0 --> 1.19.0 }. fixes #995.

---
 ...001-core-Fix-use-after-free-issue-in-test.patch | 123 --------
 ...xpiration-time-is-interpreted-as-unsigned.patch |  30 --
 user/gpgme/0003-python311.patch                    | 335 ---------------------
 user/gpgme/APKBUILD                                |  14 +-
 user/gpgme/initialize-err-variable.patch           |  26 ++
 5 files changed, 31 insertions(+), 497 deletions(-)
 delete mode 100644 user/gpgme/0001-core-Fix-use-after-free-issue-in-test.patch
 delete mode 100644 user/gpgme/0002-Make-sure-expiration-time-is-interpreted-as-unsigned.patch
 delete mode 100644 user/gpgme/0003-python311.patch
 create mode 100644 user/gpgme/initialize-err-variable.patch

(limited to 'user/gpgme')

diff --git a/user/gpgme/0001-core-Fix-use-after-free-issue-in-test.patch b/user/gpgme/0001-core-Fix-use-after-free-issue-in-test.patch
deleted file mode 100644
index 86c5110fe..000000000
--- a/user/gpgme/0001-core-Fix-use-after-free-issue-in-test.patch
+++ /dev/null
@@ -1,123 +0,0 @@
-From 81a33ea5e1b86d586b956e893a5b25c4cd41c969 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Ingo=20Kl=C3=B6cker?= <dev@ingo-kloecker.de>
-Date: Sat, 26 Jun 2021 18:02:47 +0200
-Subject: [PATCH] core: Fix use-after-free issue in test
-
-* tests/gpg/t-edit-sign.c (sign_key, verify_key_signature): New.
-(main): Factored out signing and verifying the result.
---
-
-Factoring the two steps of the test into different functions fixes the
-use-after-free issue that was caused by accidentaly using a variable
-of the first step in the second step.
-
-GnuPG-bug-id: 5509
----
- tests/gpg/t-edit-sign.c | 54 ++++++++++++++++++++++++++++-------------
- 1 file changed, 37 insertions(+), 17 deletions(-)
-
-diff --git a/tests/gpg/t-edit-sign.c b/tests/gpg/t-edit-sign.c
-index 2f983622..e0494c54 100644
---- a/tests/gpg/t-edit-sign.c
-+++ b/tests/gpg/t-edit-sign.c
-@@ -107,31 +107,19 @@ interact_fnc (void *opaque, const char *status, const char *args, int fd)
- }
- 
- 
--int
--main (int argc, char **argv)
-+void
-+sign_key (const char *key_fpr, const char *signer_fpr)
- {
-   gpgme_ctx_t ctx;
-   gpgme_error_t err;
-   gpgme_data_t out = NULL;
--  const char *signer_fpr = "A0FF4590BB6122EDEF6E3C542D727CC768697734"; /* Alpha Test */
-   gpgme_key_t signing_key = NULL;
--  const char *key_fpr = "D695676BDCEDCC2CDD6152BCFE180B1DA9E3B0B2"; /* Bravo Test */
-   gpgme_key_t key = NULL;
--  gpgme_key_t signed_key = NULL;
--  gpgme_user_id_t signed_uid = NULL;
--  gpgme_key_sig_t key_sig = NULL;
-   char *agent_info;
--  int mode;
--
--  (void)argc;
--  (void)argv;
--
--  init_gpgme (GPGME_PROTOCOL_OpenPGP);
- 
-   err = gpgme_new (&ctx);
-   fail_if_err (err);
- 
--  /* Sign the key */
-   agent_info = getenv("GPG_AGENT_INFO");
-   if (!(agent_info && strchr (agent_info, ':')))
-     gpgme_set_passphrase_cb (ctx, passphrase_cb, 0);
-@@ -159,8 +147,23 @@ main (int argc, char **argv)
-   gpgme_data_release (out);
-   gpgme_key_unref (key);
-   gpgme_key_unref (signing_key);
-+  gpgme_release (ctx);
-+}
-+
-+
-+void
-+verify_key_signature (const char *key_fpr, const char *signer_keyid)
-+{
-+  gpgme_ctx_t ctx;
-+  gpgme_error_t err;
-+  gpgme_key_t signed_key = NULL;
-+  gpgme_user_id_t signed_uid = NULL;
-+  gpgme_key_sig_t key_sig = NULL;
-+  int mode;
-+
-+  err = gpgme_new (&ctx);
-+  fail_if_err (err);
- 
--  /* Verify the key signature */
-   mode  = gpgme_get_keylist_mode (ctx);
-   mode |= GPGME_KEYLIST_MODE_SIGS;
-   err = gpgme_set_keylist_mode (ctx, mode);
-@@ -168,7 +171,7 @@ main (int argc, char **argv)
-   err = gpgme_get_key (ctx, key_fpr, &signed_key, 0);
-   fail_if_err (err);
- 
--  signed_uid = key->uids;
-+  signed_uid = signed_key->uids;
-   if (!signed_uid)
-     {
-       fprintf (stderr, "Signed key has no user IDs\n");
-@@ -180,7 +183,7 @@ main (int argc, char **argv)
-       exit (1);
-     }
-   key_sig = signed_uid->signatures->next;
--  if (strcmp ("2D727CC768697734", key_sig->keyid))
-+  if (strcmp (signer_keyid, key_sig->keyid))
-     {
-       fprintf (stderr, "Unexpected key ID in second user ID sig: %s\n",
-                 key_sig->keyid);
-@@ -196,6 +199,23 @@ main (int argc, char **argv)
- 
-   gpgme_key_unref (signed_key);
-   gpgme_release (ctx);
-+}
-+
-+
-+int
-+main (int argc, char **argv)
-+{
-+  const char *signer_fpr = "A0FF4590BB6122EDEF6E3C542D727CC768697734"; /* Alpha Test */
-+  const char *signer_keyid = signer_fpr + strlen(signer_fpr) - 16;
-+  const char *key_fpr = "D695676BDCEDCC2CDD6152BCFE180B1DA9E3B0B2"; /* Bravo Test */
-+
-+  (void)argc;
-+  (void)argv;
-+
-+  init_gpgme (GPGME_PROTOCOL_OpenPGP);
-+
-+  sign_key (key_fpr, signer_fpr);
-+  verify_key_signature (key_fpr, signer_keyid);
- 
-   return 0;
- }
diff --git a/user/gpgme/0002-Make-sure-expiration-time-is-interpreted-as-unsigned.patch b/user/gpgme/0002-Make-sure-expiration-time-is-interpreted-as-unsigned.patch
deleted file mode 100644
index 558cacda0..000000000
--- a/user/gpgme/0002-Make-sure-expiration-time-is-interpreted-as-unsigned.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 6a79e90dedc19877ae1c520fed875b57089a5425 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Ingo=20Kl=C3=B6cker?= <dev@ingo-kloecker.de>
-Date: Thu, 8 Jul 2021 11:54:06 +0200
-Subject: [PATCH] Make sure expiration time is interpreted as unsigned number
-
-* lang/qt/tests/t-various.cpp (testSignKeyWithExpiration): Convert
-expiration time to uint_least32_t.
---
-
-This fixes the test on 32-bit systems where time_t (the return type of
-expirationTime()) is a signed 32-bit integer type.
-
-GnuPG-bug-id: 5522
----
- lang/qt/tests/t-various.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/lang/qt/tests/t-various.cpp b/lang/qt/tests/t-various.cpp
-index 8563b681..72a2487a 100644
---- a/lang/qt/tests/t-various.cpp
-+++ b/lang/qt/tests/t-various.cpp
-@@ -355,7 +355,7 @@ private Q_SLOTS:
-         target.update();
-         const auto keySignature = target.userID(0).signature(target.userID(0).numSignatures() - 1);
-         QVERIFY(!keySignature.neverExpires());
--        const auto expirationDate = QDateTime::fromSecsSinceEpoch(keySignature.expirationTime()).date();
-+        const auto expirationDate = QDateTime::fromSecsSinceEpoch(uint_least32_t(keySignature.expirationTime())).date();
-         QCOMPARE(expirationDate, QDate(2106, 2, 6));  // expiration date is capped at 2106-02-06
-     }
- 
diff --git a/user/gpgme/0003-python311.patch b/user/gpgme/0003-python311.patch
deleted file mode 100644
index 293eb557e..000000000
--- a/user/gpgme/0003-python311.patch
+++ /dev/null
@@ -1,335 +0,0 @@
-Taken from the Arch Repo
-GPGME fails to detect python 3.11 currently, this patch fixes that
-Patch has not been upstreamed as of right now
-diff -upr gpgme-1.16.0.orig/configure gpgme-1.16.0/configure
---- gpgme-1.16.0.orig/configure	2021-06-24 20:10:50.000000000 +0300
-+++ gpgme-1.16.0/configure	2021-12-01 00:12:24.383952330 +0200
-@@ -19625,7 +19625,7 @@ $as_echo_n "checking for $am_display_PYT
- if ${am_cv_python_version+:} false; then :
-   $as_echo_n "(cached) " >&6
- else
--  am_cv_python_version=`$PYTHON -c "import sys; sys.stdout.write(sys.version[:3])"`
-+  am_cv_python_version=`$PYTHON -c "import sys; sys.stdout.write(sys.version[:4])"`
- fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $am_cv_python_version" >&5
- $as_echo "$am_cv_python_version" >&6; }
-@@ -19666,7 +19666,7 @@ else:
- # <https://github.com/pypa/virtualenv/issues/118>
- try:
-     from platform import python_implementation
--    if python_implementation() == 'CPython' and sys.version[:3] == '2.7':
-+    if python_implementation() == 'CPython' and sys.version[:4] == '2.7':
-         can_use_sysconfig = 0
- except ImportError:
-     pass"
-@@ -19875,7 +19875,7 @@ variable to configure. See \`\`configure
- 	{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for the distutils Python package" >&5
- $as_echo_n "checking for the distutils Python package... " >&6; }
- 	ac_distutils_result=`$PYTHON -c "import distutils" 2>&1`
--	if test -z "$ac_distutils_result"; then
-+	if test $? -eq 0; then
- 		{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
- $as_echo "yes" >&6; }
- 	else
-@@ -19933,7 +19933,7 @@ EOD`
- 				ac_python_version=$PYTHON_VERSION
- 			else
- 				ac_python_version=`$PYTHON -c "import sys; \
--					print (sys.version[:3])"`
-+					print (sys.version[:4])"`
- 			fi
- 		fi
- 
-@@ -20255,7 +20255,7 @@ $as_echo_n "checking for $am_display_PYT
- if ${am_cv_python_version+:} false; then :
-   $as_echo_n "(cached) " >&6
- else
--  am_cv_python_version=`$PYTHON -c "import sys; sys.stdout.write(sys.version[:3])"`
-+  am_cv_python_version=`$PYTHON -c "import sys; sys.stdout.write(sys.version[:4])"`
- fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $am_cv_python_version" >&5
- $as_echo "$am_cv_python_version" >&6; }
-@@ -20296,7 +20296,7 @@ else:
- # <https://github.com/pypa/virtualenv/issues/118>
- try:
-     from platform import python_implementation
--    if python_implementation() == 'CPython' and sys.version[:3] == '2.7':
-+    if python_implementation() == 'CPython' and sys.version[:4] == '2.7':
-         can_use_sysconfig = 0
- except ImportError:
-     pass"
-@@ -20505,7 +20505,7 @@ variable to configure. See \`\`configure
- 	{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for the distutils Python package" >&5
- $as_echo_n "checking for the distutils Python package... " >&6; }
- 	ac_distutils_result=`$PYTHON -c "import distutils" 2>&1`
--	if test -z "$ac_distutils_result"; then
-+	if test $? -eq 0; then
- 		{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
- $as_echo "yes" >&6; }
- 	else
-@@ -20563,7 +20563,7 @@ EOD`
- 				ac_python_version=$PYTHON_VERSION
- 			else
- 				ac_python_version=`$PYTHON -c "import sys; \
--					print (sys.version[:3])"`
-+					print (sys.version[:4])"`
- 			fi
- 		fi
- 
-@@ -20885,7 +20885,7 @@ $as_echo_n "checking for $am_display_PYT
- if ${am_cv_python_version+:} false; then :
-   $as_echo_n "(cached) " >&6
- else
--  am_cv_python_version=`$PYTHON -c "import sys; sys.stdout.write(sys.version[:3])"`
-+  am_cv_python_version=`$PYTHON -c "import sys; sys.stdout.write(sys.version[:4])"`
- fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $am_cv_python_version" >&5
- $as_echo "$am_cv_python_version" >&6; }
-@@ -20926,7 +20926,7 @@ else:
- # <https://github.com/pypa/virtualenv/issues/118>
- try:
-     from platform import python_implementation
--    if python_implementation() == 'CPython' and sys.version[:3] == '2.7':
-+    if python_implementation() == 'CPython' and sys.version[:4] == '2.7':
-         can_use_sysconfig = 0
- except ImportError:
-     pass"
-@@ -21135,7 +21135,7 @@ variable to configure. See \`\`configure
- 	{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for the distutils Python package" >&5
- $as_echo_n "checking for the distutils Python package... " >&6; }
- 	ac_distutils_result=`$PYTHON -c "import distutils" 2>&1`
--	if test -z "$ac_distutils_result"; then
-+	if test $? -eq 0; then
- 		{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
- $as_echo "yes" >&6; }
- 	else
-@@ -21193,7 +21193,7 @@ EOD`
- 				ac_python_version=$PYTHON_VERSION
- 			else
- 				ac_python_version=`$PYTHON -c "import sys; \
--					print (sys.version[:3])"`
-+					print (sys.version[:4])"`
- 			fi
- 		fi
- 
-@@ -21515,7 +21515,7 @@ $as_echo_n "checking for $am_display_PYT
- if ${am_cv_python_version+:} false; then :
-   $as_echo_n "(cached) " >&6
- else
--  am_cv_python_version=`$PYTHON -c "import sys; sys.stdout.write(sys.version[:3])"`
-+  am_cv_python_version=`$PYTHON -c "import sys; sys.stdout.write(sys.version[:4])"`
- fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $am_cv_python_version" >&5
- $as_echo "$am_cv_python_version" >&6; }
-@@ -21556,7 +21556,7 @@ else:
- # <https://github.com/pypa/virtualenv/issues/118>
- try:
-     from platform import python_implementation
--    if python_implementation() == 'CPython' and sys.version[:3] == '2.7':
-+    if python_implementation() == 'CPython' and sys.version[:4] == '2.7':
-         can_use_sysconfig = 0
- except ImportError:
-     pass"
-@@ -21765,7 +21765,7 @@ variable to configure. See \`\`configure
- 	{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for the distutils Python package" >&5
- $as_echo_n "checking for the distutils Python package... " >&6; }
- 	ac_distutils_result=`$PYTHON -c "import distutils" 2>&1`
--	if test -z "$ac_distutils_result"; then
-+	if test $? -eq 0; then
- 		{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
- $as_echo "yes" >&6; }
- 	else
-@@ -21823,7 +21823,7 @@ EOD`
- 				ac_python_version=$PYTHON_VERSION
- 			else
- 				ac_python_version=`$PYTHON -c "import sys; \
--					print (sys.version[:3])"`
-+					print (sys.version[:4])"`
- 			fi
- 		fi
- 
-@@ -22145,7 +22145,7 @@ $as_echo_n "checking for $am_display_PYT
- if ${am_cv_python_version+:} false; then :
-   $as_echo_n "(cached) " >&6
- else
--  am_cv_python_version=`$PYTHON -c "import sys; sys.stdout.write(sys.version[:3])"`
-+  am_cv_python_version=`$PYTHON -c "import sys; sys.stdout.write(sys.version[:4])"`
- fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $am_cv_python_version" >&5
- $as_echo "$am_cv_python_version" >&6; }
-@@ -22186,7 +22186,7 @@ else:
- # <https://github.com/pypa/virtualenv/issues/118>
- try:
-     from platform import python_implementation
--    if python_implementation() == 'CPython' and sys.version[:3] == '2.7':
-+    if python_implementation() == 'CPython' and sys.version[:4] == '2.7':
-         can_use_sysconfig = 0
- except ImportError:
-     pass"
-@@ -22395,7 +22395,7 @@ variable to configure. See \`\`configure
- 	{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for the distutils Python package" >&5
- $as_echo_n "checking for the distutils Python package... " >&6; }
- 	ac_distutils_result=`$PYTHON -c "import distutils" 2>&1`
--	if test -z "$ac_distutils_result"; then
-+	if test $? -eq 0; then
- 		{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
- $as_echo "yes" >&6; }
- 	else
-@@ -22453,7 +22453,7 @@ EOD`
- 				ac_python_version=$PYTHON_VERSION
- 			else
- 				ac_python_version=`$PYTHON -c "import sys; \
--					print (sys.version[:3])"`
-+					print (sys.version[:4])"`
- 			fi
- 		fi
- 
-@@ -22775,7 +22775,7 @@ $as_echo_n "checking for $am_display_PYT
- if ${am_cv_python_version+:} false; then :
-   $as_echo_n "(cached) " >&6
- else
--  am_cv_python_version=`$PYTHON -c "import sys; sys.stdout.write(sys.version[:3])"`
-+  am_cv_python_version=`$PYTHON -c "import sys; sys.stdout.write(sys.version[:4])"`
- fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $am_cv_python_version" >&5
- $as_echo "$am_cv_python_version" >&6; }
-@@ -22816,7 +22816,7 @@ else:
- # <https://github.com/pypa/virtualenv/issues/118>
- try:
-     from platform import python_implementation
--    if python_implementation() == 'CPython' and sys.version[:3] == '2.7':
-+    if python_implementation() == 'CPython' and sys.version[:4] == '2.7':
-         can_use_sysconfig = 0
- except ImportError:
-     pass"
-@@ -23025,7 +23025,7 @@ variable to configure. See \`\`configure
- 	{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for the distutils Python package" >&5
- $as_echo_n "checking for the distutils Python package... " >&6; }
- 	ac_distutils_result=`$PYTHON -c "import distutils" 2>&1`
--	if test -z "$ac_distutils_result"; then
-+	if test $? -eq 0; then
- 		{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
- $as_echo "yes" >&6; }
- 	else
-@@ -23083,7 +23083,7 @@ EOD`
- 				ac_python_version=$PYTHON_VERSION
- 			else
- 				ac_python_version=`$PYTHON -c "import sys; \
--					print (sys.version[:3])"`
-+					print (sys.version[:4])"`
- 			fi
- 		fi
- 
-@@ -23291,13 +23291,13 @@ $as_echo "$as_me: WARNING:
- 
-         if test -n "$PYTHON"; then
-       # If the user set $PYTHON, use it and don't search something else.
--      { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether $PYTHON version is >= 3.9" >&5
--$as_echo_n "checking whether $PYTHON version is >= 3.9... " >&6; }
-+      { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether $PYTHON version is >= 3.11" >&5
-+$as_echo_n "checking whether $PYTHON version is >= 3.11... " >&6; }
-       prog="import sys
- # split strings by '.' and convert to numeric.  Append some zeros
- # because we need at least 4 digits for the hex conversion.
- # map returns an iterator in Python 3.0 and a list in 2.x
--minver = list(map(int, '3.9'.split('.'))) + [0, 0, 0]
-+minver = list(map(int, '3.11'.split('.'))) + [0, 0, 0]
- minverhex = 0
- # xrange is not present in Python 3.0 and range returns an iterator
- for i in list(range(0, 4)): minverhex = (minverhex << 8) + minver[i]
-@@ -23318,19 +23318,19 @@ fi
-     else
-       # Otherwise, try each interpreter until we find one that satisfies
-       # VERSION.
--      { $as_echo "$as_me:${as_lineno-$LINENO}: checking for a Python interpreter with version >= 3.9" >&5
--$as_echo_n "checking for a Python interpreter with version >= 3.9... " >&6; }
-+      { $as_echo "$as_me:${as_lineno-$LINENO}: checking for a Python interpreter with version >= 3.11" >&5
-+$as_echo_n "checking for a Python interpreter with version >= 3.11... " >&6; }
- if ${am_cv_pathless_PYTHON+:} false; then :
-   $as_echo_n "(cached) " >&6
- else
- 
--	for am_cv_pathless_PYTHON           in python3.9 none; do
-+	for am_cv_pathless_PYTHON           in python3.11 none; do
- 	  test "$am_cv_pathless_PYTHON" = none && break
- 	  prog="import sys
- # split strings by '.' and convert to numeric.  Append some zeros
- # because we need at least 4 digits for the hex conversion.
- # map returns an iterator in Python 3.0 and a list in 2.x
--minver = list(map(int, '3.9'.split('.'))) + [0, 0, 0]
-+minver = list(map(int, '3.11'.split('.'))) + [0, 0, 0]
- minverhex = 0
- # xrange is not present in Python 3.0 and range returns an iterator
- for i in list(range(0, 4)): minverhex = (minverhex << 8) + minver[i]
-@@ -23405,7 +23405,7 @@ $as_echo_n "checking for $am_display_PYT
- if ${am_cv_python_version+:} false; then :
-   $as_echo_n "(cached) " >&6
- else
--  am_cv_python_version=`$PYTHON -c "import sys; sys.stdout.write(sys.version[:3])"`
-+  am_cv_python_version=`$PYTHON -c "import sys; sys.stdout.write(sys.version[:4])"`
- fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $am_cv_python_version" >&5
- $as_echo "$am_cv_python_version" >&6; }
-@@ -23446,7 +23446,7 @@ else:
- # <https://github.com/pypa/virtualenv/issues/118>
- try:
-     from platform import python_implementation
--    if python_implementation() == 'CPython' and sys.version[:3] == '2.7':
-+    if python_implementation() == 'CPython' and sys.version[:4] == '2.7':
-         can_use_sysconfig = 0
- except ImportError:
-     pass"
-@@ -23655,7 +23655,7 @@ variable to configure. See \`\`configure
- 	{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for the distutils Python package" >&5
- $as_echo_n "checking for the distutils Python package... " >&6; }
- 	ac_distutils_result=`$PYTHON -c "import distutils" 2>&1`
--	if test -z "$ac_distutils_result"; then
-+	if test $? -eq 0; then
- 		{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
- $as_echo "yes" >&6; }
- 	else
-@@ -23713,7 +23713,7 @@ EOD`
- 				ac_python_version=$PYTHON_VERSION
- 			else
- 				ac_python_version=`$PYTHON -c "import sys; \
--					print (sys.version[:3])"`
-+					print (sys.version[:4])"`
- 			fi
- 		fi
- 
-@@ -24035,7 +24035,7 @@ $as_echo_n "checking for $am_display_PYT
- if ${am_cv_python_version+:} false; then :
-   $as_echo_n "(cached) " >&6
- else
--  am_cv_python_version=`$PYTHON -c "import sys; sys.stdout.write(sys.version[:3])"`
-+  am_cv_python_version=`$PYTHON -c "import sys; sys.stdout.write(sys.version[:4])"`
- fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $am_cv_python_version" >&5
- $as_echo "$am_cv_python_version" >&6; }
-@@ -24076,7 +24076,7 @@ else:
- # <https://github.com/pypa/virtualenv/issues/118>
- try:
-     from platform import python_implementation
--    if python_implementation() == 'CPython' and sys.version[:3] == '2.7':
-+    if python_implementation() == 'CPython' and sys.version[:4] == '2.7':
-         can_use_sysconfig = 0
- except ImportError:
-     pass"
-@@ -24285,7 +24285,7 @@ variable to configure. See \`\`configure
- 	{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for the distutils Python package" >&5
- $as_echo_n "checking for the distutils Python package... " >&6; }
- 	ac_distutils_result=`$PYTHON -c "import distutils" 2>&1`
--	if test -z "$ac_distutils_result"; then
-+	if test $? -eq 0; then
- 		{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
- $as_echo "yes" >&6; }
- 	else
-@@ -24343,7 +24343,7 @@ EOD`
- 				ac_python_version=$PYTHON_VERSION
- 			else
- 				ac_python_version=`$PYTHON -c "import sys; \
--					print (sys.version[:3])"`
-+					print (sys.version[:4])"`
- 			fi
- 		fi
- 
diff --git a/user/gpgme/APKBUILD b/user/gpgme/APKBUILD
index 3e1990903..66edf3974 100644
--- a/user/gpgme/APKBUILD
+++ b/user/gpgme/APKBUILD
@@ -1,8 +1,8 @@
 # Contributor: Ariadne Conill <ariadne@dereferenced.org>
 # Maintainer: A. Wilcox <awilfox@adelielinux.org>
 pkgname=gpgme
-pkgver=1.16.0
-pkgrel=2
+pkgver=1.19.0
+pkgrel=0
 pkgdesc="GnuPG Made Easy"
 url="https://www.gnupg.org/related_software/gpgme/"
 arch="all"
@@ -14,9 +14,7 @@ makedepends="$depends_dev doxygen libassuan-dev libgpg-error-dev python3-dev
 	swig cmd:which"
 subpackages="$pkgname-dev $pkgname-doc gpgmepp qgpgme py3-gpg:_py"
 source="https://gnupg.org/ftp/gcrypt/$pkgname/$pkgname-$pkgver.tar.bz2
-	0001-core-Fix-use-after-free-issue-in-test.patch
-	0002-Make-sure-expiration-time-is-interpreted-as-unsigned.patch
-	0003-python311.patch
+	initialize-err-variable.patch
 	"
 
 build() {
@@ -60,7 +58,5 @@ _py() {
 	mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
 }
 
-sha512sums="69487be69612e9bf0221ff56ae687248bd13635db1b7087130e93c1670e38f3c810bbca17723555c04fe207976c35871bbc3da005179ce099504321cf33636e4  gpgme-1.16.0.tar.bz2
-8e455ffa6590ab976ec52e47a8adf28ddc7fe5cfe6a191375bf19ff0ca3b9dd1a5788f2d33ecd4214eaf59cf7668b64f87add305da169775ad59ebd048e93303  0001-core-Fix-use-after-free-issue-in-test.patch
-774e2c28168353c5933293d4ed17ed7c5c88426290ed3500cbf2d3131dd406d2e6944bdc1b3db90c8310c71cd6db67aaae0f3459eadf47484c9cbfaaf1e712de  0002-Make-sure-expiration-time-is-interpreted-as-unsigned.patch
-bddb4d520241e9a2cc7395344fefccbe3f224e7e1b3e24900e71619c4ec22f80a63c25e3c64824229d64cace948c0d2af97576827c744aa0405c8c94d7ecd64f  0003-python311.patch"
+sha512sums="c6f01ad9432abe33f407e81083dd2f299375ad13b0517429ea1c55fb8cffa05e470dd26f5910a78b8d0f4c8c1e620788a9f369d983c191a3dac681714054fe84  gpgme-1.19.0.tar.bz2
+ea49e300ed5e470098d2de80c0c440ef8dd8f74363888d14527e0a5063bb85ed9f69a732f6bd9ef4013f36b4f69128035b5cf68deece10a7f9f8108c94d085f8  initialize-err-variable.patch"
diff --git a/user/gpgme/initialize-err-variable.patch b/user/gpgme/initialize-err-variable.patch
new file mode 100644
index 000000000..7a8d95047
--- /dev/null
+++ b/user/gpgme/initialize-err-variable.patch
@@ -0,0 +1,26 @@
+From b608c084b9220d8ed288eb916e88a236abac0707 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ingo=20Kl=C3=B6cker?= <dev@ingo-kloecker.de>
+Date: Mon, 27 Mar 2023 16:49:03 +0200
+Subject: [PATCH] core: Initialize error variable
+
+* src/engine-gpg.c (build_argv): Initialize err.
+--
+
+Fixes-commit: fbce7deb3b68af900f692591d5d05fa5c1a83f5f
+---
+ src/engine-gpg.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/engine-gpg.c b/src/engine-gpg.c
+index 9419f089..50497987 100644
+--- a/src/engine-gpg.c
++++ b/src/engine-gpg.c
+@@ -874,7 +874,7 @@ gpg_set_command_handler (void *engine, engine_command_handler_t fnc,
+ static gpgme_error_t
+ build_argv (engine_gpg_t gpg, const char *pgmname)
+ {
+-  gpgme_error_t err;
++  gpgme_error_t err = 0;
+   struct arg_and_data_s *a;
+   struct fd_data_map_s *fd_data_map = NULL;
+   size_t datac=0, argc=0, allocated_argc=0;
-- 
cgit v1.2.3-70-g09d2