From 83393e10eb5fcfefb92ff758db41b36004ad9bf1 Mon Sep 17 00:00:00 2001
From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
Date: Fri, 14 Jun 2019 20:27:38 +0000
Subject: user/opal-utils: new package

---
 user/opal-utils/APKBUILD       | 44 ++++++++++++++++++++++++++++++++++++++++++
 user/opal-utils/musl.patch     | 36 ++++++++++++++++++++++++++++++++++
 user/opal-utils/opal-prd.patch |  8 ++++++++
 3 files changed, 88 insertions(+)
 create mode 100644 user/opal-utils/APKBUILD
 create mode 100644 user/opal-utils/musl.patch
 create mode 100644 user/opal-utils/opal-prd.patch

(limited to 'user/opal-utils')

diff --git a/user/opal-utils/APKBUILD b/user/opal-utils/APKBUILD
new file mode 100644
index 000000000..d6eddcd70
--- /dev/null
+++ b/user/opal-utils/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=opal-utils
+pkgver=6.3.1
+pkgrel=0
+pkgdesc="Tools for IBM FSP and OpenPOWER systems"
+url="https://lists.ozlabs.org/listinfo/skiboot"
+arch="ppc64"
+license="Apache-2.0"
+depends=""
+makedepends=""
+subpackages="$pkgname-doc"
+source="skiboot-$pkgver.tar.gz::https://github.com/open-power/skiboot/archive/v$pkgver.tar.gz
+	musl.patch
+	opal-prd.patch
+	"
+builddir="$srcdir/skiboot-$pkgver"
+
+_tools="opal-prd gard"
+
+build() {
+	for _tool in $_tools; do
+		cd "$builddir"/external/$_tool
+		make
+	done
+}
+
+check() {
+	for _tool in $_tools; do
+		cd "$builddir"/external/$_tool
+		make test
+	done
+}
+
+package() {
+	for _tool in $_tools; do
+		cd "$builddir"/external/$_tool
+		make DESTDIR="$pkgdir" prefix="/usr" install
+	done
+}
+
+sha512sums="ad2156d864cedcf3d19e8ff094d12059703aaf9a5ea8403e230ecf33d331dae45e0f28a89c65ad05f94605e493bc8d42df92698847600810d5609bc56ade24b8  skiboot-6.3.1.tar.gz
+e7480f16b6eb41fd65b40ea1f20031118030f24681b7b8afcfdebb8cde7625e45902683cfb5fe0af3259060fb1b92b9c2f5d62354de356e7706a7f08ad9f772e  musl.patch
+944dd564a2c846a675544c8ecdb2fa4714235f3fd974e135a71220379640f94883811399fe03d2d697fcb49e219504af264af0f201a6a7b37029687dea6a28cf  opal-prd.patch"
diff --git a/user/opal-utils/musl.patch b/user/opal-utils/musl.patch
new file mode 100644
index 000000000..5835935e8
--- /dev/null
+++ b/user/opal-utils/musl.patch
@@ -0,0 +1,36 @@
+--- skiboot-6.3.1/ccan/endian/endian.h.old	2019-05-10 06:50:45.000000000 +0000
++++ skiboot-6.3.1/ccan/endian/endian.h	2019-06-04 07:57:14.416435679 +0000
+@@ -112,9 +112,9 @@
+ #error "Unknown endian"
+ #elif HAVE_LITTLE_ENDIAN && HAVE_BIG_ENDIAN
+ #error "Can't compile for both big and little endian."
+-#elif HAVE_LITTLE_ENDIAN
++#elif HAVE_LITTLE_ENDIAN && !defined(__BYTE_ORDER)
+ #define __BYTE_ORDER	__LITTLE_ENDIAN
+-#elif HAVE_BIG_ENDIAN
++#elif HAVE_BIG_ENDIAN && !defined(__BYTE_ORDER)
+ #define __BYTE_ORDER	__BIG_ENDIAN
+ #endif
+ 
+--- skiboot-6.3.1/include/inttypes.h.old	2019-05-10 06:50:45.000000000 +0000
++++ skiboot-6.3.1/include/inttypes.h	2019-06-04 08:07:42.108161539 +0000
+@@ -25,15 +25,15 @@
+ 
+ #include <stdint.h>
+ 
+-#ifndef __WORDSIZE
+-/* If we don't have __WORDSIZE it means we're *certainly* building skiboot
++#ifndef __LONG_WIDTH__
++/* If we don't have __LONG_WIDTH__ it means we're *certainly* building skiboot
+  * which will *ALWAYS* have a word size of 32bits.
+  * (unless someone goes and ports skiboot to something that isn't powerpc)
+  */
+-#define __WORDSIZE 32
++#define __LONG_WIDTH__ 32
+ #endif
+ 
+-#if __WORDSIZE == 64
++#if __LONG_WIDTH__ == 64
+ #define PRIu64 "lu"
+ #define PRIx64 "lx"
+ #else
diff --git a/user/opal-utils/opal-prd.patch b/user/opal-utils/opal-prd.patch
new file mode 100644
index 000000000..29b38cd43
--- /dev/null
+++ b/user/opal-utils/opal-prd.patch
@@ -0,0 +1,8 @@
+--- skiboot-6.3.1/external/opal-prd/thunk.S.old	2019-05-10 06:50:45.000000000 +0000
++++ skiboot-6.3.1/external/opal-prd/thunk.S	2019-06-04 08:01:00.851806263 +0000
+@@ -1,4 +1,4 @@
+-#include <endian.h>
++#define __BYTE_ORDER __BIG_ENDIAN
+ #include <asm/unistd.h>
+ 
+ #ifndef __NR_switch_endian
-- 
cgit v1.2.3-70-g09d2