From 57ba41a5c0b9244b3e87536235a3ce4e28c44c64 Mon Sep 17 00:00:00 2001
From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
Date: Sun, 4 Dec 2022 00:40:14 +0000
Subject: user/py3-twisted: Regenerate raiser.c for Py3.11

Fixes: #895
---
 user/py3-twisted/APKBUILD | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

(limited to 'user/py3-twisted')

diff --git a/user/py3-twisted/APKBUILD b/user/py3-twisted/APKBUILD
index 408081052..8bc9e72dd 100644
--- a/user/py3-twisted/APKBUILD
+++ b/user/py3-twisted/APKBUILD
@@ -13,7 +13,7 @@ arch="all"
 # also need to be packaged and added to depends=
 options="net"
 license="MIT"
-depends="python3 py3-attrs py3-incremental py3-zope-interface"
+depends="python3 py3-attrs py3-cython py3-incremental py3-zope-interface"
 makedepends="python3-dev"
 subpackages=""
 source="https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.bz2
@@ -30,6 +30,7 @@ builddir="$srcdir/Twisted-$pkgver"
 #     - CVE-2020-10109
 
 build() {
+	(cd "$builddir"/src/twisted/test && cython raiser.pyx)
 	python3 setup.py build
 }
 
-- 
cgit v1.2.3-70-g09d2