From 3e48a440a5fe6f14babfe5c77d25302433c68b37 Mon Sep 17 00:00:00 2001
From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
Date: Wed, 18 Jul 2018 23:17:47 -0500
Subject: user/speex: This is a commit of Speex, an audio compression codec
 specifically tuned for the reproduction of human speech

---
 user/speex/APKBUILD | 40 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)
 create mode 100644 user/speex/APKBUILD

(limited to 'user/speex')

diff --git a/user/speex/APKBUILD b/user/speex/APKBUILD
new file mode 100644
index 000000000..c39ae6691
--- /dev/null
+++ b/user/speex/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: 
+pkgname=speex
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Audio compression format designed for speech"
+url="https://www.speex.org/"
+arch="all"
+options="!check"  # Test suite is for Win32 only.
+license="BSD-3-Clause"
+depends=""
+makedepends="libogg-dev speexdsp-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
+source="https://downloads.us.xiph.org/releases/speex/speex-$pkgver.tar.gz"
+
+build() {
+	cd "$builddir"
+	./configure \
+		--build=$CBUILD \
+		--host=$CHOST \
+		--prefix=/usr \
+		--sysconfdir=/etc \
+		--mandir=/usr/share/man \
+		--infodir=/usr/share/info \
+		--disable-static \
+		--enable-binaries
+	make
+}
+
+package() {
+	cd "$builddir"
+	make -j1 DESTDIR="$pkgdir" install
+}
+
+tools() {
+	pkgdesc="$pkgdesc - command line tools"
+	mkdir -p "$subpkgdir"/usr
+	mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+sha512sums="7fe10838c7d1bafcbe42295b82b79262420dba793b8a4388e2f73a3007850b5572face1b5308d9f4e8d7dfc9cb1c016cbad88cd65b2892667986107ed946836b  speex-1.2.0.tar.gz"
-- 
cgit v1.2.3-70-g09d2