From c887e52046cd233bbac6525c9043068220d5aed6 Mon Sep 17 00:00:00 2001
From: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
Date: Tue, 19 Feb 2019 09:16:44 -0600
Subject: user/weechat: upgrade to 2.4

---
 user/weechat/APKBUILD                 | 10 +++-------
 user/weechat/fix-python-linking.patch | 11 -----------
 user/weechat/fix-unsigned-char.patch  | 37 -----------------------------------
 3 files changed, 3 insertions(+), 55 deletions(-)
 delete mode 100644 user/weechat/fix-python-linking.patch
 delete mode 100644 user/weechat/fix-unsigned-char.patch

(limited to 'user')

diff --git a/user/weechat/APKBUILD b/user/weechat/APKBUILD
index 6f8bb3701..b298be73a 100644
--- a/user/weechat/APKBUILD
+++ b/user/weechat/APKBUILD
@@ -2,8 +2,8 @@
 # Contributor: zlg <zlg+adelie@zlg.space>
 # Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
 pkgname=weechat
-pkgver=2.3
-pkgrel=1
+pkgver=2.4
+pkgrel=0
 pkgdesc="Fast, light, extensible ncurses-based chat client"
 url="https://www.weechat.org"
 arch="all"
@@ -16,8 +16,6 @@ checkdepends="cpputest"
 subpackages="$pkgname-dev $pkgname-aspell:_plugin $pkgname-lua:_plugin
 	$pkgname-perl:_plugin $pkgname-python:_plugin $pkgname-lang"
 source="https://www.weechat.org/files/src/$pkgname-$pkgver.tar.gz
-	fix-python-linking.patch
-	fix-unsigned-char.patch
 	libintl-fix.patch
 	"
 
@@ -63,7 +61,5 @@ check() {
 	ctest -V
 }
 
-sha512sums="3315eb672d099dec041a6ece268e3efac9f766fe8273b13810c9ed6bc9129ed0db9730a027db6cdf157338472caf99d60aaf3de9b096a3c395fdf889b106aaea  weechat-2.3.tar.gz
-95f6d1405141421fae70288ec560a6d61f0bde1ce0bfa6e522e24a9673e699099594e83511b39e413aff28010ea1f7f1672af051ac370b152c732d6ca36a9056  fix-python-linking.patch
-e9dddc914f08660c49fd3331ebdca73a3df7e165b284d8b19e0487974ec2d8d75d03cd6d07da6ba9783015ddb19d6c118b697a830dcbea13f078ca7826223370  fix-unsigned-char.patch
+sha512sums="3537c3032237b0f1d103849516ccb461a29e13bf37f021af7905c75a3dc7c70fa4a76be2e8559b0299165c114d0408f3267fb74eb21a70f1661e6dac35e3bb9a  weechat-2.4.tar.gz
 59841bc343b1d10a542631eb01380789f96cac896380dbb3b159444c4806bd6367952e457b9ffd42fb87c1e19fc77eba78c38fd2178ef202ab9f7f1a543417ca  libintl-fix.patch"
diff --git a/user/weechat/fix-python-linking.patch b/user/weechat/fix-python-linking.patch
deleted file mode 100644
index c45d3af3a..000000000
--- a/user/weechat/fix-python-linking.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- weechat-1.9/cmake/FindPython.cmake.old	2017-06-25 03:20:52.000000000 -0500
-+++ weechat-1.9/cmake/FindPython.cmake	2017-09-24 18:04:48.181662013 -0500
-@@ -67,7 +67,7 @@
-     )
-   if(ENABLE_PYTHON3)
-     find_library(PYTHON_LIBRARY
--      NAMES python3.7 python3.6 python3.5 python3.4 python3.3 python3.2 python3.1 python3.0 python3 python2.7 python2.6 python2.5 python
-+      NAMES python3.7m python3.7 python3.6m python3.6 python3.5m python3.5 python3.4m python3.4 python3.3 python3.2 python3.1 python3.0 python3
-       HINTS ${PYTHON_POSSIBLE_LIB_PATH}
-       )
-   else()
diff --git a/user/weechat/fix-unsigned-char.patch b/user/weechat/fix-unsigned-char.patch
deleted file mode 100644
index d4acd1986..000000000
--- a/user/weechat/fix-unsigned-char.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-This patch is backported from the upcoming 2.4 release. It corrects
-highlighting behavior for plugins such as urlserver.py.
-
-See-Also: https://github.com/weechat/weechat/issues/1277
-Patch-Author: Sébastien Helleu <flashcode@flashtux.org>
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 0ae69ea0f..1d7738af5 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -27,8 +27,8 @@ project(weechat C)
- set(CMAKE_VERBOSE_MAKEFILE OFF)
- set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake ${CMAKE_MODULE_PATH})
- set(CMAKE_SKIP_RPATH ON)
--set(CMAKE_C_FLAGS   "${CMAKE_C_FLAGS} -Wall -Wextra -Werror-implicit-function-declaration")
--set(CMAKE_CXX_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Werror-implicit-function-declaration")
-+set(CMAKE_C_FLAGS   "${CMAKE_C_FLAGS} -fsigned-char -Wall -Wextra -Werror-implicit-function-declaration")
-+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fsigned-char -Wall -Wextra -Werror-implicit-function-declaration")
- 
- # version
- execute_process(COMMAND ${CMAKE_SOURCE_DIR}/version.sh devel-major OUTPUT_VARIABLE VERSION_MAJOR)
-diff --git a/configure.ac b/configure.ac
-index d267ca10f..a0bf00078 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1330,7 +1330,7 @@ AC_DEFINE_UNQUOTED(WEECHAT_SHAREDIR, "$WEECHAT_SHAREDIR")
- weechat_libdir=${libdir}/weechat
- AC_SUBST(weechat_libdir)
- 
--COMMON_CFLAGS="-Wall -Wextra -Werror-implicit-function-declaration"
-+COMMON_CFLAGS="-fsigned-char -Wall -Wextra -Werror-implicit-function-declaration"
- AC_MSG_CHECKING([whether we have GNU assembler])
- GAS=`as --version < /dev/null 2>/dev/null | grep GNU`
- if test "$GAS"; then
--- 
-2.19.1
-
-- 
cgit v1.2.3-70-g09d2