# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=gnumeric
pkgver=1.12.46
pkgrel=0
pkgdesc="GNOME spreadsheet software"
url="http://www.gnumeric.org/"
arch="all"
options="!check"  # Fails with:
# CRITICAL **: 20:41:56.049: go_conf_add_monitor: assertion 'node || key' failed
# no clue.
license="GPL-2.0-only OR GPL-3.0-only"
depends=""
makedepends="byacc gobject-introspection-dev goffice-dev>=0.10.46 gtk+3.0-dev intltool
	itstool libgda-dev libxml2-utils perl-dev zlib-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://ftp.gnome.org/pub/GNOME/sources/gnumeric/1.12/gnumeric-$pkgver.tar.xz"

build() {
	LIBS="-lintl" YACC=yacc ./configure \
		--build=$CBUILD \
		--host=$CHOST \
		--prefix=/usr \
		--sysconfdir=/etc \
		--mandir=/usr/share/man \
		--localstatedir=/var \
		--enable-introspection
	make
}

check() {
	make check
}

package() {
	make DESTDIR="$pkgdir" install
}

sha512sums="b3b3befe79f3ec8db6d7d9c80a1eed5293f5c0a9ca1d8dd131320eb031952b296147c51df1c775c6f9a0c466912e5523360373ee0b6e453e928929394ab517ea  gnumeric-1.12.46.tar.xz"