# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libfm-extra
pkgver=1.3.1
pkgrel=0
pkgdesc="Library for generating menu caches"
url="https://wiki.lxde.org/en/PCManFM"
arch="all"
license="GPL-2.0+"
depends=""
makedepends="glib-dev intltool"
subpackages="$pkgname-dev"
source="https://downloads.sourceforge.net/pcmanfm/libfm-$pkgver.tar.xz"
# because of course it's in the libfm tarball
builddir="$srcdir/libfm-$pkgver"

build() {
	./configure \
		--prefix=/usr \
		--sysconfdir=/etc \
		--with-extra-only \
		--disable-static
	make
}

check() {
	make check
}

package() {
	make DESTDIR="$pkgdir" install
}

sha512sums="f385cf7bf2f4800c11dd6474cd20009cbe1208f1d08570b61954ea8bd84c56cc49880cbf84d4b2aa4b91eb6929d017ebc427649391059b786d7e6fc4535e4f14  libfm-1.3.1.tar.xz"