# Contributor: William Pitcock <nenolod@dereferenced.org>
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Dan Theisen <djt@hxx.in>
# TODO: Repackage from better source, rehost or something.
pkgname=libxdg-basedir
pkgver=1.2.0
pkgrel=0
pkgdesc="library for XDG base dir specification"
url="https://nevill.ch/libxdg-basedir/"
arch="all"
license="MIT"
depends=""
makedepends=""
subpackages="$pkgname-dev"
source="https://nevill.ch/libxdg-basedir/downloads/$pkgname-$pkgver.tar.gz"

prepare() {
	cd "$builddir"
	default_prepare
	update_config_sub
}

build() {
	cd "$builddir"
	./configure \
		--build=$CBUILD \
		--host=$CHOST \
		--prefix=/usr \
		--sysconfdir=/etc \
	make
}

check() {
	cd "$builddir"
	make check
}

package() {
	cd "$builddir"
	make DESTDIR="$pkgdir" install
}

sha512sums="346553ddd9d0a0c854af9320f2ced695a0838adc18736b66120bea48ea60cb9ea3a7390672a42f83909db92f692e94de833d9e8bcfe51568a72ad1f4661fde06  libxdg-basedir-1.2.0.tar.gz"