# Contributor: Dan Theisen <djt@hxx.in>
# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
pkgname=perl-common-sense
_pkgreal=common-sense
_author=MLEHMANN
_au=${_author%%"${_author#??}"}
_a=${_author%%"${_author#?}"}
pkgver=3.75
pkgrel=0
pkgdesc="Implements some (in)sane defaults for Perl programs"
url="https://metacpan.org/pod/common::sense"
arch="noarch"
license="Artistic-1.0-Perl OR GPL-1.0+"
depends="perl"
makedepends="perl-dev"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"

build() {
	PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
	make
}

check() {
	make test
}

package() {
	make DESTDIR="$pkgdir" install
	find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}

sha512sums="cb6034d9ff721a4122e0215db8ad5279ec4b189c3364593d427d70a1e84a1583a0e1447e276aa9a4fcaeb2f9d47a465a5bc4c0f842c803d3ddf91755311f4af4  common-sense-3.75.tar.gz"