# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
pkgname=perl-data-dump
_pkgreal=Data-Dump
_author=GARU
_au=${_author%%"${_author#??}"}
_a=${_author%%"${_author#?}"}
pkgver=1.25
pkgrel=0
pkgdesc="Perl module for outputting data structures"
url="https://metacpan.org/pod/Data::Dump"
arch="noarch"
license="Artistic-1.0-Perl OR GPL-1.0+"
depends="perl"
makedepends="perl-dev"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"

build() {
	PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
	make
}

check() {
	make test
}

package() {
	make DESTDIR="$pkgdir" install
	find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}

sha512sums="fc859b0f02a44a959da3e162606c8fbaefececf8dbd0aa357d68a5a3143b818ae423dd7862063f2f77161ea000fcaa6841c96a2c4a268b889da9588292b157fe  Data-Dump-1.25.tar.gz"