# Contributor: Dan Theisen <djt@hxx.in>
# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
pkgname=perl-extutils-depends
_pkgreal=ExtUtils-Depends
_author=XAOC
_au=${_author%%"${_author#??}"}
_a=${_author%%"${_author#?}"}
pkgver=0.8001
pkgrel=0
pkgdesc="Easily build XS extensions that depend on XS extensions"
url="https://metacpan.org/release/ExtUtils-Depends"
arch="noarch"
license="Artistic-1.0-Perl OR GPL-1.0+"
depends="perl"
makedepends="perl-dev"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"

build() {
	PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
	make
}

check() {
	make test
}

package() {
	make DESTDIR="$pkgdir" install
	find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}

sha512sums="80141f90fbde7c62b192a55d40d26ce4e442150287ae6fe200388dc84cedba5f5210ee6cd9a40b1a9cda0cc49815b1ba1ab35e75afaa7440de3c3577d01bb733  ExtUtils-Depends-0.8001.tar.gz"