# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
pkgname=perl-list-moreutils-xs
_pkgreal=List-MoreUtils-XS
_author=REHSACK
_au=${_author%%"${_author#??}"}
_a=${_author%%"${_author#?}"}
pkgver=0.430
pkgrel=0
pkgdesc="Provide the stuff missing in List::Util in XS"
url="https://metacpan.org/release/List-MoreUtils-XS"
arch="all"
license="Apache-2.0"
depends="perl"
makedepends="perl-dev"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"

build() {
	PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
	make
}

check() {
	make test
}

package() {
	make DESTDIR="$pkgdir" install
	find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}

sha512sums="98260b81f03a425bf8c2e0b63bc3a8d360a0aa2e198b2b7faaeaa48684936183018afdd1e6a04bd7e99a7e728d809709c6206ea578dfe7d8d40c5a4e3e4bb405  List-MoreUtils-XS-0.430.tar.gz"