# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=qt5-qtsvg
_pkgname=qtsvg-everywhere-src
pkgver=5.12.9
pkgrel=0
pkgdesc="Qt SVG rendering library"
url="https://www.qt.io/"
arch="all"
license="LGPL-3.0-only WITH Qt-LGPL-exception-1.1 OR GPL-3.0-only WITH Qt-GPL-exception-1.0"
makedepends="qt5-qtbase-dev zlib-dev"
subpackages="$pkgname-dev"
source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz"
builddir="$srcdir"/$_pkgname-$pkgver

build() {
	qmake
	make
}

check() {
	make check
}

package() {
	make install INSTALL_ROOT="$pkgdir"
}

sha512sums="30e32772d9be1f7cec7cef905686dd861bb974dc74230575f9b2cd4aa2b28da5af3083b67872573f54976c5560486c5469b3fa1acb5ef86fe439367453c368f0  qtsvg-everywhere-src-5.12.9.tar.xz"