summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/hiptt/package.py
diff options
context:
space:
mode:
authorBrian Van Essen <vanessen1@llnl.gov>2023-08-14 07:11:30 -0700
committerGitHub <noreply@github.com>2023-08-14 16:11:30 +0200
commit1673d3e3223eefa609ab66ae11a9c0b1d244f7fe (patch)
tree50903ae2d1a8870cbfe2d44f977e060c05c29a3c /var/spack/repos/builtin/packages/hiptt/package.py
parentc7cca3aa8d11789eaee9bfc80b8417ffea511532 (diff)
downloadspack-1673d3e3223eefa609ab66ae11a9c0b1d244f7fe.tar.gz
spack-1673d3e3223eefa609ab66ae11a9c0b1d244f7fe.tar.bz2
spack-1673d3e3223eefa609ab66ae11a9c0b1d244f7fe.tar.xz
spack-1673d3e3223eefa609ab66ae11a9c0b1d244f7fe.zip
Added package for the hipTT library (#39388)
Diffstat (limited to 'var/spack/repos/builtin/packages/hiptt/package.py')
-rw-r--r--var/spack/repos/builtin/packages/hiptt/package.py35
1 files changed, 35 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/hiptt/package.py b/var/spack/repos/builtin/packages/hiptt/package.py
new file mode 100644
index 0000000000..d2c9e118a7
--- /dev/null
+++ b/var/spack/repos/builtin/packages/hiptt/package.py
@@ -0,0 +1,35 @@
+# Copyright 2013-2023 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
+#
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
+from spack.package import *
+
+
+class Hiptt(MakefilePackage, ROCmPackage):
+ """hipTT - Fast GPU Tensor Transpose for NVIDIA and AMD GPU."""
+
+ homepage = "https://github.com/DmitryLyakh/hipTT"
+ url = "https://github.com/DmitryLyakh/hipTT"
+ git = "https://github.com/DmitryLyakh/hipTT.git"
+ tags = ["ecp", "radiuss"]
+
+ maintainers("bvanessen")
+
+ version("master", branch="master")
+
+ patch("bugfix_make.patch")
+
+ # To enable this package add it to the LD_LIBRARY_PATH
+ def setup_dependent_build_environment(self, env, dependent_spec):
+ hiptt_home = self.spec["hiptt"].prefix
+ env.prepend_path("cuTT_ROOT", hiptt_home)
+ env.prepend_path("cuTT_LIBRARY", hiptt_home.lib)
+ env.prepend_path("cuTT_INCLUDE_PATH", hiptt_home.include)
+
+ def install(self, spec, prefix):
+ mkdir(prefix.bin)
+ install("bin/cutt_test", prefix.bin)
+ install("bin/cutt_bench", prefix.bin)
+ install_tree("lib", prefix.lib)
+ install_tree("include", prefix.include)