summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-04-16 23:43:54 -0500
committerKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-04-16 23:43:54 -0500
commit007b3c73cc85b18b775391e36bbaf6488fe687d8 (patch)
treebb37c16fd28ace5c820b3c88fc7ead0f75bfd022
parent8664ed2cd9850f6c0df47780bcab4766173b78da (diff)
downloadpackages-007b3c73cc85b18b775391e36bbaf6488fe687d8.tar.gz
packages-007b3c73cc85b18b775391e36bbaf6488fe687d8.tar.bz2
packages-007b3c73cc85b18b775391e36bbaf6488fe687d8.tar.xz
packages-007b3c73cc85b18b775391e36bbaf6488fe687d8.zip
user/libcroco: upgrade to 0.6.13
-rw-r--r--user/libcroco/APKBUILD10
-rw-r--r--user/libcroco/CVE-2017-7960.patch58
2 files changed, 4 insertions, 64 deletions
diff --git a/user/libcroco/APKBUILD b/user/libcroco/APKBUILD
index 5365445f7..0ed8d4685 100644
--- a/user/libcroco/APKBUILD
+++ b/user/libcroco/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer:
pkgname=libcroco
-pkgver=0.6.12
-pkgrel=2
+pkgver=0.6.13
+pkgrel=0
pkgdesc="GNOME CSS 2 parsing and manipulation toolkit"
url="https://gitlab.gnome.org/GNOME/libcroco"
arch="all"
@@ -11,8 +11,7 @@ subpackages="$pkgname-dev"
depends=
makedepends="glib-dev libxml2-dev"
checkdepends="cmd:which"
-source="https://download.gnome.org/sources/$pkgname/0.6/$pkgname-$pkgver.tar.xz
- CVE-2017-7960.patch"
+source="https://download.gnome.org/sources/$pkgname/0.6/$pkgname-$pkgver.tar.xz"
# secfixes:
# 0.6.12-r2:
@@ -38,5 +37,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="af9a171d5ccded255b57f170576e67155f12fa0f61ab3e379e907975f77afc37e82e22772c6019b2897cffc15b2425faf3ccfda92b1a45b23eda2519debabeb6 libcroco-0.6.12.tar.xz
-da26b95808d7f06c15afed306fac2a80012413bf96ad2cd249c7420a6f41a02d76abeb80b94705f24414f1986084aa4d864fd82038274f664fa91b31fbcabd30 CVE-2017-7960.patch"
+sha512sums="038a3ac9d160a8cf86a8a88c34367e154ef26ede289c93349332b7bc449a5199b51ea3611cebf3a2416ae23b9e45ecf8f9c6b24ea6d16a5519b796d3c7e272d4 libcroco-0.6.13.tar.xz"
diff --git a/user/libcroco/CVE-2017-7960.patch b/user/libcroco/CVE-2017-7960.patch
deleted file mode 100644
index 4561392c0..000000000
--- a/user/libcroco/CVE-2017-7960.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From 898e3a8c8c0314d2e6b106809a8e3e93cf9d4394 Mon Sep 17 00:00:00 2001
-From: Ignacio Casal Quinteiro <qignacio@amazon.com>
-Date: Sun, 16 Apr 2017 13:13:43 +0200
-Subject: [PATCH] input: check end of input before reading a byte
-
-When reading bytes we weren't check that the index wasn't
-out of bound and this could produce an invalid read which
-could deal to a security bug.
----
- src/cr-input.c | 11 +++++++++--
- 1 file changed, 9 insertions(+), 2 deletions(-)
-
-diff --git a/src/cr-input.c b/src/cr-input.c
-index 49000b1..3b63a88 100644
---- a/src/cr-input.c
-+++ b/src/cr-input.c
-@@ -256,7 +256,7 @@ cr_input_new_from_uri (const gchar * a_file_uri, enum CREncoding a_enc)
- *we should free buf here because it's own by CRInput.
- *(see the last parameter of cr_input_new_from_buf().
- */
-- buf = NULL ;
-+ buf = NULL;
- }
-
- cleanup:
-@@ -404,6 +404,8 @@ cr_input_get_nb_bytes_left (CRInput const * a_this)
- enum CRStatus
- cr_input_read_byte (CRInput * a_this, guchar * a_byte)
- {
-+ gulong nb_bytes_left = 0;
-+
- g_return_val_if_fail (a_this && PRIVATE (a_this)
- && a_byte, CR_BAD_PARAM_ERROR);
-
-@@ -413,6 +415,12 @@ cr_input_read_byte (CRInput * a_this, guchar * a_byte)
- if (PRIVATE (a_this)->end_of_input == TRUE)
- return CR_END_OF_INPUT_ERROR;
-
-+ nb_bytes_left = cr_input_get_nb_bytes_left (a_this);
-+
-+ if (nb_bytes_left < 1) {
-+ return CR_END_OF_INPUT_ERROR;
-+ }
-+
- *a_byte = PRIVATE (a_this)->in_buf[PRIVATE (a_this)->next_byte_index];
-
- if (PRIVATE (a_this)->nb_bytes -
-@@ -477,7 +485,6 @@ cr_input_read_char (CRInput * a_this, guint32 * a_char)
- if (*a_char == '\n') {
- PRIVATE (a_this)->end_of_line = TRUE;
- }
--
- }
-
- return status;
---
-2.17.1
-