summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2021-10-24 19:03:30 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2021-10-24 19:24:20 -0500
commit07f96151f33e7b8efe78cc397b2cfc5619baaabf (patch)
treef2f1cc571b72fe7c1bdc9edced132ee6a4da7bb2
parent8905fa7409ea656c66d11a95b9568884e8e951b8 (diff)
downloadpackages-07f96151f33e7b8efe78cc397b2cfc5619baaabf.tar.gz
packages-07f96151f33e7b8efe78cc397b2cfc5619baaabf.tar.bz2
packages-07f96151f33e7b8efe78cc397b2cfc5619baaabf.tar.xz
packages-07f96151f33e7b8efe78cc397b2cfc5619baaabf.zip
system/coreutils: Fix test suite under apkf
The chgrp calls fail because of supplementary group shens under fakeroot. Override the group detection to prevent this.
-rw-r--r--system/coreutils/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/system/coreutils/APKBUILD b/system/coreutils/APKBUILD
index 71c10cca4..a91eaf7b8 100644
--- a/system/coreutils/APKBUILD
+++ b/system/coreutils/APKBUILD
@@ -54,7 +54,9 @@ build() {
}
check() {
- make check
+ # This prevents 'chgrp' tests from breaking inside APK Foundry.
+ env COREUTILS_GROUPS='build' make -C tests check
+ # We can't run gnulb-tests because of multiple chown failures.
}
package() {