summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-12-11 20:49:19 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-12-11 20:49:19 -0600
commit0a9442b2f6d0ad1175a7d4a413c97832d6dec7b5 (patch)
tree03c7ebd07bf1c5b0d3c0d10f4550eb551b09f169
parent93194fcd4be5fafc1c6ac02781e2f6cc32de9093 (diff)
downloadpackages-0a9442b2f6d0ad1175a7d4a413c97832d6dec7b5.tar.gz
packages-0a9442b2f6d0ad1175a7d4a413c97832d6dec7b5.tar.bz2
packages-0a9442b2f6d0ad1175a7d4a413c97832d6dec7b5.tar.xz
packages-0a9442b2f6d0ad1175a7d4a413c97832d6dec7b5.zip
system/binutils: Bootstrapping fixes
* Add !tracedeps to options. This is required because since binutils has its own rpath, abuild(1) will try and seek out owner packages for all linked libraries. In the preimage environment, it can't find the owner of /lib/libc.so. * Add textrels to options. Apparently m68k binutils needs this. * Disable NLS as we don't need to have user-facing translated messages in the bootstrapping environment. * Disable shared libraries to prevent conflicts. I tried to use Gentoo's --with-extra-soversion-suffix patches, but they only worked on libctf[1]. libsframe is still a conflicting file. I could not find a way to disable shared only for libsframe. [1]: https://gitweb.gentoo.org/fork/binutils-gdb.git/commit/?h=gentoo/binutils-2.42&id=bc95c4f7765898935936e889bc8062f5a5f7804b
-rw-r--r--system/binutils/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/system/binutils/APKBUILD b/system/binutils/APKBUILD
index 06f7c4cb6..f6545f7d0 100644
--- a/system/binutils/APKBUILD
+++ b/system/binutils/APKBUILD
@@ -40,7 +40,7 @@ source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
if [ "$CHOST" != "$CTARGET" ]; then
pkgname="$pkgname-$CTARGET_ARCH"
subpackages=""
- options="!check"
+ options="!check textrels !tracedeps"
sonameprefix="$pkgname:"
builddir="$srcdir"/binutils-$pkgver
fi
@@ -75,7 +75,7 @@ build() {
if [ "$CHOST" != "$CTARGET" ]; then
_sysroot="$CBUILDROOT"
- _cross_configure="--disable-install-libiberty"
+ _cross_configure="--disable-install-libiberty --disable-nls --disable-shared"
fi
# -z separate-code is currently causing kernel miscompiles on x86*