summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-04-17 22:51:13 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-04-17 22:51:13 +0000
commit1164b81851b71ddbaeb60c285f3aebc6fb18ea63 (patch)
tree5c58c82e4e329a86c1508b6dfb4c325a7d9dc3f5
parent6e5b3282fb9a3360fdb5804d798e852a3938c9a9 (diff)
downloadpackages-1164b81851b71ddbaeb60c285f3aebc6fb18ea63.tar.gz
packages-1164b81851b71ddbaeb60c285f3aebc6fb18ea63.tar.bz2
packages-1164b81851b71ddbaeb60c285f3aebc6fb18ea63.tar.xz
packages-1164b81851b71ddbaeb60c285f3aebc6fb18ea63.zip
user/openttd: bump to 1.9.1
-rw-r--r--user/openttd/APKBUILD9
-rw-r--r--user/openttd/icu61.patch45
2 files changed, 3 insertions, 51 deletions
diff --git a/user/openttd/APKBUILD b/user/openttd/APKBUILD
index 63df0988e..2c185d8cb 100644
--- a/user/openttd/APKBUILD
+++ b/user/openttd/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=openttd
-pkgver=1.8.0
+pkgver=1.9.1
pkgrel=0
pkgdesc="Simulation game based on Transport Tycoon Deluxe"
url="https://www.openttd.org/en/"
@@ -12,9 +12,7 @@ depends="opengfx openmsx opensfx"
makedepends="fontconfig-dev freetype-dev icu-dev libpng-dev libxdg-basedir-dev
lzo-dev sdl-dev xz-dev zlib-dev"
subpackages="$pkgname-doc"
-source="https://binaries.openttd.org/releases/1.8.0/openttd-$pkgver-source.tar.xz
- icu61.patch
- "
+source="https://proxy.binaries.openttd.org/openttd-releases/$pkgver/openttd-$pkgver-source.tar.xz"
build() {
cd "$builddir"
@@ -32,5 +30,4 @@ package() {
make install
}
-sha512sums="a2d61b3c94a550c8f3a581127df8c3459b1ddff5ba924942c468cbc70e88e0bf4405cecb68a91243b544ead64f215aa8d489a07b38dce507ae7d59e8ec155d7a openttd-1.8.0-source.tar.xz
-db470433bcc68688b1a4cf71a514879c139300a778feb3f832bff0400b578d4b7720df6e259a86013334a661fce56c66d74aaf709d0027cf9638f006bebca10e icu61.patch"
+sha512sums="44d907299a14fd09ebff980f7c212bbdbd5def880bc56bfe106c3efa8cb32472bbcafdbb145d3f4340a3bc96179418f78fe2ddc62dd067b464eca73313b477c1 openttd-1.9.1-source.tar.xz"
diff --git a/user/openttd/icu61.patch b/user/openttd/icu61.patch
deleted file mode 100644
index e4143d82f..000000000
--- a/user/openttd/icu61.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 19076c24c1f3baf2a22d1fa832d5688216cf54a3 Mon Sep 17 00:00:00 2001
-From: Charles Pigott <charlespigott@googlemail.com>
-Date: Sun, 8 Apr 2018 01:06:18 +0100
-Subject: [PATCH] Fix #6690: Compilation with ICU 61
-
----
- src/language.h | 2 +-
- src/strings.cpp | 4 ++--
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/language.h b/src/language.h
-index d33ba81892..ec241dbd8c 100644
---- a/src/language.h
-+++ b/src/language.h
-@@ -105,7 +105,7 @@ extern LanguageList _languages;
- extern const LanguageMetadata *_current_language;
-
- #ifdef WITH_ICU_SORT
--extern Collator *_current_collator;
-+extern icu::Collator *_current_collator;
- #endif /* WITH_ICU_SORT */
-
- bool ReadLanguagePack(const LanguageMetadata *lang);
-diff --git a/src/strings.cpp b/src/strings.cpp
-index 1c539d9343..fd7420259a 100644
---- a/src/strings.cpp
-+++ b/src/strings.cpp
-@@ -52,7 +52,7 @@ const LanguageMetadata *_current_language = NULL; ///< The currently loaded lang
- TextDirection _current_text_dir; ///< Text direction of the currently selected language.
-
- #ifdef WITH_ICU_SORT
--Collator *_current_collator = NULL; ///< Collator for the language currently in use.
-+icu::Collator *_current_collator = NULL; ///< Collator for the language currently in use.
- #endif /* WITH_ICU_SORT */
-
- static uint64 _global_string_params_data[20]; ///< Global array of string parameters. To access, use #SetDParam.
-@@ -1795,7 +1795,7 @@ bool ReadLanguagePack(const LanguageMetadata *lang)
-
- /* Create a collator instance for our current locale. */
- UErrorCode status = U_ZERO_ERROR;
-- _current_collator = Collator::createInstance(Locale(_current_language->isocode), status);
-+ _current_collator = icu::Collator::createInstance(icu::Locale(_current_language->isocode), status);
- /* Sort number substrings by their numerical value. */
- if (_current_collator != NULL) _current_collator->setAttribute(UCOL_NUMERIC_COLLATION, UCOL_ON, status);
- /* Avoid using the collator if it is not correctly set. */