summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2020-03-24 02:31:34 -0500
committerMax Rees <maxcrees@me.com>2020-03-24 02:52:10 -0500
commit1dae15ee57313f28cab47f14a99f64a9d24a8579 (patch)
treed3e67993c277f443503fff1d38a6dd8a4e4c90f7
parent89716e150c4103445da0047908fc16d9a5dafec3 (diff)
downloadpackages-1dae15ee57313f28cab47f14a99f64a9d24a8579.tar.gz
packages-1dae15ee57313f28cab47f14a99f64a9d24a8579.tar.bz2
packages-1dae15ee57313f28cab47f14a99f64a9d24a8579.tar.xz
packages-1dae15ee57313f28cab47f14a99f64a9d24a8579.zip
user/sshfs: bump to 3.7.0
-rw-r--r--user/sshfs/APKBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/user/sshfs/APKBUILD b/user/sshfs/APKBUILD
index c6fe305e9..d3f1ce3f0 100644
--- a/user/sshfs/APKBUILD
+++ b/user/sshfs/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=sshfs
-pkgver=3.6.0
+pkgver=3.7.0
pkgrel=0
pkgdesc="FUSE client based on the SSH File Transfer Protocol"
url="https://github.com/libfuse/sshfs"
@@ -9,7 +9,7 @@ arch="all"
options="!check" # Requires fuse kernel module to be loaded and local ssh server
license="GPL-2.0-only AND GPL-2.0+ AND LGPL-2.1-only"
depends="openssh-client"
-#checkdepends="py3-pytest cmd:which"
+#checkdepends="cmd:which openssh-server openssh-sftp-server py3-pytest"
makedepends="fuse3-dev glib-dev meson coreutils py3-docutils"
subpackages="$pkgname-doc"
source="https://github.com/libfuse/$pkgname/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.xz"
@@ -32,6 +32,16 @@ build() {
}
check() {
+ # This test requires a running SSH server on localhost, with the
+ # current user being able to login without a password. Recommended
+ # procedure:
+ #
+ # 1. Setup sshd - make sure sftp subsystem is enabled
+ # 2. Ensure current user has a SSH key configured in ~/.ssh/config and
+ # ~/.ssh/authorized_keys
+ # 3. Test `ssh localhost`
+ # 4. Run `abuild check`
+
cd "$builddir"/output
python3 -m pytest test/
}
@@ -40,4 +50,4 @@ package() {
DESTDIR="$pkgdir" ninja -C output install
}
-sha512sums="fe34d7bbb76bea6aedf96b4ce7500ad6d81230cca9a43b831302159e5926797a243b7d1675d23ba101057ef247f64ad7df18a73d20578e84b9524218d9ff97bd sshfs-3.6.0.tar.xz"
+sha512sums="bd8bcd45dd9a5e9686c6fb442e877ffdb592ba0d3424d5dab84a955bfafb17e8666abefba6857467833f5b285842bdadd5a9b6c9e8128ac2e564c36df79aa570 sshfs-3.7.0.tar.xz"