summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-04-28 20:56:30 +0000
committerZach van Rijn <me@zv.io>2022-10-21 18:33:58 -0500
commit203c23f8cdabf1be9cbd4bb07b2f507a56bb3ca9 (patch)
treeebf1ffedb841d87491d1312b73773fcd379749b8
parent624e14df6f662abd56aae050d715d700487aa939 (diff)
downloadpackages-203c23f8cdabf1be9cbd4bb07b2f507a56bb3ca9.tar.gz
packages-203c23f8cdabf1be9cbd4bb07b2f507a56bb3ca9.tar.bz2
packages-203c23f8cdabf1be9cbd4bb07b2f507a56bb3ca9.tar.xz
packages-203c23f8cdabf1be9cbd4bb07b2f507a56bb3ca9.zip
user/efibootmgr: bump { 16 --> 17 }. fixes #607.
-rw-r--r--user/efibootmgr/APKBUILD15
-rw-r--r--user/efibootmgr/fix-efiboot-includes.patch66
2 files changed, 75 insertions, 6 deletions
diff --git a/user/efibootmgr/APKBUILD b/user/efibootmgr/APKBUILD
index 379316b65..b977b8855 100644
--- a/user/efibootmgr/APKBUILD
+++ b/user/efibootmgr/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=efibootmgr
-pkgver=16
+pkgver=17
pkgrel=0
pkgdesc="User-space application to modify the Intel EFI Boot Manager"
url="https://github.com/rhboot/efibootmgr"
@@ -9,16 +9,19 @@ arch="pmmx x86_64 aarch64 ia64"
options="!check" # Dangerous.
license="GPL-2.0-only"
depends=""
-makedepends="efivar-dev"
+makedepends="efivar-dev popt-dev pkgconf"
subpackages="$pkgname-doc"
-source="https://github.com/rhboot/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2"
+source="https://github.com/rhboot/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2
+ fix-efiboot-includes.patch
+ "
build() {
- make EFIDIR="Adelie" libdir="/usr/lib" LIBS="intl"
+ make EFIDIR="Adelie"
}
package() {
- make EFIDIR="Adelie" libdir="/usr/lib" LIBS="intl" DESTDIR="$pkgdir" install
+ make EFIDIR="Adelie" DESTDIR="$pkgdir" install
}
-sha512sums="936318c7163c07b716f89be3d830957d9db68ba1b059223f7ea3d9eafe0dbf1c91b9aee096f5aed70955c6052c3b8547295c0a47f17cdf43788259d87d1990b9 efibootmgr-16.tar.bz2"
+sha512sums="59a2a6e7885886ab3cdd2e733f1ae2d2fc76b307a9848706af6bf4197acbea8d2a0b1105fc4983252c8d204af974b417a03b9cc66d0541f8a68503c47268a601 efibootmgr-17.tar.bz2
+055cdebafce1993a600148d74f61785a7c217d73c9868d542ff7eecca3a0236010495473ecdcd568fbfb7301e7c55ba766d4803089af32d88772451481f83a2b fix-efiboot-includes.patch"
diff --git a/user/efibootmgr/fix-efiboot-includes.patch b/user/efibootmgr/fix-efiboot-includes.patch
new file mode 100644
index 000000000..cfcab07f2
--- /dev/null
+++ b/user/efibootmgr/fix-efiboot-includes.patch
@@ -0,0 +1,66 @@
+diff -ur a/src/efi.c b/src/efi.c
+--- a/src/efi.c 2022-04-28 19:57:19.197635727 +0000
++++ b/src/efi.c 2022-04-28 19:57:53.558571268 +0000
+@@ -25,8 +25,8 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#include <efiboot.h>
+-#include <efivar.h>
++#include <efivar/efiboot.h>
++#include <efivar/efivar.h>
+ #include <errno.h>
+ #include <stdint.h>
+ #include <sys/stat.h>
+diff -ur a/src/efibootdump.c b/src/efibootdump.c
+--- a/src/efibootdump.c 2022-04-28 19:57:19.197635727 +0000
++++ b/src/efibootdump.c 2022-04-28 19:57:45.128341742 +0000
+@@ -11,8 +11,8 @@
+ #include "fix_coverity.h"
+
+ #include <ctype.h>
+-#include <efiboot.h>
+-#include <efivar.h>
++#include <efivar/efiboot.h>
++#include <efivar/efivar.h>
+ #include <err.h>
+ #include <inttypes.h>
+ #include <libintl.h>
+diff -ur a/src/efibootmgr.c b/src/efibootmgr.c
+--- a/src/efibootmgr.c 2022-04-28 19:57:19.197635727 +0000
++++ b/src/efibootmgr.c 2022-04-28 19:57:35.418077359 +0000
+@@ -47,8 +47,8 @@
+ #include <dirent.h>
+ #include <unistd.h>
+ #include <getopt.h>
+-#include <efivar.h>
+-#include <efiboot.h>
++#include <efivar/efivar.h>
++#include <efivar/efiboot.h>
+ #include <inttypes.h>
+
+ #include "list.h"
+diff -ur a/src/eficonman.c b/src/eficonman.c
+--- a/src/eficonman.c 2022-04-28 19:57:19.197635727 +0000
++++ b/src/eficonman.c 2022-04-28 19:58:41.789884456 +0000
+@@ -10,7 +10,7 @@
+
+ #include "fix_coverity.h"
+
+-#include <efivar.h>
++#include <efivar/efivar.h>
+ #include <err.h>
+ #include <inttypes.h>
+ #include <libintl.h>
+diff -ur a/src/include/efi.h b/src/include/efi.h
+--- a/src/include/efi.h 2022-04-28 19:57:19.197635727 +0000
++++ b/src/include/efi.h 2022-04-28 19:58:57.110301583 +0000
+@@ -29,7 +29,7 @@
+ #include <stdint.h>
+ #include <dirent.h>
+
+-#include <efivar.h>
++#include <efivar/efivar.h>
+
+ /*******************************************************
+ * Boot Option Attributes