summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 10:35:07 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 10:35:07 +0000
commit20b49018c40a8128596be4450639bb4252be6e15 (patch)
treead628ac854a36c5979d83df0be7aaffbfde6339d
parent60669ea0bb74adb5892714a8580e984eb446fb53 (diff)
downloadpackages-20b49018c40a8128596be4450639bb4252be6e15.tar.gz
packages-20b49018c40a8128596be4450639bb4252be6e15.tar.bz2
packages-20b49018c40a8128596be4450639bb4252be6e15.tar.xz
packages-20b49018c40a8128596be4450639bb4252be6e15.zip
user/*: Modernise / fix syntax / deps / metadata
-rw-r--r--user/adelie-kde-theme/APKBUILD3
-rw-r--r--user/aspell-dict-sk/APKBUILD2
-rw-r--r--user/command-not-found/APKBUILD9
-rw-r--r--user/gprbuild/APKBUILD8
-rw-r--r--user/lxqt-build-tools/APKBUILD2
-rw-r--r--user/pidgin/APKBUILD3
-rw-r--r--user/py3-alabaster/APKBUILD5
-rw-r--r--user/py3-docutils/APKBUILD13
-rw-r--r--user/py3-markupsafe/APKBUILD7
-rw-r--r--user/py3-mock/APKBUILD2
-rw-r--r--user/py3-olefile/APKBUILD4
-rw-r--r--user/py3-pillow/APKBUILD7
-rw-r--r--user/py3-six/APKBUILD5
-rw-r--r--user/utf8proc/APKBUILD2
-rw-r--r--user/xclipboard/APKBUILD3
15 files changed, 27 insertions, 48 deletions
diff --git a/user/adelie-kde-theme/APKBUILD b/user/adelie-kde-theme/APKBUILD
index 5eb3e9509..9cc8badd5 100644
--- a/user/adelie-kde-theme/APKBUILD
+++ b/user/adelie-kde-theme/APKBUILD
@@ -9,6 +9,8 @@ arch="noarch"
options="!check" # No test suite.
license="NCSA"
depends="adelie-wallpapers papirus-icons"
+makedepends=""
+subpackages=""
source="kdeglobals
kscreenlockerrc
adelie-kde-theme.js
@@ -16,7 +18,6 @@ source="kdeglobals
builddir="$srcdir/"
package() {
- cd "$builddir"
install -D -m644 kdeglobals "$pkgdir"/etc/xdg/kdeglobals
install -m644 kscreenlockerrc "$pkgdir"/etc/xdg/kscreenlockerrc
install -D -m644 adelie-kde-theme.js \
diff --git a/user/aspell-dict-sk/APKBUILD b/user/aspell-dict-sk/APKBUILD
index 831456f53..466ee7cb7 100644
--- a/user/aspell-dict-sk/APKBUILD
+++ b/user/aspell-dict-sk/APKBUILD
@@ -11,7 +11,7 @@ options="!check" # No test suite.
license="GPL-2.0-only"
depends="aspell"
makedepends="debianutils-which"
-source="http://www.sk-spell.sk.cx/file_download/103/aspell6-sk-$_pkgver.tar.bz2"
+source="https://distfiles.adelielinux.org/source/aspell6-sk-$_pkgver.tar.bz2"
builddir="$srcdir/aspell6-sk-$_pkgver"
build() {
diff --git a/user/command-not-found/APKBUILD b/user/command-not-found/APKBUILD
index 96cd1127d..ed9919343 100644
--- a/user/command-not-found/APKBUILD
+++ b/user/command-not-found/APKBUILD
@@ -11,13 +11,12 @@ license="MIT"
depends="apk-tools"
makedepends=""
subpackages="$pkgname-bash $pkgname-zsh"
-source="$pkgname-$pkgver.tar.gz::https://git.dereferenced.org/kaniini/command-not-found/archive/v$pkgver.tar.gz
+source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.gz
explicit-apk-path.patch
"
builddir="$srcdir/$pkgname"
package() {
- cd "$builddir"
install -d -D -m755 "$pkgdir"/usr/libexec
install -m755 command-not-found.sh "$pkgdir"/usr/libexec/command-not-found
}
@@ -25,17 +24,15 @@ package() {
bash() {
pkgdesc="$pkgdesc (Bash shell support)"
install_if="$pkgname=$pkgver-r$pkgrel bash"
- cd "$builddir"
install -d -D -m755 "$subpkgdir"/etc/profile.d/
- install -m755 profiles/command-not-found.ash "$subpkgdir"/etc/profile.d/command-not-found.sh
+ install -m755 "$builddir"/profiles/command-not-found.ash "$subpkgdir"/etc/profile.d/command-not-found.sh
}
zsh() {
pkgdesc="$pkgdesc (Z shell support)"
install_if="$pkgname=$pkgver-r$pkgrel zsh"
- cd "$builddir"
install -d -D -m755 "$subpkgdir"/etc/zprofile.d/
- install -m755 profiles/command-not-found.zsh "$subpkgdir"/etc/zprofile.d/command-not-found.zsh
+ install -m755 "$builddir"/profiles/command-not-found.zsh "$subpkgdir"/etc/zprofile.d/command-not-found.zsh
}
sha512sums="a9fc6cf063195abf4bbf015f770b93fb23e2afc0efbed10a54adc1e0d38d7f9a57ab5817a52e483dd01aa21888e76f5aaefdbf89c835f227be2f150848ddb7ad command-not-found-0.3.tar.gz
diff --git a/user/gprbuild/APKBUILD b/user/gprbuild/APKBUILD
index 46cd8f81d..4ffe06950 100644
--- a/user/gprbuild/APKBUILD
+++ b/user/gprbuild/APKBUILD
@@ -9,10 +9,12 @@ url="https://github.com/AdaCore/gprbuild"
arch="all"
options="!check" # No test suite.
license="GPL-3.0+"
+depends=""
makedepends="gcc-gnat"
-source="$pkgname-$_pkgver-src.tar.gz::http://mirrors.cdn.adacore.com/art/5cdf8e8031e87a8f1d425093
- xmlada-$_xmlver-src.tar.gz::http://mirrors.cdn.adacore.com/art/5cdf916831e87a8f1d4250b5
- foxkit.xml"
+source="https://distfiles.adelielinux.org/source/$pkgname-$_pkgver-src.tar.gz
+ https://distfiles.adelielinux.org/source/xmlada-$_xmlver-src.tar.gz
+ foxkit.xml
+ "
builddir="$srcdir/$pkgname-$_pkgver-src"
build() {
diff --git a/user/lxqt-build-tools/APKBUILD b/user/lxqt-build-tools/APKBUILD
index 05e730aae..a2ffa3160 100644
--- a/user/lxqt-build-tools/APKBUILD
+++ b/user/lxqt-build-tools/APKBUILD
@@ -11,10 +11,10 @@ options="!check"
license="BSD-3-Clause"
depends=""
makedepends="cmake extra-cmake-modules qt5-qtbase-dev"
+subpackages=""
source="lxqt-build-tools-$pkgver.tar.gz::https://github.com/lxde/lxqt-build-tools/archive/$pkgver.tar.gz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
diff --git a/user/pidgin/APKBUILD b/user/pidgin/APKBUILD
index 905fe0558..83ee02c14 100644
--- a/user/pidgin/APKBUILD
+++ b/user/pidgin/APKBUILD
@@ -15,7 +15,6 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-lang finch libpurple"
source="https://bitbucket.org/pidgin/main/downloads/$pkgname-$pkgver.tar.bz2"
build() {
- cd "$builddir"
LIBS="-lX11 -ltinfo" ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -42,12 +41,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/py3-alabaster/APKBUILD b/user/py3-alabaster/APKBUILD
index 4bf90edf0..becfde6d2 100644
--- a/user/py3-alabaster/APKBUILD
+++ b/user/py3-alabaster/APKBUILD
@@ -13,24 +13,21 @@ arch="noarch"
license="BSD-3-Clause"
depends="python3 py3-pygments"
makedepends="python3-dev"
+subpackages=""
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
# Zero tests currently.
python3 setup.py test
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
-
}
sha512sums="e3bfd0c92ce01f08d5e6d9dc1ef0967ca1f54827e08756f4a0ba7be8d3b8bec7f2e53a169b831ff5ce2d2548f7f52c6e518bcc513e49bb3e4c38274293aebbac py3-alabaster-0.7.12.tar.gz"
diff --git a/user/py3-docutils/APKBUILD b/user/py3-docutils/APKBUILD
index c07253ad7..5c1db1353 100644
--- a/user/py3-docutils/APKBUILD
+++ b/user/py3-docutils/APKBUILD
@@ -38,16 +38,15 @@ package() {
doc() {
default_doc
- cd "$builddir"
- local docdir="$subpkgdir/usr/share/doc/$pkgname"
+ docdir="$subpkgdir/usr/share/doc/$pkgname"
mkdir -p "$docdir"
- cp -R docs/* "$docdir"
- cp *.txt "$docdir"
+ cp -R "$builddir"/docs/* "$docdir"
+ cp "$builddir"/*.txt "$docdir"
- local licdir="$subpkgdir/usr/share/licenses/$pkgname"
+ licdir="$subpkgdir/usr/share/licenses/$pkgname"
mkdir -p "$licdir"
- rm -f licenses/docutils.conf
- cp licenses/* "$licdir"
+ rm -f "$builddir"/licenses/docutils.conf
+ cp "$builddir"/licenses/* "$licdir"
}
sha512sums="b4528c7eba5a27e40f290a9df6894c277d11906d02f6842b9f364b29af9aa1e46f6008c87e4355947bcfa9f2db1cae9f38cf9fa7b8008ba45fa6d685922003a6 py3-docutils-0.15.2.tar.gz"
diff --git a/user/py3-markupsafe/APKBUILD b/user/py3-markupsafe/APKBUILD
index ced64dfdf..a9721b9d3 100644
--- a/user/py3-markupsafe/APKBUILD
+++ b/user/py3-markupsafe/APKBUILD
@@ -11,25 +11,22 @@ url="https://pypi.python.org/pypi/MarkupSafe"
arch="all"
license="BSD-3-Clause"
depends="python3"
-makedepends="python3-dev"
checkdepends="py3-pytest"
+makedepends="python3-dev"
+subpackages=""
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
PYTHONPATH="$PYTHONPATH:$(echo build/lib.*)" pytest
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
-
}
sha512sums="f3014e6131a3ab866914c5635b5397ef71906bffb1b6f8c5f2ed2acf167429ff7914236d38943e872683a57a9be9669f4c5aace6274f3307ab21ef25373db0b6 py3-markupsafe-1.1.1.tar.gz"
diff --git a/user/py3-mock/APKBUILD b/user/py3-mock/APKBUILD
index 28047234a..4445df141 100644
--- a/user/py3-mock/APKBUILD
+++ b/user/py3-mock/APKBUILD
@@ -19,13 +19,11 @@ source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
package() {
mkdir -p "$pkgdir"
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
diff --git a/user/py3-olefile/APKBUILD b/user/py3-olefile/APKBUILD
index c44ee5842..a890d231f 100644
--- a/user/py3-olefile/APKBUILD
+++ b/user/py3-olefile/APKBUILD
@@ -11,21 +11,19 @@ arch="noarch"
license="BSD-2-Clause AND Custom"
depends="python3"
makedepends="python3-dev unzip"
+subpackages=""
source="$pkgname-$pkgver.zip::https://files.pythonhosted.org/packages/source/o/$_pkgname/$_pkgname-$pkgver.zip"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
PYTHONPATH="build/lib" python3 tests/test_olefile.py
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
}
diff --git a/user/py3-pillow/APKBUILD b/user/py3-pillow/APKBUILD
index c47d31b1e..8012a6fe2 100644
--- a/user/py3-pillow/APKBUILD
+++ b/user/py3-pillow/APKBUILD
@@ -43,11 +43,10 @@ doc() {
pkgdesc="Example scripts for $pkgname"
depends="$pkgname"
- cd "$builddir"
- local destdir="$subpkgdir/usr/share/doc/$pkgname"
+ destdir="$subpkgdir/usr/share/doc/$pkgname"
install -d "$destdir"/Scripts
- install -m 644 Scripts/* "$destdir"/Scripts/
- install -Dm644 LICENSE "$subpkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -m 644 "$builddir"/Scripts/* "$destdir"/Scripts/
+ install -Dm644 "$builddir"/LICENSE "$subpkgdir/usr/share/licenses/$pkgname/LICENSE"
}
sha512sums="757bfdab2ba418195e96e696d2d111de3b38b6bafe4f6f94012f024f59c9bc8542fdab54f643eaf7b2867a9214db806e72eecbdd636bfceb55b47d3164f643ec py3-pillow-6.2.1.tar.gz
diff --git a/user/py3-six/APKBUILD b/user/py3-six/APKBUILD
index 94ece5835..32beed401 100644
--- a/user/py3-six/APKBUILD
+++ b/user/py3-six/APKBUILD
@@ -10,23 +10,20 @@ arch="noarch"
options="!check" # Circular dependency with py3-pytest
license="MIT"
depends=""
-makedepends="python3-dev"
#checkdepends="py3-pluggy py3-pytest"
+makedepends="python3-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/benjaminp/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 setup.py test
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
diff --git a/user/utf8proc/APKBUILD b/user/utf8proc/APKBUILD
index 4b8d6ac3a..459901e02 100644
--- a/user/utf8proc/APKBUILD
+++ b/user/utf8proc/APKBUILD
@@ -8,7 +8,7 @@ url="http://juliastrings.github.io/utf8proc"
arch="all"
license="MIT AND Unicode-DFS-2016"
depends=""
-makedepends=""
+makedepends="cmake"
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/JuliaStrings/utf8proc/archive/v$pkgver.tar.gz
https://dev.sick.bike/dist/$pkgname-testdata-$pkgver.tar.gz"
diff --git a/user/xclipboard/APKBUILD b/user/xclipboard/APKBUILD
index b0219ea81..f5f75114e 100644
--- a/user/xclipboard/APKBUILD
+++ b/user/xclipboard/APKBUILD
@@ -14,7 +14,6 @@ subpackages="$pkgname-doc"
source="https://www.x.org/releases/individual/app/xclipboard-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -26,12 +25,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}