summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-02 18:10:52 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-02 18:10:52 +0000
commit2b10e0a3277c5e5d5d345ff323d9bf4cd0c814ef (patch)
treeb0fe1d17a91bf0c6943a570b2aaff3f60a0fc87a
parent3ecae3f91e160032089607f2c08228c22da278e5 (diff)
downloadpackages-2b10e0a3277c5e5d5d345ff323d9bf4cd0c814ef.tar.gz
packages-2b10e0a3277c5e5d5d345ff323d9bf4cd0c814ef.tar.bz2
packages-2b10e0a3277c5e5d5d345ff323d9bf4cd0c814ef.tar.xz
packages-2b10e0a3277c5e5d5d345ff323d9bf4cd0c814ef.zip
user/*: Modernise / fix syntax
-rw-r--r--user/audiofile/APKBUILD6
-rw-r--r--user/id3lib/APKBUILD3
-rw-r--r--user/libmad/APKBUILD3
3 files changed, 2 insertions, 10 deletions
diff --git a/user/audiofile/APKBUILD b/user/audiofile/APKBUILD
index 4744d3297..66b00d0c7 100644
--- a/user/audiofile/APKBUILD
+++ b/user/audiofile/APKBUILD
@@ -12,7 +12,8 @@ depends_dev="flac-dev"
makedepends="$depends_dev alsa-lib-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="https://audiofile.68k.org/audiofile-$pkgver.tar.gz
- tests-unsigned-gcc6.patch"
+ tests-unsigned-gcc6.patch
+ "
prepare() {
default_prepare
@@ -20,7 +21,6 @@ prepare() {
}
build() {
- cd "$builddir"
export CXXFLAGS="$CXXFLAGS -fpermissive"
./configure \
--build=$CBUILD \
@@ -33,12 +33,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/id3lib/APKBUILD b/user/id3lib/APKBUILD
index 957ed5eb0..78b50ae07 100644
--- a/user/id3lib/APKBUILD
+++ b/user/id3lib/APKBUILD
@@ -28,7 +28,6 @@ prepare() {
}
build() {
- cd "$builddir"
export CFLAGS="$CFLAGS -fPIC"
export CXXFLAGS="$CXXFLAGS -fPIC"
./configure \
@@ -42,12 +41,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/libmad/APKBUILD b/user/libmad/APKBUILD
index 58da6a323..38f6a0deb 100644
--- a/user/libmad/APKBUILD
+++ b/user/libmad/APKBUILD
@@ -20,7 +20,6 @@ source="https://downloads.sourceforge.net/sourceforge/mad/$pkgname-$pkgver.tar.g
"
prepare() {
- cd "$builddir"
update_config_sub
default_prepare
libtoolize --force && aclocal -I m4 && autoconf \
@@ -28,7 +27,6 @@ prepare() {
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -39,7 +37,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -D -m644 "$srcdir"/mad.pc "$pkgdir"/usr/lib/pkgconfig/mad.pc
}