summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKiyoshi Aman <adelie@aerdan.vulpine.house>2020-02-15 12:59:50 -0500
committerKiyoshi Aman <adelie@aerdan.vulpine.house>2020-02-15 12:59:50 -0500
commit2f94cd0ed63ba3f9424310aa2b4cfd41698d2c63 (patch)
treec6c7359ddcb8e188f405892147c9af8c30010105
parentbb80c60d13e7382d403d1bf545a86cb7fa5ae9b9 (diff)
downloadpackages-2f94cd0ed63ba3f9424310aa2b4cfd41698d2c63.tar.gz
packages-2f94cd0ed63ba3f9424310aa2b4cfd41698d2c63.tar.bz2
packages-2f94cd0ed63ba3f9424310aa2b4cfd41698d2c63.tar.xz
packages-2f94cd0ed63ba3f9424310aa2b4cfd41698d2c63.zip
user/mate-sensors-applet: upgrade to 1.24.0
-rw-r--r--user/mate-sensors-applet/APKBUILD8
-rw-r--r--user/mate-sensors-applet/locale-guards.patch29
2 files changed, 34 insertions, 3 deletions
diff --git a/user/mate-sensors-applet/APKBUILD b/user/mate-sensors-applet/APKBUILD
index a74080090..66bdcf6fa 100644
--- a/user/mate-sensors-applet/APKBUILD
+++ b/user/mate-sensors-applet/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
pkgname=mate-sensors-applet
-pkgver=1.22.1
+pkgver=1.24.0
pkgrel=0
pkgdesc="System monitoring applet for the MATE desktop environment"
url="https://mate-desktop.org"
@@ -11,7 +11,8 @@ depends=""
makedepends="gtk+3.0-dev intltool itstool libnotify-dev libxml2-utils libxslt
mate-panel-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://pub.mate-desktop.org/releases/${pkgver%.*}/mate-sensors-applet-$pkgver.tar.xz"
+source="https://pub.mate-desktop.org/releases/${pkgver%.*}/mate-sensors-applet-$pkgver.tar.xz
+ locale-guards.patch"
build() {
./configure \
@@ -32,4 +33,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="4b6e608c92f03051044863f770b295d1526b19a9668513b566e81adeb28bc8524d8f458d114d2b44acf00f20c2f0a8d86b1ca7254fa165fde3b867c75a6b83e6 mate-sensors-applet-1.22.1.tar.xz"
+sha512sums="039834b7cfe641e670e372e311da3d737254ab3cf13b27e71c6555888ac1165766fe2d940bcea44a5ceed5f0ddcd3390d01331d927121137c21a6647c68875c2 mate-sensors-applet-1.24.0.tar.xz
+dd8d0c78ad16e26b6f9cad3283fcd45ce7f5bd4ea16a01ff26cfd060cb26206a07a71c42d90a16cc39fb2e53b890d08b0fc9690b20ff0662c5ff16eab3065265 locale-guards.patch"
diff --git a/user/mate-sensors-applet/locale-guards.patch b/user/mate-sensors-applet/locale-guards.patch
new file mode 100644
index 000000000..d3a35b92b
--- /dev/null
+++ b/user/mate-sensors-applet/locale-guards.patch
@@ -0,0 +1,29 @@
+diff -Nurd mate-sensors-applet-1.24.0/plugins/i2c-proc/i2c-proc-plugin.c mate-sensors-applet-1.24.0.new/plugins/i2c-proc/i2c-proc-plugin.c
+--- mate-sensors-applet-1.24.0/plugins/i2c-proc/i2c-proc-plugin.c 2020-02-10 07:40:35.000000000 -0500
++++ mate-sensors-applet-1.24.0.new/plugins/i2c-proc/i2c-proc-plugin.c 2020-02-15 12:50:42.395405752 -0500
+@@ -144,9 +144,11 @@
+ gchar *old_locale = NULL;
+
+ /* always use C locale */
++#ifdef HAVE_LOCALE_H
+ if (NULL == (old_locale = setlocale(LC_NUMERIC, "C"))) {
+ g_warning("Could not change locale to C locale for reading i2c-proc device files.. will try regardless");
+ }
++#endif
+
+ if (NULL == (fp = fopen(path, "r"))) {
+ g_set_error(error, SENSORS_APPLET_PLUGIN_ERROR, I2C_PROC_DEVICE_FILE_OPEN_ERROR, "Error opening sensor device file %s", path);
+@@ -203,11 +205,11 @@
+ } /* end switch */
+ fclose(fp);
+ }
+-
++#ifdef HAVE_LOCALE_H
+ if (NULL != old_locale) {
+ setlocale(LC_NUMERIC, old_locale);
+ }
+-
++#endif
+ return (gdouble)sensor_value;
+ }
+