summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-08-06 04:07:25 -0500
committerMax Rees <maxcrees@me.com>2019-08-06 04:07:25 -0500
commit3402e15390c449c7e85deae606d5c3baf3b165b5 (patch)
tree6c50ca29ecf6817214dd8b461b40f9664fe6189e
parent32172ae02169797472a276aad55bc700922ea2d4 (diff)
downloadpackages-3402e15390c449c7e85deae606d5c3baf3b165b5.tar.gz
packages-3402e15390c449c7e85deae606d5c3baf3b165b5.tar.bz2
packages-3402e15390c449c7e85deae606d5c3baf3b165b5.tar.xz
packages-3402e15390c449c7e85deae606d5c3baf3b165b5.zip
user/py3-zipp: new package
-rw-r--r--user/py3-zipp/APKBUILD34
-rw-r--r--user/py3-zipp/scm.patch19
2 files changed, 53 insertions, 0 deletions
diff --git a/user/py3-zipp/APKBUILD b/user/py3-zipp/APKBUILD
new file mode 100644
index 000000000..ba2673027
--- /dev/null
+++ b/user/py3-zipp/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+# FIXME: drop after python3 >= 3.8.0
+pkgname=py3-zipp
+_pkgname=zipp
+_p="${_pkgname#?}"
+_p="${_pkgname%"$_p"}"
+pkgver=0.5.2
+pkgrel=0
+pkgdesc="Backport of Python 3.7's zip.Path"
+url="https://pypi.python.org/pypi/zipp"
+arch="noarch"
+# Certified net clean
+license="MIT"
+depends="python3"
+makedepends=""
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz
+ scm.patch"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="8c84b620844315ab1f1aa3c5bb29dcdf1271a0139198b5c3d6aa31ecb9a86f0dcef963819403d971ae0461c737312c064572c57ecf32d73dc973a5f69cf0375c py3-zipp-0.5.2.tar.gz
+7e9061e3ba0e3ded95633f1baa1438f7bb7ea32cecd423001bcbafdfad93aca5bfe0a444035e41b31aeea66b31c86b22854b4f18b2cbbfda356986a2433ca677 scm.patch"
diff --git a/user/py3-zipp/scm.patch b/user/py3-zipp/scm.patch
new file mode 100644
index 000000000..b7d0f690e
--- /dev/null
+++ b/user/py3-zipp/scm.patch
@@ -0,0 +1,19 @@
+--- zipp-0.5.2/setup.cfg 2019-07-07 17:14:00.000000000 -0400
++++ zipp-0.5.2/setup.cfg 2019-08-06 05:03:34.500180967 -0400
+@@ -22,7 +22,7 @@ packages = find:
+ include_package_data = true
+ python_requires = >=2.7
+ install_requires =
+-setup_requires = setuptools_scm >= 1.15.0
++setup_requires =
+
+ [options.extras_require]
+ testing =
+--- zipp-0.5.2/setup.py 2019-07-07 17:13:42.000000000 -0400
++++ zipp-0.5.2/setup.py 2019-08-06 05:03:01.970180844 -0400
+@@ -3,4 +3,4 @@
+ import setuptools
+
+ if __name__ == "__main__":
+- setuptools.setup(use_scm_version=True)
++ setuptools.setup(version='0.5.2')