summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-08-18 21:32:50 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-08-27 18:01:51 -0500
commit3a693d9a9814877562c44a651ab517120d3e6530 (patch)
tree3424127efa229a7822e2d2bcc2991d626c030bf9
parent3519a7ac26ec394231840d3d24af38f9f00efb90 (diff)
downloadpackages-3a693d9a9814877562c44a651ab517120d3e6530.tar.gz
packages-3a693d9a9814877562c44a651ab517120d3e6530.tar.bz2
packages-3a693d9a9814877562c44a651ab517120d3e6530.tar.xz
packages-3a693d9a9814877562c44a651ab517120d3e6530.zip
user/systemd: Fix build-path feature
-rw-r--r--user/systemd/APKBUILD2
-rw-r--r--user/systemd/amalgamation.patch25
2 files changed, 14 insertions, 13 deletions
diff --git a/user/systemd/APKBUILD b/user/systemd/APKBUILD
index 802e45962..857515a4d 100644
--- a/user/systemd/APKBUILD
+++ b/user/systemd/APKBUILD
@@ -36,4 +36,4 @@ package() {
}
sha512sums="40558194e05a17b218adf3d6df48b738c866855d43d09c1e9381c2c568a44a8f1617b64476736fc7e34416ad9e8d25dc023cf9de090b4ef9079866919377009f systemd-256.5.tar.gz
-564a854361ddd4287b44b159e2b6dc9e7fd2f2ed1b84375d20b8b73e3409f5dd3add5ae741f68729d39cba0abf161b4faef7c712bffe7a8a149e0a781f19960e amalgamation.patch"
+9ab17d7ea81556818f473ab54165cc4dd64605cccbce62629f94b2a33a5de3477ccfd4d5c32951e04d068deae374ca7e78053c7806d06a93d3dccc7d14499712 amalgamation.patch"
diff --git a/user/systemd/amalgamation.patch b/user/systemd/amalgamation.patch
index f57c2032c..2771864b3 100644
--- a/user/systemd/amalgamation.patch
+++ b/user/systemd/amalgamation.patch
@@ -652,6 +652,19 @@ index 3ea2c9d09a..e21b609573 100644
#include <linux/if_infiniband.h>
#include <string.h>
+diff --git a/src/basic/build-path.c b/src/basic/build-path.c
+index b5972658df..9c4c6233f7 100644
+--- a/src/basic/build-path.c
++++ b/src/basic/build-path.c
+@@ -157,7 +157,7 @@ int get_build_exec_dir(char **ret) {
+ runpath_cached = get_runpath(&runpath);
+
+ /* We only care if the runpath starts with $ORIGIN/ */
+- if (runpath_cached > 0 && !startswith(runpath, "$ORIGIN/"))
++ //if (runpath_cached > 0 && !startswith(runpath, "$ORIGIN/"))
+ runpath_cached = 0;
+ }
+ if (runpath_cached < 0)
diff --git a/src/basic/constants.h b/src/basic/constants.h
index e70817c51f..cec9c478a2 100644
--- a/src/basic/constants.h
@@ -3458,18 +3471,6 @@ index 7758267b17..3e2c91bfa3 100644
#include "alloc-util.h"
#include "build.h"
-diff --git a/src/test/meson.build b/src/test/meson.build
-index 9d3c7d675f..a0c5c33536 100644
---- a/src/test/meson.build
-+++ b/src/test/meson.build
-@@ -51,7 +51,6 @@ simple_tests += files(
- 'test-bitmap.c',
- 'test-blockdev-util.c',
- 'test-bootspec.c',
-- 'test-build-path.c',
- 'test-bus-util.c',
- 'test-calendarspec.c',
- 'test-cgroup-setup.c',
diff --git a/src/test/test-arphrd-util.c b/src/test/test-arphrd-util.c
index 15b7997750..0007297911 100644
--- a/src/test/test-arphrd-util.c