summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2021-01-27 01:48:38 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2021-01-27 01:48:38 +0000
commit3a72b7aa97facc86a94e2125cf3514d29cc9284a (patch)
tree18d9b40ac9f569b833f2c76d59be0d30fd1ad5f7
parent770475880f5ebd388d6f161570aba713ffc9953d (diff)
downloadpackages-3a72b7aa97facc86a94e2125cf3514d29cc9284a.tar.gz
packages-3a72b7aa97facc86a94e2125cf3514d29cc9284a.tar.bz2
packages-3a72b7aa97facc86a94e2125cf3514d29cc9284a.tar.xz
packages-3a72b7aa97facc86a94e2125cf3514d29cc9284a.zip
system/apk-tools: allow s6-linux-init-common to be installed
-rw-r--r--system/apk-tools/APKBUILD4
-rw-r--r--system/apk-tools/s6-linux-init.patch11
2 files changed, 14 insertions, 1 deletions
diff --git a/system/apk-tools/APKBUILD b/system/apk-tools/APKBUILD
index 5f0683e86..b5609354f 100644
--- a/system/apk-tools/APKBUILD
+++ b/system/apk-tools/APKBUILD
@@ -15,6 +15,7 @@ subpackages="$pkgname-dev $pkgname-static $pkgname-doc"
source="https://dev.sick.bike/dist/$pkgname-v$pkgver+adelie.tar.gz
https://dev.sick.bike/dist/$pkgname-help-v$pkgver.tar.gz
apk.zsh-completion
+ s6-linux-init.patch
"
builddir="$srcdir/$pkgname-v$pkgver"
@@ -72,4 +73,5 @@ static() {
sha512sums="739cbf487a9184aba56c87448d18acebf357b6eddb4852033cc0cd331fc910d425a5d01f7b0bf109f5cd62f78f10cca96ebcbdb4fa00d197edb90726998e1523 apk-tools-v2.12.0+adelie.tar.gz
b8e6e6e9efe2fc3a900e5fea54ed2f047bbf8917c8c3e470e001865c2169167ce6a273869ba577aceb1a1580b7dd684de115a4d92250786958fa13b9e8abf28b apk-tools-help-v2.12.0.tar.gz
-cedda9bf11e0a516c9bf0fd1a239ffa345cdd236419cbd8b10273410610ae7d0f0f61fd36e1e9ccc3bbf32f895508cdca4fb57a0e04f78dd88469b33bf64a32a apk.zsh-completion"
+cedda9bf11e0a516c9bf0fd1a239ffa345cdd236419cbd8b10273410610ae7d0f0f61fd36e1e9ccc3bbf32f895508cdca4fb57a0e04f78dd88469b33bf64a32a apk.zsh-completion
+f92e2e0c062b71e1e5cf95f0d4997166ccc7f7a5e45af8d1650f5951a1d552d89217c8c60d24f31fa626e8e0675c5e882e6b36ef1af8f7624e54627b22801381 s6-linux-init.patch"
diff --git a/system/apk-tools/s6-linux-init.patch b/system/apk-tools/s6-linux-init.patch
new file mode 100644
index 000000000..2dc3db924
--- /dev/null
+++ b/system/apk-tools/s6-linux-init.patch
@@ -0,0 +1,11 @@
+The s6-linux-init-common package has a FIFO which breaks with this.
+--- apk-tools-v2.12.0/src/database.c.old 2020-12-30 02:39:04.000000000 +0000
++++ apk-tools-v2.12.0/src/database.c 2021-01-27 01:47:04.680712750 +0000
+@@ -2592,7 +2592,6 @@
+ apk_warning(PKG_VER_FMT": support for packages without embedded "
+ "checksums will be dropped in apk-tools 3.",
+ PKG_VER_PRINTF(pkg));
+- ipkg->broken_files = 1;
+ ctx->missing_checksum = 1;
+ }
+ break;