summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 01:25:05 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 01:25:05 +0000
commit3ea118af1cd765fc11767538a4724bfa88ee4d14 (patch)
tree20ca87504ef803f47ef99f09347d6d3575a022f8
parente64e8125463de387720322e2fc84e2943811dfdf (diff)
downloadpackages-3ea118af1cd765fc11767538a4724bfa88ee4d14.tar.gz
packages-3ea118af1cd765fc11767538a4724bfa88ee4d14.tar.bz2
packages-3ea118af1cd765fc11767538a4724bfa88ee4d14.tar.xz
packages-3ea118af1cd765fc11767538a4724bfa88ee4d14.zip
system/the rest: modernise, fix metadata
-rw-r--r--system/unzip/APKBUILD5
-rw-r--r--system/utmps/APKBUILD5
-rw-r--r--system/uucp/APKBUILD3
-rw-r--r--system/vim/APKBUILD1
-rw-r--r--system/xmlto/APKBUILD4
-rw-r--r--system/xz/APKBUILD2
-rw-r--r--system/zip/APKBUILD3
-rw-r--r--system/zlib/APKBUILD4
-rw-r--r--system/zstd/APKBUILD2
9 files changed, 4 insertions, 25 deletions
diff --git a/system/unzip/APKBUILD b/system/unzip/APKBUILD
index aad54fa2d..e915966a0 100644
--- a/system/unzip/APKBUILD
+++ b/system/unzip/APKBUILD
@@ -19,8 +19,6 @@ source="$pkgname-$pkgver.tgz::https://distfiles.adelielinux.org/source/$pkgname$
builddir="$srcdir/$pkgname$_pkgver"
build() {
- cd "$builddir"
-
make -f unix/Makefile \
CC="${CHOST}-gcc" \
LOCAL_ZIP="${CFLAGS} ${CPPFLAGS}" \
@@ -28,13 +26,10 @@ build() {
}
check() {
- cd "$builddir"
make -f unix/Makefile check
}
package() {
- cd "$builddir"
-
make -f unix/Makefile \
MANDIR=${pkgdir}/usr/share/man/man1/ \
prefix=${pkgdir}/usr install
diff --git a/system/utmps/APKBUILD b/system/utmps/APKBUILD
index c96899720..eef50c1d8 100644
--- a/system/utmps/APKBUILD
+++ b/system/utmps/APKBUILD
@@ -18,7 +18,6 @@ source="https://skarnet.org/software/$pkgname/$pkgname-$pkgver.tar.gz
wtmpd.run"
build() {
- cd "$builddir"
./configure \
--enable-shared \
--enable-static \
@@ -31,7 +30,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
runimage="$pkgdir/etc/s6-linux-init/current/run-image"
mkdir -p -m 0755 "$runimage/utmps" "$runimage/service/utmpd" "$runimage/service/wtmpd"
@@ -55,6 +53,7 @@ libs() {
dev() {
pkgdesc="$pkgdesc (development files)"
depends="skalibs-dev>=$_skalibs_version"
+ install_if="dev $pkgname=$pkgver-r$pkgrel"
mkdir -p "$subpkgdir/usr"
mv "$pkgdir/usr/lib" "$pkgdir/usr/include" "$subpkgdir/usr/"
}
@@ -70,7 +69,7 @@ libsdev() {
doc() {
pkgdesc="$pkgdesc (documentation)"
- depends=
+ depends=""
install_if="docs $pkgname=$pkgver-r$pkgrel"
mkdir -p "$subpkgdir/usr/share/doc"
cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
diff --git a/system/uucp/APKBUILD b/system/uucp/APKBUILD
index 3106cb083..d17de7902 100644
--- a/system/uucp/APKBUILD
+++ b/system/uucp/APKBUILD
@@ -14,7 +14,6 @@ subpackages="$pkgname-doc"
source="https://ftp.gnu.org/gnu/uucp/uucp-$pkgver.tar.gz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -26,12 +25,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/system/vim/APKBUILD b/system/vim/APKBUILD
index 649938aa4..0e17d805a 100644
--- a/system/vim/APKBUILD
+++ b/system/vim/APKBUILD
@@ -33,7 +33,6 @@ prepare() {
}
build() {
- local _onlynative
[ "$CBUILD" != "$CHOST" ] || _onlynative="--enable-perlinterp=dynamic --enable-python3interp=dynamic"
./configure \
--build=$CBUILD \
diff --git a/system/xmlto/APKBUILD b/system/xmlto/APKBUILD
index cde9e5e58..cbba646f5 100644
--- a/system/xmlto/APKBUILD
+++ b/system/xmlto/APKBUILD
@@ -10,12 +10,10 @@ arch="all"
license="GPL-2.0+"
depends="libxslt perl-yaml-syck perl-test-pod bash docbook-xsl"
makedepends="bash"
-install=""
subpackages="$pkgname-doc"
source="https://releases.pagure.org/xmlto/xmlto-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -26,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
}
diff --git a/system/xz/APKBUILD b/system/xz/APKBUILD
index 253d3194c..71c504ebe 100644
--- a/system/xz/APKBUILD
+++ b/system/xz/APKBUILD
@@ -15,7 +15,6 @@ source="https://tukaani.org/xz/xz-$pkgver.tar.gz
"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -37,7 +36,6 @@ build() {
}
check() {
- cd "$builddir"
make check
}
diff --git a/system/zip/APKBUILD b/system/zip/APKBUILD
index ed060ef03..457dbac28 100644
--- a/system/zip/APKBUILD
+++ b/system/zip/APKBUILD
@@ -15,16 +15,13 @@ source="https://sourceforge.net/projects/infozip/files/Zip%203.x%20%28latest%29/
10-zip-3.0-build.patch
20-zip-3.0-exec-stack.patch
30-zip-3.0-pic.patch"
-
builddir="$srcdir"/${pkgname}30
build() {
- cd "$builddir"
make -f unix/Makefile LOCAL_ZIP="${CFLAGS} ${CPPFLAGS}" prefix=/usr generic
}
package() {
- cd "$builddir"
make -f unix/Makefile prefix=${pkgdir}/usr MANDIR=${pkgdir}/usr/share/man install
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/system/zlib/APKBUILD b/system/zlib/APKBUILD
index 72d63357d..42233e86f 100644
--- a/system/zlib/APKBUILD
+++ b/system/zlib/APKBUILD
@@ -7,11 +7,11 @@ arch="all"
license="Zlib"
url="https://zlib.net"
depends=""
+makedepends=""
subpackages="$pkgname-dev $pkgname-doc"
source="https://zlib.net/$pkgname-$pkgver.tar.gz"
build() {
- cd "$builddir"
CHOST="${CHOST}" ./configure \
--prefix=/usr \
--libdir=/lib \
@@ -20,12 +20,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make install \
pkgconfigdir="/usr/lib/pkgconfig" \
DESTDIR="$pkgdir"
diff --git a/system/zstd/APKBUILD b/system/zstd/APKBUILD
index d14f9a8ed..adc82aec3 100644
--- a/system/zstd/APKBUILD
+++ b/system/zstd/APKBUILD
@@ -8,8 +8,8 @@ url="https://facebook.github.io/zstd/"
arch="all"
license="BSD-3-Clause AND GPL-2.0-only"
depends=""
-makedepends="lz4-dev xz-dev zlib-dev"
checkdepends="file"
+makedepends="lz4-dev xz-dev zlib-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/facebook/zstd/releases/download/v$pkgver/zstd-$pkgver.tar.gz"