summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2025-02-19 15:09:44 +0000
committerZach van Rijn <me@zv.io>2025-02-19 15:21:23 +0000
commit412c6903b2015c07518df5a8b939800415333691 (patch)
treede1756e428d08def3cd12ce273baeab94a850675
parent2b4ad00e99c27baf27669a5441b92975da17c502 (diff)
downloadpackages-412c6903b2015c07518df5a8b939800415333691.tar.gz
packages-412c6903b2015c07518df5a8b939800415333691.tar.bz2
packages-412c6903b2015c07518df5a8b939800415333691.tar.xz
packages-412c6903b2015c07518df5a8b939800415333691.zip
system/openssh: handle 9.8 binary split. fixes #1323.
NOTE: sshd must still be restarted after upgrade. We should do this automatically (future commit). For now, avoid the case where it is always broken.
-rw-r--r--system/openssh/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/system/openssh/APKBUILD b/system/openssh/APKBUILD
index c17e23c4b..3c877c3c8 100644
--- a/system/openssh/APKBUILD
+++ b/system/openssh/APKBUILD
@@ -4,7 +4,7 @@
pkgname=openssh
pkgver=9.9_p2
_myver=${pkgver%_*}${pkgver#*_}
-pkgrel=0
+pkgrel=1
pkgdesc="Remote login tool using encrypted SSH protocol"
url="https://www.openssh.com/portable.html"
arch="all"
@@ -137,8 +137,12 @@ server() {
replaces="openssh-server-common"
install -d "$subpkgdir"/usr/sbin
- install -d "$subpkgdir"/etc/ssh
mv "$pkgdir"/usr/sbin/sshd "$subpkgdir"/usr/sbin/
+
+ install -d "$subpkgdir"/usr/lib/ssh
+ mv "$pkgdir"/usr/lib/ssh/sshd-session "$subpkgdir"/usr/lib/ssh/
+
+ install -d "$subpkgdir"/etc/ssh
mv "$pkgdir"/etc/ssh/sshd_config "$subpkgdir"/etc/ssh/
}