summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-10-23 06:46:24 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-10-23 06:46:24 +0000
commit43c142d94bfe406bfe2fa98e0aa4a7d9a88c444e (patch)
treedb8f487f5deef3959d2ac79088207aca73a32137
parentda164b82c01384917dd9fe1be7325be5edcf7316 (diff)
downloadpackages-43c142d94bfe406bfe2fa98e0aa4a7d9a88c444e.tar.gz
packages-43c142d94bfe406bfe2fa98e0aa4a7d9a88c444e.tar.bz2
packages-43c142d94bfe406bfe2fa98e0aa4a7d9a88c444e.tar.xz
packages-43c142d94bfe406bfe2fa98e0aa4a7d9a88c444e.zip
user/libqalculate: new package
-rw-r--r--user/libqalculate/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/user/libqalculate/APKBUILD b/user/libqalculate/APKBUILD
new file mode 100644
index 000000000..345b10eba
--- /dev/null
+++ b/user/libqalculate/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=libqalculate
+pkgver=2.6.2
+pkgrel=0
+pkgdesc="Library implementing a powerful, versatile desktop calculator"
+url="https://qalculate.github.io/"
+arch="all"
+options="!check" # missing potfiles
+license="GPL-2.0+"
+depends=""
+makedepends="curl-dev gmp-dev icu-dev intltool libxml2-dev mpfr-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang qalc"
+source="https://github.com/Qalculate/libqalculate/releases/download/v$pkgver/libqalculate-$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+qalc() {
+ pkgdesc="Powerful, versatile desktop calculator (terminal UI)"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+sha512sums="cf7acdfba786ec8c3b9c07a89e605b2f021d63d43dde3f36081e54a0a4826f5f2b0bf9092ec69a3a34ae5aca229d1330c84c786dfdf3869bde6e8d07457e8f93 libqalculate-2.6.2.tar.gz"