summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-02-06 17:58:07 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-04-24 20:51:35 -0500
commit49b4f4c950f66ea0994a8053e7202be512e2f20a (patch)
treea41351890053ee0d7beb1f5a94e1ed761e3a9c90
parent8373a840b1318e0756ea835c7e0abf46de5134fb (diff)
downloadpackages-49b4f4c950f66ea0994a8053e7202be512e2f20a.tar.gz
packages-49b4f4c950f66ea0994a8053e7202be512e2f20a.tar.bz2
packages-49b4f4c950f66ea0994a8053e7202be512e2f20a.tar.xz
packages-49b4f4c950f66ea0994a8053e7202be512e2f20a.zip
system/m4: Update to 1.4.19
-rw-r--r--system/m4/APKBUILD16
-rw-r--r--system/m4/disable-mbrtowc-test.patch4
-rw-r--r--system/m4/localename-test-fix.patch34
-rw-r--r--system/m4/m4-1.4.19-test-198.patch31
4 files changed, 41 insertions, 44 deletions
diff --git a/system/m4/APKBUILD b/system/m4/APKBUILD
index a673c7277..7dcd26271 100644
--- a/system/m4/APKBUILD
+++ b/system/m4/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer:
pkgname=m4
-pkgver=1.4.18
-pkgrel=1
+pkgver=1.4.19
+pkgrel=0
pkgdesc="GNU macro processor"
url="https://www.gnu.org/software/m4"
arch="all"
@@ -9,11 +9,11 @@ license="GPL-3.0+"
depends=""
checkdepends="diffutils"
makedepends="texinfo"
-subpackages="m4-doc"
+subpackages="$pkgname-doc $pkgname-lang"
source="https://ftp.gnu.org/gnu/m4/$pkgname-$pkgver.tar.gz
disable-mbrtowc-test.patch
- localename-test-fix.patch
gnulib-tests-dont-require-gpg-passphrase.patch
+ m4-1.4.19-test-198.patch
"
build() {
@@ -34,7 +34,7 @@ package() {
rmdir -p "$pkgdir"/usr/lib 2>/dev/null || true
}
-sha512sums="29254dd4267a093e8d9da3a26df8b02564044cdb4506be539ec1aff4e5d406477bcf32f5e813c840f3aec77293bfe2cdde18f6a21724a7e0bfff646ec88b74ae m4-1.4.18.tar.gz
-78bf099c96fcec8c9cebd4e34f0d7c942e99da2ec238baa9464f8443580edb0565e9026c433ee54fb564304ec8e7e90766e19474472e57b48e567fd7b356777e disable-mbrtowc-test.patch
-fac0cb58e698996284a222c4da340f92689d6db98f1fbab6e61e1c5f2d90122660296f8e5c60c94169413e3e2ee632c6264f12b98e5d3a1e1aae145a2d4aac45 localename-test-fix.patch
-fb7344bc8a7aea1f1ce87474109aaf3d5a5ca0cd86b517025c6aad9a388a9ede7c267e7095d171d8768d1c0f0d9d8009e307467352afa81484c54dc476db0ebd gnulib-tests-dont-require-gpg-passphrase.patch"
+sha512sums="f5dd0f02fcae65a176a16af9a8e1747c26e9440c6c224003ba458d3298b777a75ffb189aee9051fb0c4840b2a48278be4a51d959381af0b1d627570f478c58f2 m4-1.4.19.tar.gz
+c39562852502282f83b9bfa46aff00c8859b19d4d4335dbdb488748b10f6df6a13ea8291784683bf967674a5a824276419af47d2395e8af18823452a8d4999da disable-mbrtowc-test.patch
+fb7344bc8a7aea1f1ce87474109aaf3d5a5ca0cd86b517025c6aad9a388a9ede7c267e7095d171d8768d1c0f0d9d8009e307467352afa81484c54dc476db0ebd gnulib-tests-dont-require-gpg-passphrase.patch
+f409fcfd70d55c099bba7d784bea8f99cd6ccbfe24dfc3d76a2e757df96b6c71f7e4b42f63d433259e3bec7b7e40e6569533c032c98537003a6e7314754dd6fb m4-1.4.19-test-198.patch"
diff --git a/system/m4/disable-mbrtowc-test.patch b/system/m4/disable-mbrtowc-test.patch
index cc2be2478..45b019b9d 100644
--- a/system/m4/disable-mbrtowc-test.patch
+++ b/system/m4/disable-mbrtowc-test.patch
@@ -4,7 +4,7 @@
#!/bin/sh
-# Test whether the POSIX locale has encoding errors.
-LC_ALL=C \
--./test-mbrtowc${EXEEXT} 5 || exit
+-${CHECKER} ./test-mbrtowc${EXEEXT} 5 || exit
-LC_ALL=POSIX \
--./test-mbrtowc${EXEEXT} 5
+-${CHECKER} ./test-mbrtowc${EXEEXT} 5
+exit 77
diff --git a/system/m4/localename-test-fix.patch b/system/m4/localename-test-fix.patch
deleted file mode 100644
index 04584aba6..000000000
--- a/system/m4/localename-test-fix.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- m4-1.4.18/tests/localename.c.old 2016-12-31 13:54:43.000000000 +0000
-+++ m4-1.4.18/tests/localename.c 2017-07-30 16:40:47.098541270 +0000
-@@ -40,7 +40,7 @@
- # if defined __APPLE__ && defined __MACH__
- # include <xlocale.h>
- # endif
--# if __GLIBC__ >= 2 && !defined __UCLIBC__
-+# if defined __linux__
- # include <langinfo.h>
- # endif
- # if !defined IN_LIBINTL
-@@ -2692,16 +2692,19 @@
- locale_t thread_locale = uselocale (NULL);
- if (thread_locale != LC_GLOBAL_LOCALE)
- {
--# if __GLIBC__ >= 2 && !defined __UCLIBC__
-+# if defined(_NL_LOCALE_NAME)
-+ const char *name = nl_langinfo(_NL_LOCALE_NAME(category));
-+# if __GLIBC__ >= 2 && !defined __UCLIBC__
- /* Work around an incorrect definition of the _NL_LOCALE_NAME macro in
- glibc < 2.12.
- See <http://sourceware.org/bugzilla/show_bug.cgi?id=10968>. */
-- const char *name =
-- nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
-+ if (name[0] == '\0')
-+ name = nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
- if (name[0] == '\0')
- /* Fallback code for glibc < 2.4, which did not implement
- nl_langinfo (_NL_LOCALE_NAME (category)). */
- name = thread_locale->__names[category];
-+# endif
- return name;
- # elif defined __FreeBSD__ || (defined __APPLE__ && defined __MACH__)
- /* FreeBSD, Mac OS X */
diff --git a/system/m4/m4-1.4.19-test-198.patch b/system/m4/m4-1.4.19-test-198.patch
new file mode 100644
index 000000000..3ca4bd478
--- /dev/null
+++ b/system/m4/m4-1.4.19-test-198.patch
@@ -0,0 +1,31 @@
+From cd7f4d153ccccf601751e9fa82424412f6ecfc96 Mon Sep 17 00:00:00 2001
+From: Eric Blake <eblake@redhat.com>
+Date: Tue, 1 Jun 2021 08:10:51 -0500
+Subject: [PATCH] tests: Fix 198.sysval
+
+In my attempt to avoid test failures on Haiku, I caused test failures
+on platforms where sh is noisy when reporting a killed sub-process.
+
+* doc/m4.texi (Sysval): Avoid stderr noise during test.
+Fixes: 17011ea76a (tests: Skip signal detection on Haiku)
+Fixes: https://lists.gnu.org/archive/html/bug-m4/2021-05/msg00029.html
+---
+ doc/m4.texi | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/doc/m4.texi b/doc/m4.texi
+index 247f2be5..3b833b2a 100644
+--- a/doc/m4.texi
++++ b/doc/m4.texi
+@@ -6756,6 +6756,7 @@ ifdef(`__unix__', ,
+ ')m4exit(`77')')dnl
+ changequote(`[', `]')
+ @result{}
+-syscmd([/bin/sh -c 'kill -9 $$'; st=$?; test $st = 137 || test $st = 265])
++syscmd([@{ /bin/sh -c 'kill -9 $$'; @} 2>/dev/null; st=$?;
++test $st = 137 || test $st = 265])
+ @result{}
+ ifelse(sysval, [0], , [errprint([ skipping: shell does not send signal 9
+--
+2.17.1
+