summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-11-13 04:43:24 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-11-13 04:43:24 +0000
commit4c868930b9c8af6ff6165b02a0c8cd5423139456 (patch)
treea63e62d68cf75238be05b96005f98803034479a9
parent939576404a1853bf009789059c34288420bfd6ec (diff)
downloadpackages-4c868930b9c8af6ff6165b02a0c8cd5423139456.tar.gz
packages-4c868930b9c8af6ff6165b02a0c8cd5423139456.tar.bz2
packages-4c868930b9c8af6ff6165b02a0c8cd5423139456.tar.xz
packages-4c868930b9c8af6ff6165b02a0c8cd5423139456.zip
system/zsh: add /etc/zprofile.d support
-rw-r--r--system/zsh/APKBUILD6
-rw-r--r--system/zsh/zprofile7
-rw-r--r--system/zsh/zshrc1
3 files changed, 11 insertions, 3 deletions
diff --git a/system/zsh/APKBUILD b/system/zsh/APKBUILD
index 5bc505946..32c86b7df 100644
--- a/system/zsh/APKBUILD
+++ b/system/zsh/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=zsh
pkgver=5.6.2
-pkgrel=0
+pkgrel=1
pkgdesc="A very advanced and programmable command interpreter (shell)"
url="http://www.zsh.org/"
arch="all"
@@ -178,5 +178,5 @@ _submv() {
}
sha512sums="f0a49e41b55eb478692ab5471d7c9828956b7e96bc82944202b0ef1c49a889b21a0e7682aa5f59fd0054ebfd866c2244c8a622e7aa46c13038af5c226c48a3a2 zsh-5.6.2.tar.xz
-cbc184f0c4af1441eaad2a3f7255be9941c64bd5a05977aea5ca3a0a11a3d121c34c1fc9e633465eda087cd196dabf9591082117bbb42cc6e6bc9352ec2c207d zprofile
-cd3a8a6ada8f1ce97a6ca7af5a615092339cde00c20c657d7ce7bf4da57f7a774f2eb5c7d17bdf7e1a12e8b5d0d7878c977d87a0b068c2a869b91cec9ef8d69d zshrc"
+e90723eb790581419498f3ab86fb5d6cab4aaede8c87eb79ead7047d259b643cfb47f4d1beb06d03e038cfda3a20ef9dd4c1b417270ab55c688e166fe30ef4f6 zprofile
+1675e016f97333cad89b587f4292d81b6bc10e27b75482e3e0c3808539c95bd49b907b6579fb98d817f77f2f2384c0df5afa3e2b6f43b6ae9b466925cd9ccffc zshrc"
diff --git a/system/zsh/zprofile b/system/zsh/zprofile
index 363d4863c..50cbdaaaa 100644
--- a/system/zsh/zprofile
+++ b/system/zsh/zprofile
@@ -21,4 +21,11 @@ _src_etc_profile
export EDITOR=${EDITOR:-/usr/bin/vim}
export PAGER=${PAGER:-/usr/bin/less}
+if [ -d /etc/zprofile.d ]; then
+ for i in /etc/zprofile.d/*.zsh; do
+ [ -r $i ] && . $i
+ done
+ unset i
+fi
+
unset -f _src_etc_profile
diff --git a/system/zsh/zshrc b/system/zsh/zshrc
index 11546c289..4deb81e28 100644
--- a/system/zsh/zshrc
+++ b/system/zsh/zshrc
@@ -30,3 +30,4 @@ do_colour() {
}
do_colour
+unset -f do_colour