summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-07-03 02:37:17 -0500
committerZach van Rijn <me@zv.io>2022-10-21 18:34:02 -0500
commit4e4432a15c25582590e9c2279097abd32f519c29 (patch)
treee292417e42bafb29311659b26b733e67afd5ff45
parent96b7dfab1154f36ca20eb13d67a88dd5689030a9 (diff)
downloadpackages-4e4432a15c25582590e9c2279097abd32f519c29.tar.gz
packages-4e4432a15c25582590e9c2279097abd32f519c29.tar.bz2
packages-4e4432a15c25582590e9c2279097abd32f519c29.tar.xz
packages-4e4432a15c25582590e9c2279097abd32f519c29.zip
user/gtk4: New package
-rw-r--r--user/gtk4/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/user/gtk4/APKBUILD b/user/gtk4/APKBUILD
new file mode 100644
index 000000000..a3914da40
--- /dev/null
+++ b/user/gtk4/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
+# Maintainer: Sile Ekaterin Liszka <sheila@vulpine.house>
+pkgname=gtk4
+pkgver=4.6.5
+pkgrel=0
+pkgdesc="Version 4 of the GNOME graphics toolkit"
+url="https://www.gtk.org"
+arch="all"
+options="!check" # Requires X11
+license="LGPL-2.0+ AND LGPL-2.1+ AND LGPL-2.0-only AND Expat"
+depends=""
+makedepends="cairo-dev cmake cups-dev ffmpeg-dev ffmpeg-libs gdk-pixbuf-dev
+ gi-docgen glib-dev gobject-introspection-dev graphene-dev gstreamer-dev
+ gst-plugins-bad-dev iso-codes-dev libepoxy-dev libexecinfo-dev
+ libxcursor-dev libxi-dev libxinerama-dev libxkbcommon-dev libxrandr-dev
+ meson ninja pango-dev>=1.50.0 py3-docutils py3-jinja2 py3-markdown
+ py3-pygments py3-pygobject py3-toml py3-typogrify tiff-dev
+ wayland-dev wayland-protocols"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://download.gnome.org/sources/gtk/${pkgver%.*}/gtk-$pkgver.tar.xz"
+builddir="$srcdir/gtk-$pkgver"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ -Dc_link_args='-lexecinfo' \
+ -Dgtk_doc=true \
+ -Dman-pages=true \
+ -Ddemos=false \
+ -Dbuild-examples=false \
+ build
+ ninja -C build
+}
+
+check() {
+ ninja -C build test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}
+
+sha512sums="a7bf28f6b9f5259fe1333432c205aeb8673f5f32ea0b1878c0724676f148e2d1680fe63ed9594ab5b92120d3497f06cddc5cde428247b3fc876e5785b3dd47ca gtk-4.6.5.tar.xz"
+