summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 08:15:37 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 08:15:37 +0000
commit4ee438300a4076eaf6b8389f0164279f59a6160e (patch)
tree3725ec595df0c6f111d226c0be78826bb3d30fba
parente36d5e759a5f40404e482da9d5d5c571061e4578 (diff)
downloadpackages-4ee438300a4076eaf6b8389f0164279f59a6160e.tar.gz
packages-4ee438300a4076eaf6b8389f0164279f59a6160e.tar.bz2
packages-4ee438300a4076eaf6b8389f0164279f59a6160e.tar.xz
packages-4ee438300a4076eaf6b8389f0164279f59a6160e.zip
system/musl: integrate latest posix-conformance commit
-rw-r--r--system/musl/APKBUILD2
-rw-r--r--system/musl/amalgamation.patch6
2 files changed, 4 insertions, 4 deletions
diff --git a/system/musl/APKBUILD b/system/musl/APKBUILD
index c3ae526d1..ad2bbaf06 100644
--- a/system/musl/APKBUILD
+++ b/system/musl/APKBUILD
@@ -117,7 +117,7 @@ utils() {
}
sha512sums="3976257352ada259fe9baa31bb7d0193765d4e9d6583503543af0122d02fa75e5b5f9e5fee6b6f2550959a389eec3cc45e54eae9ccd08b7d5601c1207d367de1 musl-1.2.0_alpha2.tar.xz
-90cc7d683ea62a6b89f5bf4b782d4d70ee59a0498ad938a78c224b4e1058d45e4a196cf9278e57d7f57e40931072c339a9cbcafb8f0b2a902b485e9c757eec9a amalgamation.patch
+f01ab92b9d385c15369c0bb7d95e1bc06a009c8851e363517d0ba1bae3fc2647af69fc2f363b5d962d376c5d9a1994b5728fd88ccbfff5f0d3d0970a02df1512 amalgamation.patch
88ae443dbb8e0a4368235bdc3a1c5c7b718495afa75e06deb8e01becc76cb1f0d6964589e2204fc749c9c1b3190b8b9ac1ae2c0099cab8e2ce3ec877103d4332 3001-make-real-lastlog-h.patch
6a7ff16d95b5d1be77e0a0fbb245491817db192176496a57b22ab037637d97a185ea0b0d19da687da66c2a2f5578e4343d230f399d49fe377d8f008410974238 handle-aux-at_base.patch
ded41235148930f8cf781538f7d63ecb0c65ea4e8ce792565f3649ee2523592a76b2a166785f0b145fc79f5852fd1fb1729a7a09110b3b8f85cba3912e790807 fgetspent_r.patch
diff --git a/system/musl/amalgamation.patch b/system/musl/amalgamation.patch
index fd77581da..5918c3be6 100644
--- a/system/musl/amalgamation.patch
+++ b/system/musl/amalgamation.patch
@@ -413,7 +413,7 @@ index f407ffe0..4fd3a60c 100644
errno = ENOENT;
return 0;
diff --git a/src/unistd/renameat.c b/src/unistd/renameat.c
-index c3b40a25..e2f03d39 100644
+index c3b40a25..6af5aed6 100644
--- a/src/unistd/renameat.c
+++ b/src/unistd/renameat.c
@@ -1,11 +1,93 @@
@@ -468,8 +468,8 @@ index c3b40a25..e2f03d39 100644
+
+ /* Test equality of old and new.
+ If they both resolve to the same dentry, we do nothing. */
-+ if (fstatat(oldfd, old, &oldstat, 0) == 0 && \
-+ fstatat(newfd, new, &newstat, 0) == 0 && \
++ if (fstatat(oldfd, old, &oldstat, AT_SYMLINK_NOFOLLOW) == 0 && \
++ fstatat(newfd, new, &newstat, AT_SYMLINK_NOFOLLOW) == 0 && \
+ oldstat.st_dev == newstat.st_dev && \
+ oldstat.st_ino == newstat.st_ino) return 0;
+