summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-09-09 04:49:33 -0500
committerKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-09-09 04:49:33 -0500
commit53bef7fd13c68d4362ffed71df76149bd3dc9c3a (patch)
treea3044276ff14365a3a9fbbc90816f477c646b225
parent55a08e768b3ae06bc55b5a8f6057adb30b56f4d2 (diff)
downloadpackages-53bef7fd13c68d4362ffed71df76149bd3dc9c3a.tar.gz
packages-53bef7fd13c68d4362ffed71df76149bd3dc9c3a.tar.bz2
packages-53bef7fd13c68d4362ffed71df76149bd3dc9c3a.tar.xz
packages-53bef7fd13c68d4362ffed71df76149bd3dc9c3a.zip
user/xfce4-cpugraph-plugin: new package
-rw-r--r--user/xfce4-cpugraph-plugin/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/user/xfce4-cpugraph-plugin/APKBUILD b/user/xfce4-cpugraph-plugin/APKBUILD
new file mode 100644
index 000000000..3aef0d879
--- /dev/null
+++ b/user/xfce4-cpugraph-plugin/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce4-cpugraph-plugin
+pkgver=1.0.5
+pkgrel=0
+pkgdesc="Graphical CPU monitor plugin for the XFCE panel"
+url="https://xfce.org"
+arch="all"
+license="GPL-2.0+"
+makedepends="intltool libxfce4ui-dev xfce4-panel-dev"
+subpackages="$pkgname-lang"
+langdir="/usr/lib/locale"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-cpugraph-plugin/1.0/xfce4-cpugraph-plugin-$pkgver.tar.bz2"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ chmod a+w config.sub
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="3d1246958dd30638104f14a8b0078e25c05b67b42da953a97cb51d2b04e70d3f1da9d42ca4f4575b7114bce5abc4cb94d598737631536c0575b55d9a391e210a xfce4-cpugraph-plugin-1.0.5.tar.bz2"