summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-18 21:38:54 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-18 21:38:54 +0000
commit5d070da1a2fe35cc976508c90797eb5105227b06 (patch)
tree0a3d549fbdf1a76ecb2a90a58dbe316dcad4c9de
parent32c38901a3117b823697bdcd7adafec4607912d6 (diff)
downloadpackages-5d070da1a2fe35cc976508c90797eb5105227b06.tar.gz
packages-5d070da1a2fe35cc976508c90797eb5105227b06.tar.bz2
packages-5d070da1a2fe35cc976508c90797eb5105227b06.tar.xz
packages-5d070da1a2fe35cc976508c90797eb5105227b06.zip
user/boost: overhaul
-rw-r--r--user/boost/APKBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/user/boost/APKBUILD b/user/boost/APKBUILD
index e979993d8..5c836d68a 100644
--- a/user/boost/APKBUILD
+++ b/user/boost/APKBUILD
@@ -11,7 +11,7 @@ license="BSL-1.0"
options="!check" # No test suite.
depends=""
depends_dev="linux-headers"
-makedepends="$depends_dev python3-dev flex bison bzip2-dev zlib-dev"
+makedepends="$depends_dev byacc bzip2-dev flex python3-dev xz-dev zstd-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/${pkgname}_$_pkgver.tar.bz2
boost-1.57.0-python-abi_letters.patch
@@ -19,7 +19,14 @@ source="http://downloads.sourceforge.net/$pkgname/${pkgname}_$_pkgver.tar.bz2
"
builddir="$srcdir/${pkgname}_${_pkgver}"
-_libs="date_time
+_libs="
+ atomic
+ chrono
+ container
+ contract
+ coroutine
+ date_time
+ fiber
filesystem
graph
iostreams
@@ -66,20 +73,21 @@ esac
_enginedir=tools/build/src/engine
_bjam="${builddir}/$_enginedir/bin.linux${_boostarch}/bjam"
[ "$_boostarch" = "s390" ] && _bjam="${builddir}/$_enginedir/bin.linux390/bjam" && \
- _options_s390="--without-context --without-coroutine --without-coroutine2"
+ _options_s390="--without-coroutine --without-coroutine2"
+# context is broken on at least s390 and sparc
_options="--user-config=\"$builddir/user-config.jam\"
--prefix=\"$pkgdir/usr\"
release
debug-symbols=off
- threading=single,multi
runtime-link=shared
link=shared,static
cflags=-fno-strict-aliasing
-sPYTHON_ROOT=/usr
-sTOOLS=gcc
- --layout=tagged
+ --layout=system
-q
+ --without-context
-j${JOBS:-2}
${_options_s390}
"