summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2020-04-29 12:21:14 -0500
committerMax Rees <maxcrees@me.com>2020-04-29 12:21:14 -0500
commit5df19234b438dd8d1d876033a8987e563c033c1a (patch)
tree34461b33228e653ffd1aeaae930711a19f7db759
parentf58efe23e016a57672e127d949784f408c0d470c (diff)
downloadpackages-5df19234b438dd8d1d876033a8987e563c033c1a.tar.gz
packages-5df19234b438dd8d1d876033a8987e563c033c1a.tar.bz2
packages-5df19234b438dd8d1d876033a8987e563c033c1a.tar.xz
packages-5df19234b438dd8d1d876033a8987e563c033c1a.zip
user/tcpdump: remove old patch for CVE-2018-19519
This was fixed upstream in a different way, but the patch was still being applied with some fuzz. https://github.com/the-tcpdump-group/tcpdump/commit/511915bef7e4de2f31b8d9f581b4a44b0cfbcf53
-rw-r--r--user/tcpdump/APKBUILD9
-rw-r--r--user/tcpdump/CVE-2018-19519.patch10
2 files changed, 3 insertions, 16 deletions
diff --git a/user/tcpdump/APKBUILD b/user/tcpdump/APKBUILD
index f39d5c9d5..d2d2ec909 100644
--- a/user/tcpdump/APKBUILD
+++ b/user/tcpdump/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=tcpdump
pkgver=4.9.3
-pkgrel=0
+pkgrel=1
pkgdesc="A tool for network monitoring and data acquisition"
url="http://www.tcpdump.org"
arch="all"
@@ -10,9 +10,7 @@ license="BSD-3-Clause"
depends=""
makedepends="libpcap-dev openssl-dev perl"
subpackages="$pkgname-doc"
-source="http://www.tcpdump.org/release/$pkgname-$pkgver.tar.gz
- CVE-2018-19519.patch
- "
+source="http://www.tcpdump.org/release/$pkgname-$pkgver.tar.gz"
# secfixes:
# 4.9.2-r1:
@@ -67,5 +65,4 @@ package() {
rm -f "$pkgdir"/usr/sbin/tcpdump.4*
}
-sha512sums="3aec673f78b996a4df884b1240e5d0a26a2ca81ee7aca8a2e6d50255bb53476e008a5ced4409e278a956710d8a4d31d85bbb800c9f1aab92b0b1046b59292a22 tcpdump-4.9.3.tar.gz
-eb4232e434064ec59b07840aa394cfcc05c89e817f2d4ebeb4da1dbb1c910fe1805857356d6304ebdb16e32aa6476ce90f164aabc60501b493fd5601b380af7e CVE-2018-19519.patch"
+sha512sums="3aec673f78b996a4df884b1240e5d0a26a2ca81ee7aca8a2e6d50255bb53476e008a5ced4409e278a956710d8a4d31d85bbb800c9f1aab92b0b1046b59292a22 tcpdump-4.9.3.tar.gz"
diff --git a/user/tcpdump/CVE-2018-19519.patch b/user/tcpdump/CVE-2018-19519.patch
deleted file mode 100644
index ac3293927..000000000
--- a/user/tcpdump/CVE-2018-19519.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- tcpdump-4.9.2/print-hncp.c.old 2017-09-03 23:17:14.000000000 +0000
-+++ tcpdump-4.9.2/print-hncp.c 2018-12-07 19:31:24.360000000 +0000
-@@ -228,6 +228,7 @@
- snprintf(buf, sizeof(buf), "%s/%d", ipaddr_string(ndo, &addr), plen);
- plenbytes += 1 + IPV4_MAPPED_HEADING_LEN;
- } else {
-+ buf[0] = '\0';
- plenbytes = decode_prefix6(ndo, prefix, max_length, buf, sizeof(buf));
- }
-