summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorst Burkhardt <horst@adelielinux.org>2024-12-06 14:56:59 +1100
committerHorst Burkhardt <horst@adelielinux.org>2024-12-06 14:56:59 +1100
commit64d6f83100072cf993005bfe052850011e692d0c (patch)
tree95941f1b97016dd68ee326ba2f4867ae06511ce3
parent8013ad410c77fc2e2f07ed67bec642b25f6f569c (diff)
downloadpackages-64d6f83100072cf993005bfe052850011e692d0c.tar.gz
packages-64d6f83100072cf993005bfe052850011e692d0c.tar.bz2
packages-64d6f83100072cf993005bfe052850011e692d0c.tar.xz
packages-64d6f83100072cf993005bfe052850011e692d0c.zip
bootstrap/ecj-3.2: would you believe I forgot how to actually build ecj? I wouldn't have.
Signed-off-by: Horst Burkhardt <horst@adelielinux.org>
-rw-r--r--bootstrap/ecj-3.2/APKBUILD36
1 files changed, 16 insertions, 20 deletions
diff --git a/bootstrap/ecj-3.2/APKBUILD b/bootstrap/ecj-3.2/APKBUILD
index e0c57ff39..ec7c38000 100644
--- a/bootstrap/ecj-3.2/APKBUILD
+++ b/bootstrap/ecj-3.2/APKBUILD
@@ -11,32 +11,28 @@ depends="jamvm=1.5.1-r0"
makedepends="ant=1.8.4-r0 zip"
subpackages="$pkgname-dev"
source="https://archive.eclipse.org/eclipse/downloads/drops/R-$pkgver-200702121330/eclipse-sourceBuild-srcIncluded-$pkgver.zip
- "
+build-niceties.patch"
-prepare() {
- rm -v lib/classes.zip
- default_prepare
- autoreconf -vif
- }
+unpack() {
+ unpack eclipse-sourceBuild-srcIncluded-"$pkgver".zip
+ mv jdtcoresrc ecj-3.2.2
+ cd ecj-3.2.2
+ unzip -d src -q src/ecj.jar
+ }
build() {
export JAVAC="/usr/bin/jikes"
- ./configure \
- --enable-ffi \
- --disable-int-caching \
- --enable-runtime-reloc-checks \
- --prefix=/usr/$pkgname \
- --datadir=/usr/share \
- --bindir=/usr/bin \
- --with-classpath-install-dir=/usr
- make
+ ant "-Dbuild.compiler=jikes" -f compilejdtcorewithjavac.xml
+ ant "-Dnoget=true -Dmaven.mode.offline=true -Dbuild.sysclasspath=ignore" -lib ecj.jar -f compilejdtcore.xml compile
}
package() {
- make DESTDIR="$pkgdir" install
- ln -s jamvm "$pkgdir"/usr/bin/java
- ln -s jikes "$pkgdir"/usr/bin/javac
- ln -s fastjar "$pkgdir"/usr/bin/jar
+ cp -v dist/ecj.jar "$pkgdir"/usr/libexec/ecj-3.2.jar
+ echo "#!/bin/sh" > "$pkgdir"/usr/bin/ecj-3.2
+ chmod a+x "$pkgdir"/usr/bin/ecj-3.2
+ echo "# Wrapper for ECJ 3.2" >> "$pkgdir"/usr/bin/ecj-3.2
+ echo "exec jamvm -cp /usr/share/classpath -jar /usr/libexec/ecj-3.2.jar \"\${@}\"" >> "$pkgdir"/usr/bin/ecj-3.2
}
-sha512sums="74a7e66f4411e1856d35c396ffb12124ac5ad622e5cb401558b24aa675d158efbc1522534e962786adf6ae8ff328d394f25f8f28d6b6a9e5531bc4abf241c8f3 eclipse-sourceBuild-srcIncluded-3.2.2.zip"
+sha512sums="74a7e66f4411e1856d35c396ffb12124ac5ad622e5cb401558b24aa675d158efbc1522534e962786adf6ae8ff328d394f25f8f28d6b6a9e5531bc4abf241c8f3 eclipse-sourceBuild-srcIncluded-3.2.2.zip
+cc393c37b693b36a7715e2e3f2fa8e87fe9697e9846da60c4c950bc5be8202e12566aec87b458f706f1bbdd6ea5dfe7f7e92c66fb87ec54f74ea004d12ac4221 build-niceties.patch"