summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-12-17 05:55:08 -0600
committerKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-12-17 05:55:08 -0600
commit661357bacd35ea3f5a2b4da314ab11773a441108 (patch)
treeecb7c2ffccc14a4adef2a8deb7f385b2bfb5183c
parentfc2ad9b7f1712c4b153d9399604e557e89d7bef0 (diff)
downloadpackages-661357bacd35ea3f5a2b4da314ab11773a441108.tar.gz
packages-661357bacd35ea3f5a2b4da314ab11773a441108.tar.bz2
packages-661357bacd35ea3f5a2b4da314ab11773a441108.tar.xz
packages-661357bacd35ea3f5a2b4da314ab11773a441108.zip
user/aspell-dict-ny: new package
-rw-r--r--user/aspell-dict-ny/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/user/aspell-dict-ny/APKBUILD b/user/aspell-dict-ny/APKBUILD
new file mode 100644
index 000000000..258dcd0a7
--- /dev/null
+++ b/user/aspell-dict-ny/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=aspell-dict-ny
+pkgver=0.01.0
+_pkgver=${pkgver%.*}-${pkgver#*.*.}
+pkgrel=0
+pkgdesc="Chichewa dictionaries for aspell"
+url="http://aspell.net"
+arch="noarch"
+options="!check" # no tests
+license="GPL-2.0-only"
+depends="aspell"
+makedepends="debianutils-which"
+source="ftp://ftp.gnu.org/gnu/aspell/dict/ny/aspell5-ny-$_pkgver.tar.bz2"
+builddir="$srcdir/aspell5-ny-$_pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --vars DESTDIR="$pkgdir"
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="52f4526d605a2f0577217af1dc8e44da20484fe7f725ceee1f8fdf9ba0fc1457910d55567ea9287465cbf37955af9a11b2caba084cece59aec29755cb147cb05 aspell5-ny-0.01-0.tar.bz2"