summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-05-22 22:00:42 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-05-22 22:00:42 -0500
commit6634ad60df3ccfadce5c8fa4ecdda7ac8ec1c012 (patch)
tree0cdf25f21a8e19d2d5880515acd54ab6f21f5b42
parent3d40bdfba5dc21e3f0f3ee710d5c9c73e500620c (diff)
downloadpackages-6634ad60df3ccfadce5c8fa4ecdda7ac8ec1c012.tar.gz
packages-6634ad60df3ccfadce5c8fa4ecdda7ac8ec1c012.tar.bz2
packages-6634ad60df3ccfadce5c8fa4ecdda7ac8ec1c012.tar.xz
packages-6634ad60df3ccfadce5c8fa4ecdda7ac8ec1c012.zip
system/abuild: add patches to make newapkbuild work at all
-rw-r--r--system/abuild/0001-newapkbuild-fix-typo.patch25
-rw-r--r--system/abuild/0002-newapkbuild-move-checksum-call-to-after-fetch.patch40
-rw-r--r--system/abuild/APKBUILD8
3 files changed, 71 insertions, 2 deletions
diff --git a/system/abuild/0001-newapkbuild-fix-typo.patch b/system/abuild/0001-newapkbuild-fix-typo.patch
new file mode 100644
index 000000000..9df4f8526
--- /dev/null
+++ b/system/abuild/0001-newapkbuild-fix-typo.patch
@@ -0,0 +1,25 @@
+From 15299d6c47c3a0fdd0091691ad3461680f1cadff Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Tue, 22 May 2018 21:50:06 -0500
+Subject: [PATCH 1/2] newapkbuild: fix typo
+
+---
+ newapkbuild.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/newapkbuild.in b/newapkbuild.in
+index 541f261..1a005c3 100644
+--- a/newapkbuild.in
++++ b/newapkbuild.in
+@@ -170,7 +170,7 @@ newaport() {
+ pkgname=$pn
+ fi
+ if [ -e "$pkgname"/APKBUILD ] && [ -z "$force" ]; then
+- error "$pkgname/APKBUILD already exist"
++ error "$pkgname/APKBUILD already exists"
+ return 1
+ fi
+ mkdir -p "$pkgname"
+--
+2.15.0
+
diff --git a/system/abuild/0002-newapkbuild-move-checksum-call-to-after-fetch.patch b/system/abuild/0002-newapkbuild-move-checksum-call-to-after-fetch.patch
new file mode 100644
index 000000000..338aff758
--- /dev/null
+++ b/system/abuild/0002-newapkbuild-move-checksum-call-to-after-fetch.patch
@@ -0,0 +1,40 @@
+From d3040cca076e187259e4aa4b1d613752d7254fcd Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Tue, 22 May 2018 21:50:55 -0500
+Subject: [PATCH 2/2] newapkbuild: move checksum call to after fetch
+
+unpack will no longer unpack without a checksum, even with -f. This
+means that newapkbuild will not be able to deduce what kind of build
+system is contained within, so the templates for CMake, Perl, etc are
+never used.
+
+This patch ensures checksumming is done right after fetch, so that
+unpack works properly.
+---
+ newapkbuild.in | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/newapkbuild.in b/newapkbuild.in
+index 1a005c3..77d1a8b 100644
+--- a/newapkbuild.in
++++ b/newapkbuild.in
+@@ -228,7 +228,7 @@ subpackages="\$pkgname-dev \$pkgname-doc"
+ source="$source"
+ __EOF__
+
+- abuild -f fetch unpack
++ abuild -f fetch checksum unpack
+ # Figure out the builddir
+ for i in src/*; do
+ if [ -d "$i" ]; then
+@@ -339,7 +339,6 @@ __EOF__
+ }
+
+ __EOF__
+- abuild -f checksum
+ }
+
+ usage() {
+--
+2.15.0
+
diff --git a/system/abuild/APKBUILD b/system/abuild/APKBUILD
index 98e34f201..9705e141e 100644
--- a/system/abuild/APKBUILD
+++ b/system/abuild/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=abuild
pkgver=3.2.0_rc1
-pkgrel=1
+pkgrel=2
pkgdesc="Script to build APK packages"
url="https://code.foxkit.us/adelie/aports"
arch="all"
@@ -21,6 +21,8 @@ options="suid !check"
pkggroups="abuild"
source="https://distfiles.adelielinux.org/source/abuild-$pkgver+adelie.tar.xz
0001-abuild-continue-faking-POSIX-support-for-now.patch
+ 0001-newapkbuild-fix-typo.patch
+ 0002-newapkbuild-move-checksum-call-to-after-fetch.patch
"
builddir="$srcdir/$pkgname-$pkgver+adelie"
@@ -68,4 +70,6 @@ _rootbld() {
}
sha512sums="8d9e66ec6a4e814f9be0a10b53c4b183afa97c9969d9bb86fdec0b9096756d6343cec4840fb61a5812eb4879e61c106adbdd286e63d9cfc4f8b66b6cad79557b abuild-3.2.0_rc1+adelie.tar.xz
-b7aa7ff9858eee2ff20eeed3b8da60d40e608b4da2676acb9c8b16ca6639283e5d70884888efd505fcd239bb462f726203e4773a4f706b16d07742b2a8631b6c 0001-abuild-continue-faking-POSIX-support-for-now.patch"
+b7aa7ff9858eee2ff20eeed3b8da60d40e608b4da2676acb9c8b16ca6639283e5d70884888efd505fcd239bb462f726203e4773a4f706b16d07742b2a8631b6c 0001-abuild-continue-faking-POSIX-support-for-now.patch
+4ef673998b8f28469eeb4d1448a664f7052686466a67b1a3f3cab1e249ad44308df92737da4eae3c3ffea06806f460e23fc1c0ddccd7f9e82c4e308cb63be029 0001-newapkbuild-fix-typo.patch
+c6ebe8219c2e8ec9fc75da1c597b2d8d960e632286a6c7f1d1ffb6623b4d4acca54ae90a6c07637c589cbbe3ed2fb0da0c26a41df20cac0318b4894991e2dbf4 0002-newapkbuild-move-checksum-call-to-after-fetch.patch"