summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Theisen <djt@hxx.in>2018-09-26 00:45:13 -0700
committerDan Theisen <djt@hxx.in>2018-09-26 00:45:13 -0700
commit698f4ca03523b4ae7ea3e96b6ba1bd69e3da25ee (patch)
tree94b98f77341decc3b3b7cc6b1522f3f3df212f0f
parentaf17de0d89834d615db6d510a2dcaf74c59598ef (diff)
downloadpackages-698f4ca03523b4ae7ea3e96b6ba1bd69e3da25ee.tar.gz
packages-698f4ca03523b4ae7ea3e96b6ba1bd69e3da25ee.tar.bz2
packages-698f4ca03523b4ae7ea3e96b6ba1bd69e3da25ee.tar.xz
packages-698f4ca03523b4ae7ea3e96b6ba1bd69e3da25ee.zip
user/perl-file-sharedir-install: new package
-rw-r--r--user/perl-file-sharedir-install/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/perl-file-sharedir-install/APKBUILD b/user/perl-file-sharedir-install/APKBUILD
new file mode 100644
index 000000000..f2b567b5e
--- /dev/null
+++ b/user/perl-file-sharedir-install/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Dan Theisen <djt@hxx.in>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-file-sharedir-install
+pkgver=0.13
+pkgrel=0
+pkgdesc="Install shared files"
+url="https://metacpan.org/pod/File::ShareDir::Install"
+arch="noarch"
+license="GPL-1.0+ OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/E/ET/ETHER/File-ShareDir-Install-$pkgver.tar.gz"
+builddir="$srcdir/File-ShareDir-Install-$pkgver"
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="a119e38491fad8ae0ebd95913e3b608e09a2b99376a5160e75083a28abe4f83c4f6a36df216365527ff87bf8ec095254b16a2f6d2515c69f34609df8672605ca File-ShareDir-Install-0.13.tar.gz"